Engine help 2.5l - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-24-2010, 11:31 AM   #1
Jeeper
 
Join Date: Mar 2010
Location: Bastrop LA
Posts: 26
Engine help 2.5l

I have an 87 yj with the 2.5l spring over lift and 31 tires for now. When I got it it ran like crap flooding and such. I found some info on the renix system and figured out that the iat sensor was open. I replaced that and did some vacuum repairs and it ran great. It got to where it would be very hard to crank first thing in the morning and the it would crank fine for the rest of the day after initial start till one day no start. Crank sensor was bad. It is showing 198000 on the speedo but has evidence of being towed by a motor home or something. I know thats a lot of info but trying to give as much background as possible. Now my problem is that I can run down the road and it runs GREAT at times and at others it bucks and snorts and runs like crap with no reason or rhyme. I was wonderin if there is any way to run a basic distributor and carb on the 2.5 to get rid of the almost impossible to diagnose intermitent renix system.... Thanks in advance Scott

fireman_033 is offline   Quote Quick Reply
Old 12-24-2010, 02:22 PM   #2
Jeeper
 
Join Date: Nov 2010
Location: virginia
Posts: 241
i would try the throttle position sensor, but thats just me.

sppfields is offline   Quote Quick Reply
Old 12-24-2010, 02:27 PM   #3
Jeeper
 
Join Date: Mar 2010
Location: Bastrop LA
Posts: 26
I am thinkin tps or O2 but just hate throwin parts at it and the problem is intermittent. I can be drivin and feel a light sputter sometimes and even hear a difference in the idle sometimes, and some times it feels like you are turning the key off and on really quick.
fireman_033 is offline   Quote Quick Reply
Old 12-24-2010, 02:30 PM   #4
jr.
Jeeper
 
jr.'s Avatar
 
Join Date: Dec 2009
Location: marquette heights,ill.
Posts: 513
Quote:
Originally Posted by sppfields View Post
i would try the throttle position sensor, but thats just me.
i think i would try the tps too
__________________
"Outside of a dog, a book is a man's best friend. Inside of a dog, it is too dark to read."
-- Groucho Marx





95 yj
91 f-150 4x4
75 shovel hardtail
jr. is offline   Quote Quick Reply
Old 01-04-2011, 10:42 AM   #5
Newb
 
Join Date: Jan 2009
Location: Costa Rica
Posts: 9
Send a message via MSN to Xytras6
Check the TPS, distribuitor, rotor and the spark plug cables.... It worked for me !
Xytras6 is offline   Quote Quick Reply
Old 01-05-2011, 11:18 AM   #6
Jeeper
 
Join Date: Jan 2011
Location: Western, NC
Posts: 55
My fuel filter was clogged up once and mine was bucking, did fine till it got to 1/4 throttle then started bucking, it was a inline filter mounted on the frame but im not sure if it was factory or not, I changed the clogged filter and the jeep ran better than it ever had.

resq229 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine knock and rough idle help rumpleskins TJ Tech Forum 5 12-26-2010 04:54 PM
engine swap, ecu died, can not start! lodmccloud TJ Tech Forum 7 03-16-2010 07:29 PM
Engine Swap 2.5L to 4.0L TideWrangler General Jeep Discussion 2 02-26-2010 05:02 PM
05 blown engine tinworm TJ General Discussion Forum 10 10-27-2009 11:58 AM
95 YJ 2.5L 4 cylinder, engine knocking cowboy724 YJ General Discussion Forum 6 03-12-2006 10:42 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC