engine miss - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-10-2008, 03:25 PM   #1
Newb
 
BossYJHawg's Avatar
 
Join Date: Oct 2008
Posts: 5
Unhappy engine miss

I have a 95 Rio Grande with a problem I can't get rid of. I just rolled over 183k and I have a engine miss. I've replaced O2 sensor, new sparks, coil, distributor, cut the cat conv. off, new exhaust....and it is still missing. Seems to be between 2000 and 3000rpm and usually in 4th gear....any ideas or suggestions what I should check next?

BossYJHawg is offline   Quote Quick Reply
Old 12-10-2008, 05:26 PM   #2
Newb
 
BossYJHawg's Avatar
 
Join Date: Oct 2008
Posts: 5
Also to add to this I seem to have a knocking sound coming from the drivers front...I replaced the tie rod end that was worn...still have the noise. Seems to be when I go over bumps @slow speeds.

BossYJHawg is offline   Quote Quick Reply
Old 12-10-2008, 05:39 PM   #3
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
one thing missing in your list is spark plug wires, don't overlook those. clunkin noise, check for dead shock, and broken sway bar link, or worn sway bar bushing.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 12-10-2008, 05:46 PM   #4
Newb
 
BossYJHawg's Avatar
 
Join Date: Oct 2008
Posts: 5
oh yea i left those out, i did replace the wires one had a pretty big gash in it...i was double checking to make sure all my hoses were tight and decided to look at the air filter and there was oil on it?! it is a stock air box and filter...not sure what is going on. i will def check what you mentioned above for the knocking sound soon as i get off work tommorow. thank you!
BossYJHawg is offline   Quote Quick Reply
Old 12-10-2008, 08:25 PM   #5
Hacks off Parts while Lit
 
whitebuffalo's Avatar
 
Join Date: May 2005
Location: The Sandhills of South Texas
Posts: 2,290
have you checked for vacuum leaks? they could cause a miss and oily filter like you mention
__________________
'90 YJ, ford 8.8, SOA, lincoln front, aussie rear, 4.88s, swampers.
whitebuffalo is offline   Quote Quick Reply
Old 12-10-2008, 09:57 PM   #6
Really?

WF Lifetime Member
 
ccain's Avatar
 
Join Date: Feb 2007
Location: SoCal
Posts: 6,453
Images: 9
Quote:
Originally Posted by whitebuffalo View Post
have you checked for vacuum leaks? they could cause a miss and oily filter like you mention
Agreed! I had one hell of a time chasing around vacuum leaks. All those stupid plastic lines were rotten and brittle. And they freakin' run everywhere! You'll have to pull apart the loom of wires and everything. My suggestion is to go ahead and replace all of them if you find ANY broken. It'll save you time and aggravation and beer! You'll probably want to check your intake/exhaust manifold gasket and your throttle body gasket. Good luck!
ccain is offline   Quote Quick Reply
Old 12-11-2008, 01:17 PM   #7
Newb
 
BossYJHawg's Avatar
 
Join Date: Oct 2008
Posts: 5
thanks guys....guess ima need a case of beer for this one...this will def keep me busy this weekend...i'll post when i find something out.
BossYJHawg is offline   Quote Quick Reply
Old 12-11-2008, 03:05 PM   #8
Jeeper
 
chasm's Avatar
 
Join Date: Oct 2006
Location: Pennsylvania
Posts: 180
Check the O-rings on the fuel injectors. They go bad with age. One bad one can make a difference!

__________________
1951 CJ3A Universal: "Garage Queen"
1983 CJ8 Scrambler: "Project"
1993 YJ Wrangler: "Wheeler"
2008 JK Rubicon "Locked & Loaded"
chasm is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 04:47 PM
D35 strength?? GrnTJ TJ Tech Forum 37 07-31-2013 01:47 PM
more juice 95_YJ YJ Tech Forum 8 09-08-2009 12:52 PM
Engine knock nvr-enough YJ Tech Forum 20 07-20-2008 01:10 AM
Couple engine questions jcarlos YJ Tech Forum 3 06-07-2008 03:00 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:00 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC