engine needs help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-21-2010, 10:06 PM   #1
Newb
 
Join Date: Apr 2010
Posts: 3
engine needs help

My wrangler yj is running poorly until I cover the air intake ( air filter) so when I starve the air flow it seems to run fine??????

gibfuncenter is offline   Quote Quick Reply
Old 04-21-2010, 11:10 PM   #2
Jeeper
 
flash19901's Avatar
 
Join Date: Apr 2010
Location: Milton, Delaware
Posts: 78
Wanna make us grin from ear to ear? Please provide make, model and year. And engine and other pertinient info as well.

__________________
Thank you.
ChrisW

Wubba, wubba, wubba. Bing, bang, bong. Yuck, yuck, yuck and a fiddle-dee-dee. - The Yeti

Husband and father of two, ASE Certified auto parts salesman and 4x5 film photographer extraordinaire.
flash19901 is offline   Quote Quick Reply
Old 04-21-2010, 11:43 PM   #3
Jeeper
 
tlrrob1000's Avatar
 
Join Date: Jul 2009
Location: Pain is a gift...Fear is not an option!
Posts: 786
Images: 23
Quote:
Originally Posted by flash19901 View Post
Wanna make us grin from ear to ear? Please provide make, model and year. And engine and other pertinient info as well.
Wow!
I won't be a smarta@!. We are here to help and not flame anyone. Although after you have been here a while you may get ribbed a bit here and there. Enjoy and welcome.
Sounds like you are running lean. I figure you have the 4.2 carbed? We do however need to know what year and what motor you have. Does this only happen when its cold? Operating temp.? All the time?
__________________
No Bad Days!
tlrrob1000 is offline   Quote Quick Reply
Old 04-22-2010, 11:26 AM   #4
Founder, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,952
if you changed something to cause this problem, change it back.

If it just "started happening" then something is wearing out. Plugs, wires, cap/rotor, fuel filter, etc.. or something is loose. A loose park plug will lose compresssion and have this same symptom. Same with a loose plug wire causing it to only run on 4-5 cylinders instead of all 6.

Id say, tune up time...
__________________
-Chris
Founder, ThumbJeeps


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Old 04-22-2010, 03:04 PM   #5
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
I would guess a vacuum leak, check your hoses
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 04-24-2010, 08:58 PM   #6
Newb
 
Join Date: Apr 2010
Posts: 3
Sorry 1994 wrangler 2.5l this jeep has been sitting for over a year, I changed plugs, fuel filter. So heres what it does starts ok but when you rev engine seems to not get good power so when I block the airintake to filter all the power comes back
gibfuncenter is offline   Quote Quick Reply
Old 04-24-2010, 09:15 PM   #7
Jeeper
 
crtaylor's Avatar
 
Join Date: Sep 2009
Location: Beaver Falls,PA
Posts: 1,055
Sitting for a year .check all vac lines,Try some Lucas fuel stabilizer,Put some fresh gas in it.

crtaylor is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 05:47 PM
engine swap, ecu died, can not start! lodmccloud TJ Tech Forum 7 03-16-2010 07:29 PM
05 blown engine tinworm TJ General Discussion Forum 10 10-27-2009 11:58 AM
Mounting engine mount brackets... 1992wranglersahara YJ Tech Forum 3 06-02-2009 08:40 PM
New to forum, engine install time deaglementor YJ Tech Forum 7 05-08-2009 12:14 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC