Engine not shutting down - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-06-2014, 05:27 AM   #1
Jeeper
 
KennPilot's Avatar
 
Join Date: Jun 2013
Posts: 24
Engine not shutting down

1987 YJ - no computer. Ignition switch does not shut the engine off. When I turn the key from run to off all other electrical components turn off (radio, electric fan, etc..) but the engine itself just keeps running. The switch itself was replaced about 3 months ago. Since it does seem to cut power everywhere but to the engine I'm at a bit of a loss as I would think if the switch was bad that it wouldn't cut off power to anything.

Any help would be greatly appreciated.

KennPilot is offline   Quote Quick Reply
Old 06-06-2014, 05:59 AM   #2
Jeeper
 
Jkilbert's Avatar
 
Join Date: Aug 2013
Location: McKeesport,Pa
Posts: 199
Send a message via Yahoo to Jkilbert
Switch could still be bad.

__________________
1992 Wrangler 2.5l 5spd.
Yes it's a money pit, but it's my money pit.
Jkilbert is offline   Quote Quick Reply
Old 06-06-2014, 01:33 PM   #3
Jeeper
 
MkUltraOps's Avatar
 
Join Date: Aug 2012
Location: Snohomish, wa
Posts: 374
trace wires if you know how...sounds like maybe a short in the switch that allows current to flow to the computer, but that would be a wild guess...somehow its getting current to the components that keep your engine alive...maybe a shorted wire giving constant 12v to the computer.

i would start by replacing the switch. if that doesnt fix it you have a really weird wiring issue
__________________
Its a Jeep thing...
MkUltraOps is offline   Quote Quick Reply
Old 06-06-2014, 06:02 PM   #4
Jeeper
 
Jeeprich25's Avatar
 
Join Date: Sep 2010
Posts: 558
That happened to me when my computer shorted out. Replaced fusible links and resoldered the circuit board in the ecu. It caused the ignition to always be hot. Had to wire in a kill switch till I could replace the ecu.
__________________
1990 Jeep Wrangler YJ. 2.5L. Bone Stock, mostly.

"I'd have more money for upgrades if it didn't break every week."
Jeeprich25 is offline   Quote Quick Reply
Old 06-06-2014, 06:07 PM   #5
Jeeper
 
Join Date: May 2011
Posts: 2,284
Quote:
Originally Posted by Jkilbert View Post
Switch could still be bad.
+1 I went through this two weeks ago with a buddy of mine. We replaced a bad ignition switch and the replacement switch was worse than the one we took out. I'd check it to be sure.
demarpaint is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:49 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC