Engine problems... please help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-05-2010, 12:52 PM   #1
Newb
 
Join Date: Dec 2010
Posts: 4
Post Engine problems... please help

i bought a 1993 jeep wrangler yj from a mechanic i've been using for a while
the truck is pretty hooked up with tires, lift kits, armor, and a beast brush guard. the truck has 120,000 miles on it. Straight 6

about 2 months after i purchased the truck i was in 4 wheel low doing some very low key offroading. i hit a bad bump got a bit of air and when i came down the engine was making a rattling noise. once checked out it turns out i blew a piston rod and needed a new engine. it was worth it to get one because of all the money put into the truck. i got the new engine (not brand new, it came out of a 2002 wrangler with 40,000 miles great condition) and no more than two weeks later while driving in 4 wheel high in the rain the same exact thing happened. same piston in the new engine. could i be doing something wrong or is it possible the truck is a lemon? the engine was insured but i still need to pay to have it installed. is it worth it?

robbyr is offline   Quote
Old 12-05-2010, 01:18 PM   #2
Jeeper
 
Join Date: Nov 2010
Posts: 16
Images: 8
How many RPM's did you turn ?

__________________
88 YJ, 4.2 5spd, Hardtop, 6" Skyjacker Monoleaf, 33's on alloy, RockCrawler Bumpers, Tube fenders, Full wrap body armour, 4.88's, SYE W/CV.
mholloway1809 is offline   Quote
Old 12-05-2010, 01:29 PM   #3
Newb
 
Join Date: Dec 2010
Posts: 4
on the first engine while i was in the air for that split second i was barely even giving it gas, but not sure how much exactly

on the second engine i was driving normally couldn't have been over 3000 rpm
robbyr is offline   Quote
Old 12-09-2010, 10:26 PM   #4
Jeeper
 
Join Date: Nov 2010
Posts: 16
Images: 8
If you didnt overrev the engine or run it low on oil i think its possible the previous owner might have.
A 2002 jeep engine with only 40k on it, must have came from a wrecked jeep with serious damage.
Second, never buy a mechanic's personal vehicle. its the one that never gets fixed right.
__________________
88 YJ, 4.2 5spd, Hardtop, 6" Skyjacker Monoleaf, 33's on alloy, RockCrawler Bumpers, Tube fenders, Full wrap body armour, 4.88's, SYE W/CV.
mholloway1809 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine problems calicocal TJ Tech Forum 4 08-18-2010 11:15 PM
Engine Light + Maintence problems Ericl TJ Tech Forum 2 08-16-2010 02:45 PM
the engine hoist saga continues... tiny terror Off-Topic 14 08-28-2009 01:02 AM
Mounting engine mount brackets... 1992wranglersahara YJ Tech Forum 3 06-02-2009 07:40 PM
Spedo dies and the engine dies when I brake jbhouse2k TJ Tech Forum 4 03-06-2007 07:17 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:44 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC