Error code help! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-02-2013, 09:29 PM   #1
Jeeper
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,904
Error code help!

I have an occasional low idle and error codes 51, 21, & 14. Anyone know what would cause all three of these error codes at the same time? Jeep is driving fine. No loss of power or anything. Just 1 in ever 10 times I stop or so id idles down around 600 rms. I would replace the MAP sensor, but sine I have the two other codes at the same time I am not sure if something else may be to blame.

__________________
Complete rebuild axle/engine/everything swap in progress:
Parts already gathered for assembly: 2001 Ford 302, 1990 Mustang GT 5.0 ECU and wiring, NP435, NP205, Pair of axles from 04' F350 SuperDuty (Sterling 10.5 Posi rear, Dana 60HP Front-Both Disk Brakes 3.73 Gears), 37" H1 Tires, 9" lift TJ Coils for 2 link conversion in front, Stage 2 Clutch Kit, 3 Row Aluminum Radiator, Chevy Astro Steering box (4" front Stretch), XJ Rear Leaf Springs (6" Rear Stretch), and lots more.
OverkillYJ is offline   Quote
Old 05-02-2013, 09:37 PM   #2
Jeeper
 
wrangleryj90's Avatar
 
Join Date: Mar 2013
Location: Spokane,Wa
Posts: 495
I have the same problem with mine I am not throwing a code tho

wrangleryj90 is offline   Quote
Old 05-03-2013, 08:16 AM   #3
Jeeper
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,904
So this is what they mean, but what would cause this? Could it be a clogged injector alone? That would be my first though, but would that trigger any problems with the MAP sensor?

51 O2S signal stays below center (lean)
21 O2S stays at center or O2S shorted to voltage
14 MAP sensor voltage too low or too high
__________________
Complete rebuild axle/engine/everything swap in progress:
Parts already gathered for assembly: 2001 Ford 302, 1990 Mustang GT 5.0 ECU and wiring, NP435, NP205, Pair of axles from 04' F350 SuperDuty (Sterling 10.5 Posi rear, Dana 60HP Front-Both Disk Brakes 3.73 Gears), 37" H1 Tires, 9" lift TJ Coils for 2 link conversion in front, Stage 2 Clutch Kit, 3 Row Aluminum Radiator, Chevy Astro Steering box (4" front Stretch), XJ Rear Leaf Springs (6" Rear Stretch), and lots more.
OverkillYJ is offline   Quote
Old 05-04-2013, 07:07 PM   #4
Jeeper
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,904
bump
__________________
Complete rebuild axle/engine/everything swap in progress:
Parts already gathered for assembly: 2001 Ford 302, 1990 Mustang GT 5.0 ECU and wiring, NP435, NP205, Pair of axles from 04' F350 SuperDuty (Sterling 10.5 Posi rear, Dana 60HP Front-Both Disk Brakes 3.73 Gears), 37" H1 Tires, 9" lift TJ Coils for 2 link conversion in front, Stage 2 Clutch Kit, 3 Row Aluminum Radiator, Chevy Astro Steering box (4" front Stretch), XJ Rear Leaf Springs (6" Rear Stretch), and lots more.
OverkillYJ is offline   Quote
Old 05-04-2013, 10:19 PM   #5
Jeeper
 
redneckbrat's Avatar
 
Join Date: Oct 2008
Location: sacramento, ca
Posts: 201
Change your O2 sensor. I had the same codes, Check engine light went off. Still waiting for the Maint Req light to go out.
__________________
91 YJ, 4.0L HO, 32X11.5X15 Wild Country, 3" lift, 6" Rugged Ridge All Terrain Fender Flare Set, custom mud flaps
redneckbrat is offline   Quote
Old 05-05-2013, 12:31 PM   #6
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,293
Quote:
Originally Posted by redneckbrat View Post
Change your O2 sensor. I had the same codes, Check engine light went off. Still waiting for the Maint Req light to go out.
Your maint light will not go off, has to reset by a dealer.
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote
Old 05-05-2013, 05:01 PM   #7
Jeeper
 
redneckbrat's Avatar
 
Join Date: Oct 2008
Location: sacramento, ca
Posts: 201
Quote:
Originally Posted by Garyk View Post
Your maint light will not go off, has to reset by a dealer.
That sucks.
__________________
91 YJ, 4.0L HO, 32X11.5X15 Wild Country, 3" lift, 6" Rugged Ridge All Terrain Fender Flare Set, custom mud flaps
redneckbrat is offline   Quote
Old 05-05-2013, 06:52 PM   #8
Jeeper
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,904
Quote:
Originally Posted by redneckbrat View Post

That sucks.
Thats wrong anyway. Will go off when fixed like every other code I have fixed.
__________________
Complete rebuild axle/engine/everything swap in progress:
Parts already gathered for assembly: 2001 Ford 302, 1990 Mustang GT 5.0 ECU and wiring, NP435, NP205, Pair of axles from 04' F350 SuperDuty (Sterling 10.5 Posi rear, Dana 60HP Front-Both Disk Brakes 3.73 Gears), 37" H1 Tires, 9" lift TJ Coils for 2 link conversion in front, Stage 2 Clutch Kit, 3 Row Aluminum Radiator, Chevy Astro Steering box (4" front Stretch), XJ Rear Leaf Springs (6" Rear Stretch), and lots more.
OverkillYJ is offline   Quote
Old 05-18-2013, 11:17 PM   #9
Jeeper
 
redneckbrat's Avatar
 
Join Date: Oct 2008
Location: sacramento, ca
Posts: 201
Quote:
Originally Posted by OverkillYJ View Post
Thats wrong anyway. Will go off when fixed like every other code I have fixed.
It's been over 180 miles, still not off. I wonder what else I need to fix for it to go out.
__________________
91 YJ, 4.0L HO, 32X11.5X15 Wild Country, 3" lift, 6" Rugged Ridge All Terrain Fender Flare Set, custom mud flaps
redneckbrat is offline   Quote
Old 05-19-2013, 08:53 AM   #10
Jeeper
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,904
I replaced the MAP sensor and the MAP error went away. Then I changed the O2 sensor and the other 2 errors went away. No more check engine light. Not sure about Maint Req light though. I have never seen that one. I have only seen the Brake light, seatbelt light, and check engine light.
__________________
Complete rebuild axle/engine/everything swap in progress:
Parts already gathered for assembly: 2001 Ford 302, 1990 Mustang GT 5.0 ECU and wiring, NP435, NP205, Pair of axles from 04' F350 SuperDuty (Sterling 10.5 Posi rear, Dana 60HP Front-Both Disk Brakes 3.73 Gears), 37" H1 Tires, 9" lift TJ Coils for 2 link conversion in front, Stage 2 Clutch Kit, 3 Row Aluminum Radiator, Chevy Astro Steering box (4" front Stretch), XJ Rear Leaf Springs (6" Rear Stretch), and lots more.
OverkillYJ is offline   Quote
Old 05-19-2013, 11:48 AM   #11
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,293
The maintenance light will come on if the o2 sensor times out. In older models this could be disconnected, in these it has to be reset.....some disconnect the maintenance required light.
CEL is different. That one will clear .

__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:08 PM.



Jeep«, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC