Failed emissions test - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-04-2014, 12:55 AM   #1
Newb
 
Bradmaus's Avatar
 
Join Date: Mar 2014
Posts: 6
Failed emissions test

I I failed my emissions test today. I did a tune up and new o2 sensor. Do you think this could fix it. If not I'm thinking it's the cat. Also I have a leaky exhaust/intake gasket. I have a new one but it looks like a very labor intensive job. Has anyone done this? Also could that bad gasket be part of the fade emissions. Any help would be great. Just bought the jeep 2 days ago and I can't transfer the title until it passes. I'm lake Stevens if anyone wants to come help.

Bradmaus is offline   Quote Quick Reply
Old 03-04-2014, 01:34 AM   #2
Jeeper
 
Join Date: Feb 2014
Location: Monroe, Or
Posts: 638
Where did they say it failed at? A Leaky manifold gasket can cause issues especially before the O2 sensor (it would mis-read the actual mix and try to compensate for it).

It's too bad you didn't live closer to Portland, if you don't pass you don't pay at all lol.

Anywho, I'd get the gasket fixed then see what happens.

__________________
1993 YJ 4.0, 5 Speed, 3.55 (for now)
2000 Durango 4.7, 5 Speed Auto, 3.92
TrailBlazing Gear Post
Project Ole Grey
Locruid is offline   Quote Quick Reply
Old 03-04-2014, 01:53 AM   #3
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 728
Did they give you a report sheet or a printout? Post it up so we can take a look and see what area(s) you failed in.
Defcon 1 is offline   Quote Quick Reply
Old 03-04-2014, 02:39 AM   #4
Newb
 
Bradmaus's Avatar
 
Join Date: Mar 2014
Posts: 6
Click image for larger version

Name:	image-1413382169.jpg
Views:	56
Size:	154.3 KB
ID:	832969
Bradmaus is offline   Quote Quick Reply
Old 03-04-2014, 03:18 AM   #5
Newb
 
Bradmaus's Avatar
 
Join Date: Mar 2014
Posts: 6
Also I believe I got the codes12, 33, 54 and 55. I just replaced the o2 sensor, plugs, cap and rotor. It has an aftermarket intake and flow master muffler after the cat btw
Bradmaus is offline   Quote Quick Reply
Old 03-04-2014, 12:24 PM   #6
Jeeper
 
0III0forlife's Avatar
 
Join Date: Mar 2012
Location: Ridgway, Pa.
Posts: 3,265
12 is batt disconnected- normal

33 is no A/C signal- normal

54 is bad cam sensor

55 is end of codes.

I would replace the cam sensor, and definitely replace the manifold gasket.
__________________
'87 YJ, 4.2L built and bored, 8.5" of lift, 8.8 rear, AX15/NP 231, Tom Woods drive shafts, Flat fenders, 12,000LB winch, Custom bumpers, Rattle can paint job. Never completed...
0III0forlife is offline   Quote Quick Reply
Old 03-06-2014, 12:37 PM   #7
Newb
 
Bradmaus's Avatar
 
Join Date: Mar 2014
Posts: 6
So not sure what part it was but I passed. I replaced the o2 sensor, plugs, cap and rotor and it turns our the exhaust gasket was not bad a bolt just was missing causing the leak. Mystery solved. Not to fix engine code 54
Bradmaus is offline   Quote Quick Reply
Old 03-06-2014, 04:38 PM   #8
Jeeper
 
Timberwolf's Avatar
 
Join Date: Sep 2010
Posts: 860
did you clear the codes after the fix?
__________________
Don't be afraid of the dark,
Be afraid of what hunts in the dark.

Timberwolf is offline   Quote Quick Reply
Old 03-06-2014, 11:57 PM   #9
Newb
 
Bradmaus's Avatar
 
Join Date: Mar 2014
Posts: 6
Yes although I still have a code 54. Shucks and autozone both are saying I don't have a cam sensor in my 2.5. Any insight on this
Bradmaus is offline   Quote Quick Reply
Old 03-07-2014, 12:15 AM   #10
Jeeper
 
Join Date: Feb 2014
Location: Monroe, Or
Posts: 638
It's in the Distributor
Camshaft position sensor 94 YJ 2.5L FI - JeepForum.com
Jeep Wrangler Camshaft Position Sensor


AKA Pickup Coil/sync pulse generator/stator


http://www.autozone.com/autozone/par...mString=search

That last link is from my store lol

__________________
1993 YJ 4.0, 5 Speed, 3.55 (for now)
2000 Durango 4.7, 5 Speed Auto, 3.92
TrailBlazing Gear Post
Project Ole Grey
Locruid is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:41 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC