Failed emissions/very poor idle/O2 sensor? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-15-2010, 11:36 AM   #1
Jeeper
 
Join Date: Nov 2010
Posts: 63
Failed emissions/very poor idle/O2 sensor?

Guys got a '90 wrangler Islander from the old man and tried to pass emissions last week. I passed everything except the NO (PPM) at the 25 mph test (1807 allowed score 2536). I was told the catalytic converter needed to be replaced. I bought and installed this weekend but still seems to be running really rich. When I dropped the kid off at school today I notice the Cat converter was red and hot. Obviously this concerned me so I parked it. I don't have deformities to the converter so i'm thinking it's probably okay.

I've read this means fuel is getting into the converter instead of firing off in the engine like it's supposed to. My question is could it be the O2 sensor not working causing it to pump more fuel than is needed? I've replaced and checked all the plugs but haven't replaced the cables or distributor cap.

I could really use some help since I need this vehicle to get around town. I don't have a ton of money so I don't want to take it to anyone so your help will be greatly appreciated. Thanks a ton in advance.

Bandit19 is offline   Quote
Old 11-15-2010, 11:39 AM   #2
Jeeper
 
Join Date: Nov 2010
Posts: 63
I also forgot to mention it was idling poorly and rough and engine killing if I let RPM's drop too far. I adjusted the choke a little and it helped with the idle some but is still running a little rough. Thanks again

Bandit19 is offline   Quote
Old 11-15-2010, 02:52 PM   #3
Newb
 
Join Date: Nov 2010
Location: Scottsdale,az
Posts: 11
Do the nutter and you should pass with flying colors. If the carb is shot check out the 2100 kit on ebay and your jeep will be running like a champ..
Scott124 is offline   Quote
Old 11-15-2010, 06:37 PM   #4
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 6,435
The 02 sensor has to be replaced at 88,500 miles anyway.
kik is offline   Quote
Old 11-15-2010, 08:37 PM   #5
Jeeper
 
Join Date: Nov 2010
Posts: 63
Scott124 can you tell me what the nutter bypass does? I had someone suggest it to me once but they didn't explain why.
Bandit19 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Sensor Problems nywrangler TJ Tech Forum 3 11-02-2010 06:47 PM
Check Engine Light Flameeater TJ Tech Forum 4 06-18-2010 05:12 PM
failed emssions with O2 sensor reading lean Help! pyro826 YJ General Discussion Forum 2 04-22-2010 12:09 PM
02 Sensor Heater Circuit (Bank 2 Sensor 2) cork1958 TJ General Discussion Forum 0 11-09-2008 09:56 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:27 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC