Fuel module doesn't fit - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-12-2013, 07:19 AM   #1
Newb
 
Join Date: May 2013
Posts: 3
Fuel module doesn't fit

I am trying to change the fuel module in my 93 yj. The new fuel module seems too long. It is the same length as the one I pulled out of the tank.
I have the 2.5 engine and the poly tank. Any ideas. Thanks

zzeno is offline   Quote
Old 05-12-2013, 10:00 AM   #2
Jeeper
 
Redrider94's Avatar
 
Join Date: Aug 2010
Posts: 662
I'm not sure but I think there is a well in the tank that your pump and sending unit set in.

Redrider94 is offline   Quote
Old 05-12-2013, 10:42 AM   #3
Jeeper
 
0III0forlife's Avatar
 
Join Date: Mar 2012
Location: Ridgway, Pa.
Posts: 3,961
redrider is correct. If you take a flashlight and look down in the tank, there is a ring molded into the bottom of the tank that the pump/sending unit sits in. It will only fit in there 1 way.
0III0forlife is offline   Quote
Old 05-12-2013, 11:25 AM   #4
Newb
 
Join Date: May 2013
Posts: 3
I know what you are talking about. The module has a rubber cone that sets in the ring. I am confused because the old module is the same length as the new one, but when I measure tank depth it appears that I am about 1 inche too long.
zzeno is offline   Quote
Old 05-12-2013, 01:40 PM   #5
Jeeper
 
Redrider94's Avatar
 
Join Date: Aug 2010
Posts: 662
Quote:
Originally Posted by zzeno View Post
I know what you are talking about. The module has a rubber cone that sets in the ring. I am confused because the old module is the same length as the new one, but when I measure tank depth it appears that I am about 1 inche too long.
If the old one is the same length as the new one then it has to fit! Sounds like you're not getting it set back in the proper location.
Redrider94 is offline   Quote
Old 05-12-2013, 06:04 PM   #6
Newb
 
Join Date: May 2013
Posts: 3
I got it in. I had to take the skid plate off. It went in easy. I think the tank was bowed up in the middle. I also straightend the skid plate a little.

zzeno is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:29 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC