Fuel pump woes - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-19-2013, 06:24 PM   #1
ZORT-1122 Driver

WF Supporting Member
 
raycer's Avatar
 
Join Date: Aug 2011
Location: Where NY/NJ/PA meet
Posts: 667
Images: 4
Fuel pump woes

My jeep decided not to start for me in the walmart parking lot today. I couldn't hear the pump prime. I switched the pump relay with the one for the horn, since they both were the same, and nothing. I did notice though that the horn wouldn't work with the fuel relay at all.

Did the tapping the gas tank with a hammer trick and the jeep started right up and made it home. Now the pump is priming and everything.

Now last year I had a similar problem and I changed the fuel pump and all was well. What are the odds the pump went bad again or could the relays be the fault. I really don't want to drop the tank again lol

__________________
Ray
1993 YJ "ZORV-1122"
4.0 AX15 4in Rough Country Lift 1.25in Perf. Acc. Shackles, few other things here and there.
raycer is offline   Quote Quick Reply
Old 07-19-2013, 06:29 PM   #2
Jeeper
 
Join Date: Feb 2013
Posts: 536
Not to be a jerk but did you put it back together correctly!

It is possible that it went bad in a year but I would not think so unless you did not put it back together correctly!

Bottom line is to be sure you will have to drop the tank

Look at it this way you have done it before!

89Saharagreen is offline   Quote Quick Reply
Old 07-19-2013, 06:59 PM   #3
ZORT-1122 Driver

WF Supporting Member
 
raycer's Avatar
 
Join Date: Aug 2011
Location: Where NY/NJ/PA meet
Posts: 667
Images: 4
Lol no offense taken. I do believe it is correct and it did work great for about 15 months.
__________________
Ray
1993 YJ "ZORV-1122"
4.0 AX15 4in Rough Country Lift 1.25in Perf. Acc. Shackles, few other things here and there.
raycer is offline   Quote Quick Reply
Old 07-19-2013, 07:08 PM   #4
Jeeper
 
Timberwolf's Avatar
 
Join Date: Sep 2010
Posts: 786
was it an airtex brand pump?
__________________
Don't be afraid of the dark,
Be afraid of what hunts in the dark.

Timberwolf is offline   Quote Quick Reply
Old 07-19-2013, 08:00 PM   #5
Newb
 
Join Date: Jun 2013
Posts: 6
Quote:
Originally Posted by Timberwolf View Post
was it an airtex brand pump?
I got an airtex fuel pump for our yj that was bad right out of the box. Heard a lot of bad things about them.
Yjred is offline   Quote Quick Reply
Old 07-19-2013, 08:03 PM   #6
Newb
 
Join Date: Jun 2013
Posts: 6
Quote:
Originally Posted by Yjred View Post

I got an airtex fuel pump for our yj that was bad right out of the box. Heard a lot of bad things about them.
The previous owner had the pump changes sometime before we got our jeep and I guess they had weakened the return line on the sending unit at the braised joint on it. It came loose and you lose your ground. So I had to change it as well. Might wanna check that also.
Yjred is offline   Quote Quick Reply
Old 07-19-2013, 09:47 PM   #7
ZORT-1122 Driver

WF Supporting Member
 
raycer's Avatar
 
Join Date: Aug 2011
Location: Where NY/NJ/PA meet
Posts: 667
Images: 4
Thanks for the fellas. The pump is a napa pump but I don't know who makes it for them. Thinking of getting a whole new sending unit and pump since my gas gauge hasn't worked in a long time either.
__________________
Ray
1993 YJ "ZORV-1122"
4.0 AX15 4in Rough Country Lift 1.25in Perf. Acc. Shackles, few other things here and there.
raycer is offline   Quote Quick Reply
Old 07-19-2013, 10:24 PM   #8
Jeeper
 
206dawgfan's Avatar
 
Join Date: Mar 2010
Location: Shoreline
Posts: 77
Really!!!! Really!!!! Check the ground on the tank. It is super week and if your gas gauge does not work also it could be a bad ground.
206dawgfan is offline   Quote Quick Reply
Old 07-19-2013, 11:43 PM   #9
ZORT-1122 Driver

WF Supporting Member
 
raycer's Avatar
 
Join Date: Aug 2011
Location: Where NY/NJ/PA meet
Posts: 667
Images: 4
The ground you speak of is on the top of the sending unit right?
__________________
Ray
1993 YJ "ZORV-1122"
4.0 AX15 4in Rough Country Lift 1.25in Perf. Acc. Shackles, few other things here and there.
raycer is offline   Quote Quick Reply
Old 07-20-2013, 04:46 PM   #10
ZORT-1122 Driver

WF Supporting Member
 
raycer's Avatar
 
Join Date: Aug 2011
Location: Where NY/NJ/PA meet
Posts: 667
Images: 4
I thought of something. If it were a bad ground at the tank, would the hammering the tank to get the pump going still work? that's how I got it started again
__________________
Ray
1993 YJ "ZORV-1122"
4.0 AX15 4in Rough Country Lift 1.25in Perf. Acc. Shackles, few other things here and there.
raycer is offline   Quote Quick Reply
Old 07-20-2013, 08:27 PM   #11
Newb
 
Join Date: Jun 2013
Posts: 6
Quote:
Originally Posted by raycer View Post
I thought of something. If it were a bad ground at the tank, would the hammering the tank to get the pump going still work? that's how I got it started again
On ours the actual metal return line on the sending unit separated at the 90 degree bend where it is braised. When it separated it lost ground. The chassis ground is connected to the outside of the sending unit, but the pump and fuel gauge are grounded to the frame of the sending unit in the tank. The only thing connecting all that is the metal return line. If the braised joint comes apart like ours did because the previous owner obviously stressed it in a previous fuel pump change, you lose your ground inside the tank.
Yjred is offline   Quote Quick Reply
Old 07-20-2013, 10:48 PM   #12
Jeeper
 
206dawgfan's Avatar
 
Join Date: Mar 2010
Location: Shoreline
Posts: 77
There are three wires that land on top of the sending unit. Power to the pump, power to the gauge and a ground.
206dawgfan is offline   Quote Quick Reply
Old 07-21-2013, 12:10 PM   #13
ZORT-1122 Driver

WF Supporting Member
 
raycer's Avatar
 
Join Date: Aug 2011
Location: Where NY/NJ/PA meet
Posts: 667
Images: 4
Quote:
Originally Posted by Yjred View Post

On ours the actual metal return line on the sending unit separated at the 90 degree bend where it is braised. When it separated it lost ground. The chassis ground is connected to the outside of the sending unit, but the pump and fuel gauge are grounded to the frame of the sending unit in the tank. The only thing connecting all that is the metal return line. If the braised joint comes apart like ours did because the previous owner obviously stressed it in a previous fuel pump change, you lose your ground inside the tank.
So maybe the hammering made it get some connection again? Either way, looks like the tank is coming down lol
__________________
Ray
1993 YJ "ZORV-1122"
4.0 AX15 4in Rough Country Lift 1.25in Perf. Acc. Shackles, few other things here and there.
raycer is offline   Quote Quick Reply
Old 07-21-2013, 03:42 PM   #14
Newb
 
Join Date: Jun 2013
Posts: 6
Quote:
Originally Posted by raycer View Post

So maybe the hammering made it get some connection again? Either way, looks like the tank is coming down lol
Don't feel bad, I had to drop the tank twice to figure it out.
Yjred is offline   Quote Quick Reply
Old 07-21-2013, 07:26 PM   #15
Jeeper
 
The Silver Gorilla's Avatar
 
Join Date: Jan 2013
Location: Tampa
Posts: 584
Quote:
Originally Posted by 206dawgfan View Post
There are three wires that land on top of the sending unit. Power to the pump, power to the gauge and a ground.
know what one is the gauge wire?
The Silver Gorilla is offline   Quote Quick Reply
Old 07-21-2013, 09:18 PM   #16
Jeeper
 
206dawgfan's Avatar
 
Join Date: Mar 2010
Location: Shoreline
Posts: 77
You will know when you open up the tank just follow the wires to either gauge or the pump. I can't remember what color they were. Good luck.

206dawgfan is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC