Half of my dash lights are out HELP - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-14-2012, 08:40 PM   #1
Newb
 
Join Date: Aug 2012
Posts: 2
Half of my dash lights are out HELP

Well some of my dash lights are out on my 95 yj. The head lights, tail lights and turn signals are all working properly. The only lights that are working on my dash are the RPM guage, temp guage and oil pressure guage the rest are not. I have took apart the dash to see if bulbs needed to be replaced. They were all fine. Is there a fuse I should be looking for to fix the problem?

Andrew.Crandall47 is offline   Quote
Old 08-14-2012, 09:11 PM   #2
Jeeper
 
JeepBotts's Avatar
 
Join Date: Jan 2012
Location: Baltimore Ohio
Posts: 17
I had the same Problem, When I took my instrument pannel off it looked ok too. However, once I put it backtogether the only thing on mine that works is the speedometer. No lights, No gauges. One day a passenger got in and shut the door and the gauge lights came back on but I still have no gauges working. Never did ger a fix still looking

JeepBotts is offline   Quote
Old 08-14-2012, 09:12 PM   #3
Jeeper
 
90DesertTanYJ's Avatar
 
Join Date: Jul 2012
Location: JAX, FL
Posts: 635
You notice on the back of the gauge cluster that nifty little piece of plastic with the copper pathways? Thats probly F**ked. Replacements can be had for about $80.

Personally I will be adapting some LEDs in place of the socket and bulb setup and hardwired in like my gauges.

90DesertTanYJ is offline   Quote
Old 08-14-2012, 09:33 PM   #4
Newb
 
Join Date: Aug 2012
Posts: 2
The back of the cluster did look a little beat up.. My gauges and everything work except the gas guage which shuts off when I turn on my lights. Is the Rpm and speedometer hooked up to that to?

Thanks for your help!
Andrew.Crandall47 is offline   Quote
Old 08-14-2012, 10:29 PM   #5
Jeeper
 
Lt. Ray T.'s Avatar
 
Join Date: Aug 2012
Location: Chiefland, FL
Posts: 369
I wish I could find a digital replacement cluster for mine. Does anyone out there have a line on such a thing?

as far as your cluster failing, try pulling it out and cleaning the contacts where the plug goes in. Actually worked for part of mine. My temp guage actually started working again also.
Lt. Ray T. is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:46 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC