Having issues - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-25-2013, 10:26 AM   #1
Newb
 
Join Date: Sep 2013
Posts: 1
Having issues

Having issues with my 1990 jeep wrangler with 2.5L in it. Drives down the road fine until sporadically it will die. I can jump or key start it and it will go a mile then die again. Once it starts this, it will run bad. Spit n sputter and a backfire cough occasionally. It seems to only run on a couple cylinders and gets worse when I give it gas.. Things I've done is change fuel filter, ignition control module, o2 sensor.

Plugs are tan and seems to be good. Ran cleaner and spray cleaned injector.. It looks like it's been warm but mechanic didn't think it was an issue. Used to have pressure in gas tank when I removed the cap. Cleaned vents and replaced cap. Sprayed distributed with wd40 looking for cracks but seemed to be ok..

Hiveranno is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:05 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC