having trouble jeep idles rough, backfires and stalls - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-21-2011, 12:41 PM   #1
Newb
 
Join Date: Sep 2011
Posts: 1
having trouble jeep idles rough, backfires and stalls

I have a 95 4 cyl.wrangler always ran good. I went mudding and it stalled, I started it up went 20 ft and stalled again to the point where It wouldnt start at all. When I turn it over the rpm guage jumps all over the place and it starts sometimes but runs rough and backfires. This is what I have done checked timing its good, getting spark on coil and all 4 cyl. has fule presure, put new plugs in it ( oil smells like gas) Please help I have a annuel jeep run this weekend and dont want to be a passanger.

salmoncreek is offline   Quote Quick Reply
Old 09-21-2011, 02:19 PM   #2
Jeeper
 
an_drew05's Avatar
 
Join Date: Aug 2011
Posts: 36
throttle position sensor? Mine was acting similar (not exactly) to this a week ago, so I changed the TPS and now it runs like dream. Mine was kicking and bucking throughout 1st and 2nd. It never stalled out to where I couldn't start it though, so I'm not exactly sure.

an_drew05 is offline   Quote Quick Reply
Old 09-21-2011, 08:52 PM   #3
Jeeper
 
theginger969's Avatar
 
Join Date: May 2011
Location: Bridgeport
Posts: 68
id check the timing on your distributor
theginger969 is offline   Quote Quick Reply
Old 09-21-2011, 08:52 PM   #4
Jeeper
 
theginger969's Avatar
 
Join Date: May 2011
Location: Bridgeport
Posts: 68
tps is a good suggestion. but doesn't sound like that. its almost like your getting a bad fuel mixture. look into getting a new fuel filter
theginger969 is offline   Quote Quick Reply
Old 03-06-2012, 10:56 PM   #5
Newb
 
Join Date: Mar 2012
Location: lakeland florida
Posts: 2
I have the same problem. changed all sensors except sos sensor. that didnt help. got new fuel injectors. Not the problem. Havent changed the fuel filter yet. I am having that done tomorrow. I will let you know if it worked.
lkndgirl is offline   Quote Quick Reply
Old 03-07-2012, 09:11 PM   #6
Jeeper
 
DirtyRob's Avatar
 
Join Date: Sep 2011
Location: Sampson County N.C.
Posts: 1,139
Images: 3
My 90 YJ did the same thing, I kept thinking fuel issue, but it was the Crank Position sensor. I swear that is what it sounds like. Below is a link to my thread a while back. Best of luck

http://www.wranglerforum.com/f8/spit...op-124957.html
__________________
wherever you go there you are..........
DirtyRob is offline   Quote Quick Reply
Old 03-07-2012, 09:31 PM   #7
Jeeper
 
Master4th's Avatar
 
Join Date: Mar 2012
Posts: 341
Sounds like fuel isn't the issue, did you check to make sure your Distributer was dry inside?

Would the engine light come on in a 94 for a failed sensor?

Also how old are your wires?
Master4th is offline   Quote Quick Reply
Old 03-08-2012, 12:31 PM   #8
Jeeper
 
Join Date: Oct 2010
Location: OC, MD
Posts: 20
Similar issue

I've got something like that happening. Mine will cruise fine but at like 2k rpms its goes substantially faster. but if my foot is on the gas most of the way, it will just do nothing almost. real hard to explain but i guess my question is, where is the fuel filter? i followed from the fuel line to the tank and cant seem to find it.
OCVinMan is offline   Quote Quick Reply
Old 03-08-2012, 09:30 PM   #9
Jeeper
 
Master4th's Avatar
 
Join Date: Mar 2012
Posts: 341
Thats the 2.5 Location


1987 to 90 4.2L

Master4th is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 04:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC