Heater not working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-06-2013, 11:25 AM   #1
Jeeper
 
Michaelh325's Avatar
 
Join Date: Nov 2013
Posts: 16
Heater not working

I have a 1989 YJ. My A/C works perfectly but for some reason my heater will not work. I can't get the blower to switch to my defrosters or any other position. I'm pretty sure that it uses the same blower motor for both the A/C and the heater. Any suggestions?

Michaelh325 is offline   Quote Quick Reply
Old 12-06-2013, 12:00 PM   #2
Jeeper
 
tchoberg's Avatar
 
Join Date: Oct 2011
Location: Mountain Center, CA
Posts: 89
I'm sure yours is the add on A/C system similar to mine in my '87.The early A/C units were dealer installed and heater is a totally separate system with have different motors and controls.
The A/C blower motor is located on the left, under the dash near the steering column and sits vertical.
The heater blower motor is located on the right and is mounted through the firewall.
Check fuses and search for the forum for some great writeups on how the heater system works and how to troubleshoot it. Good luck.

__________________
If it ain't broke, don't fix it - Don't worry, something will break soon enough for you to fix!
tchoberg is offline   Quote Quick Reply
Old 12-06-2013, 12:01 PM   #3
Jeeper
 
Join Date: Oct 2013
Location: Fishers, IN
Posts: 266
It does not use the same blower motor. The A/C is a separate unit with separate controls.

Are you using the A/C controls to try and get heat? The following is a pic of the AC controls. Do not use these.


You need to be using these:


Move the bottom lever over to Warm, you should see this gate move:


Next move the top lever to either defrost or "heat". The blower will come on. Use the verticle lever to turn the blower up more. If you are still having problems let us know what.

btw - "heat" is basically floor. We have vents for defrost and floor thats it for heat.
Thomas S is online now   Quote Quick Reply
Old 12-06-2013, 12:43 PM   #4
Jeeper
 
Michaelh325's Avatar
 
Join Date: Nov 2013
Posts: 16
Ok. The arm does move but nothing comes on when I use the I dash controls. Maybe it's a power problem
Michaelh325 is offline   Quote Quick Reply
Old 12-06-2013, 12:54 PM   #5
Jeeper
 
0III0forlife's Avatar
 
Join Date: Mar 2012
Location: Ridgway, Pa.
Posts: 2,775
If its a power problem, its either a fuse, or the heater blower motor has come unplugged. It is located under the battery in the engine compartment.
__________________
'87 YJ, 4.2L built and bored, 8.5" of lift, 8.8 rear, AX15/NP 231, Tom Woods drive shafts, Flat fenders, 12,000LB winch, Custom bumpers, Rattle can paint job. Never completed...
0III0forlife is offline   Quote Quick Reply
Old 12-06-2013, 05:00 PM   #6
Jeeper
 
WallyGator215's Avatar
 
Join Date: Aug 2013
Location: Willow Grove, Pa
Posts: 192
Images: 1
Same problem on my 87. Took the battery and tray out and saw the motor had a plug on the back with nothing in it. Found the wire I stared at all summer long and plugged it into the blower motor and BAM we got heat. If that's what you wanna call it. It is warm but like other poster said its floor and windshield vent only but it works now. Good luck
__________________
l_OlllllllO_l
WallyGator215 is offline   Quote Quick Reply
Old 12-06-2013, 05:51 PM   #7
Newb
 
Join Date: Dec 2013
Posts: 4
Have 1995 jeep wrangle sometimes blower will come on but like once In a blue moon any one have any clues
Glenlnng is offline   Quote Quick Reply
Old 12-06-2013, 07:57 PM   #8
Supporting Member

WF Supporting Member
 
CyndiB's Avatar
 
Join Date: Jul 2011
Location: Inland Empire, CA
Posts: 871
I have the opposite problem. My heater blows hot air whether it's turned on or not. I don't think I've ever even turned it on because I don't need to, lol. It's a nice feature in the winter, but not so great in the summer unless I have the top down.
CyndiB is offline   Quote Quick Reply
Old 12-08-2013, 05:11 PM   #9
Jeeper
 
Michaelh325's Avatar
 
Join Date: Nov 2013
Posts: 16
It was the plug under the battery pan. My heater is working great now. Thanks for the help.
Michaelh325 is offline   Quote Quick Reply
Old 01-01-2014, 05:30 PM   #10
Jeeper
 
Michigan jeeper's Avatar
 
Join Date: Feb 2013
Posts: 412
In my 94 I cannot seem to find any wires under the battery tray so what then?
Michigan jeeper is offline   Quote Quick Reply
Old 01-04-2014, 04:17 PM   #11
Newb
 
Join Date: May 2013
Posts: 3
mine comes on but it barley puts out any heat, and in summer it wont shut off all the way...
panman63 is offline   Quote Quick Reply
Old 01-04-2014, 06:31 PM   #12
Jeeper
 
Decoy_58's Avatar
 
Join Date: May 2013
Location: nor cal
Posts: 278
there is a great sticky for the yj heating sys on forum

__________________
1990 4.2 MPFI, 3" body lift, 1" shackle lift,2.5 suspension lift, 8000lbs winch, 33x12.50x15
GOD BLESS OUR TROOPS
LUV YOUR YJ
HANG THE BASTARD ECV 58
Decoy_58 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:57 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC