Hei distributor help before it kills me dead - Page 3 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-13-2012, 08:55 PM   #61
Jeeper
 
dentguy's Avatar
 
Join Date: Jul 2011
Location: springfield, mo
Posts: 39
So i just finished wiring all the old stuff back in and BAM...started up as easily as it used to. Set the timing but i still need to adjust (running rich..eyes burning) but, its running...until i forgot to put the vacuum hose back on the advance and eventually flooded it again while revving up from idle. So long story short, i think i may have gotten a bad HEI dizzy since its runnung now with the old dizzy. I do have to point out that i got more help and suggestions from everyone here than i did from anywhere else so THANKS EVERYONE. That was my 2nd HEI i have put in before and i never had so much trouble. Jeeps are definately like women...lol

dentguy is offline   Quote Quick Reply
Old 03-14-2012, 04:51 AM   #62
2xs
Cali Smog Nazi.

WF Supporting Member
 
2xs's Avatar
 
Join Date: Jun 2011
Location: Santa Rosa, Ca.
Posts: 2,379
Images: 3
I will never understand why you guys call a distributor a dizzy....
The professional in me flinches every time i see it....

So, you have stock timing components in it again? are you going to try the GM HEI again at a later date?

__________________
'93 Black YJ, 4.0L AX15 - UNDER CONSTRUCTION!
http://www.wranglerforum.com/f330/2x...ad-490865.html

Old Jeep that was totaled:
http://www.wranglerforum.com/f330/2x...ad-101879.html
2xs is offline   Quote Quick Reply
Old 03-14-2012, 08:09 AM   #63
Jeeper
 
dentguy's Avatar
 
Join Date: Jul 2011
Location: springfield, mo
Posts: 39
Yes all my old oem components are back in. I haven't given up on the HEI and going to go at it again once I get the new exchange. I haven't heard much about the upgrade kits for the old distributors so I may look into that
dentguy is offline   Quote Quick Reply
Old 03-14-2012, 11:51 AM   #64
Jeeper
 
darkproximity's Avatar
 
Join Date: Feb 2011
Location: Not Spokane, WA
Posts: 12,000
Quote:
Originally Posted by 2xs
I will never understand why you guys call a distributor a dizzy....
The professional in me flinches every time i see it....

So, you have stock timing components in it again? are you going to try the GM HEI again at a later date?
The english call it a dizzy.. makes sense, distributor that spins in circles...
__________________
Apache chief, e ne chuk!
darkproximity is offline   Quote Quick Reply
Old 03-14-2012, 07:09 PM   #65
Jeeper
 
Always Stuck's Avatar
 
Join Date: Sep 2010
Location: South of Boston Ma
Posts: 515
[QUOTE=dentguy;2137250]So i just finished wiring all the old stuff back in and BAM...started up as easily as it used to. Set the timing but i still need to adjust (running rich..eyes burning) but, its running...until i forgot to put the vacuum hose back on the advance and eventually flooded it again while revving up from idle. So long story short, i think i may have gotten a bad HEI dizzy since its runnung now with the old dizzy. I do have to point out that i got more help and suggestions from everyone here than i did from anywhere else so THANKS EVERYONE. That was my 2nd HEI i have put in before and i never had so much trouble. Jeeps are definately like women...lol[/QUOTE

Your ABSOLUTELY right this forum has the best people. There always willing to jump in and help.

Glad to here you got it running and I'm sure you'll get the HEI in and working well.
__________________
-------------------------------------------
Where did all my money go O ya I bought a Jeep....

My 94 Buildhttp://www.wranglerforum.com/f118/le...gin-68903.html
Always Stuck is offline   Quote Quick Reply
Old 03-14-2012, 08:12 PM   #66
Jeeper
 
dentguy's Avatar
 
Join Date: Jul 2011
Location: springfield, mo
Posts: 39
I am very impressed with everyone willing to take the time to help others out! As for the HEI, im thinking that the pick up could have been bad since i tested everything else. Nothing else could really be the problem so im sending it back and exchanging for another new one

dentguy is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!! Fit 35's Nicks99 TJ General Discussion Forum 9 03-05-2012 10:32 AM
Think I got it Overthink WF New Member Check In 12 03-05-2012 05:06 AM
Grab Handles for my 6 Year Old to help get into back seat sunnykk JK General Discussion Forum 11 03-04-2012 10:34 PM
I broke it now !! jerryj TJ General Discussion Forum 12 03-04-2012 09:11 PM
Need Help determing current lift size shockey67 TJ General Discussion Forum 8 03-04-2012 08:19 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:17 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC