Help! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-30-2013, 09:54 AM   #1
Newb
 
Join Date: May 2013
Posts: 1
Help!

'93 Wrangler 2.5L, 4 cyl, manual trans - Here's the problem: it won't start! Seriously, it acts as if the engine is not getting gas. It started out as a "hit and miss", sometimes it would start and sometimes it wouldn't. I took it to a mech who said it was the CPU. He ordered and replaced it. I drove it home and had the same issue. I took it back to the mech who "check everything" and could not find a problem. I specifically asked about the fuel system (lines, filter, pump). He said they were all good. It finally stopped running for good.

I replaced the plugs, plug wires, and distributor; checked the ignition coil; then replaced the fuel filter and fuel pump. Still won't start (does turn over though). When I pour fuel directly in, it will fire, sputter, then die. It seems as if it is just not getting fuel to the engine. Any ideas where I should check next?

Thanks

speedloader is offline   Quote Quick Reply
Old 05-30-2013, 10:11 AM   #2
Jeeper
 
Join Date: May 2013
Posts: 18
Quote:
Originally Posted by speedloader View Post
'93 Wrangler 2.5L, 4 cyl, manual trans - Here's the problem: it won't start! Seriously, it acts as if the engine is not getting gas. It started out as a "hit and miss", sometimes it would start and sometimes it wouldn't. I took it to a mech who said it was the CPU. He ordered and replaced it. I drove it home and had the same issue. I took it back to the mech who "check everything" and could not find a problem. I specifically asked about the fuel system (lines, filter, pump). He said they were all good. It finally stopped running for good.

I replaced the plugs, plug wires, and distributor; checked the ignition coil; then replaced the fuel filter and fuel pump. Still won't start (does turn over though). When I pour fuel directly in, it will fire, sputter, then die. It seems as if it is just not getting fuel to the engine. Any ideas where I should check next?

Thanks
You need to check for fuel pressure and if you getting power to the injectors if you get power then your injectors are clogged or bad check all fuses and relays

regiojeep78 is offline   Quote Quick Reply
Old 05-31-2013, 04:39 AM   #3
Jeeper
 
Join Date: Aug 2009
Location: Hinesville, Ga
Posts: 237
My 94 did the same thing, I replaced all kinds of stuff. Then got word from another forum about a relay C104, mounted on the firewall next to the battery. I opened it up and cleaned it with electronic cleaner and hooked it back up. It corrected my problem and I have not had the no start blues since.
tim2 is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:56 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC