Help Diagnose Starting issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-04-2011, 10:40 AM   #1
Newb
 
Join Date: May 2011
Posts: 4
Help Diagnose Starting issue

I own an 87 YJ with the 2.5 4 cyl with a 5 speed. It is fuel injected and is bone stock under the hood.
Here is the issue. When you get in it and turn the key it tries to fire over but it will not run. It tries and tries but nothing. Sometimes if you pop the spark plug wire off the spark plug closest to the radiator it will fire over on three cyl. you pop the plug wire back on and you are good to go. Sometimes it will restart all day long, other times it will not restart right after you shut it down.

I checked the fuel pump and it is getting fuel, pressure in the lines. It is getting spark, I checked everything including changing out the coil. I also thought it might be the cam position sensor so I swapped that out as well. I would say it might be the timing but I do not think so as when it does decide to start it purrs like a kitten.

Does anyone have any ideas on this issue? I have one idea left but other than that I am clueless here. Thanks

Iluvnos is offline   Quote Quick Reply
Old 06-04-2011, 11:34 AM   #2
Jeeper
 
92greensahara's Avatar
 
Join Date: May 2011
Posts: 22
it might be the ignition module. i had something like that happen with my 87 but it was the carbed 4.2. it would run fine but it would stall randomly then it wouldnt start back up for awhile. it would backfire then restart. changed the ignition module and it stopped. i cant tell you if its that for sure but its worth looking at.

92greensahara is offline   Quote Quick Reply
Old 06-04-2011, 11:54 AM   #3
Newb
 
Join Date: May 2011
Posts: 4
Quote:
Originally Posted by 92greensahara View Post
it might be the ignition module. i had something like that happen with my 87 but it was the carbed 4.2. it would run fine but it would stall randomly then it wouldnt start back up for awhile. it would backfire then restart. changed the ignition module and it stopped. i cant tell you if its that for sure but its worth looking at.
thanks... that is the next thing I am going to try after I check the fuel pressure to the injector. You are supposed to have 46 psi in the line and if I am not hitting that all the time it may be the fuel pump or regulator.

If the test kit shows good pressure, I am going to try the ignition module.
Iluvnos is offline   Quote Quick Reply
Old 06-04-2011, 11:58 AM   #4
Jeeper
 
92greensahara's Avatar
 
Join Date: May 2011
Posts: 22
no problem man happy to help. be glad yours insnt backfiring i had to replace a brand new muffler because of that lol
92greensahara is offline   Quote Quick Reply
Old 06-04-2011, 12:53 PM   #5
Newb
 
Join Date: May 2011
Posts: 4
Quote:
Originally Posted by 92greensahara View Post
no problem man happy to help. be glad yours insnt backfiring i had to replace a brand new muffler because of that lol
it does backfire every ow and then, but I can feel it coming as the jeeps starts to bog down a bit before it does it. When I feel it starting to do that I just push the clutch in give her a little rev and then continue on... gotta put Christine back in her place LMAO
Iluvnos is offline   Quote Quick Reply
Old 06-04-2011, 02:25 PM   #6
Newb
 
Join Date: May 2011
Posts: 4
ok fuel pressure check and it looks good. Now after i put the fuel line back to normal (taking the tool off the line) it is starting every time now. Lets see if this continues. Anyone have an idea why this would be the case?
Iluvnos is offline   Quote Quick Reply
Old 06-05-2011, 06:45 AM   #7
Jeeper
 
92greensahara's Avatar
 
Join Date: May 2011
Posts: 22
mine too it would start to bog down and sputter but i tried everything to keep it running but nothing worked. i couldnt even roll start it after it happened. i rolled down 50 ft of a hill trying to no avail lol.

92greensahara is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough running TJ - Electric or Fuel issue?? 666 TJ General Discussion Forum 4 07-01-2012 11:00 AM
93 YJ 6Cyl 4.0 Starting Issue lemonmerchant YJ Tech Forum 14 02-24-2011 10:34 AM
Latest Issue of JPFreek Adventure Magazine - View it for FREE! txoutdoorx4 Classifieds Archive 0 04-15-2010 06:59 PM
YJ starting issue aness2323 General Jeep Discussion 1 11-25-2009 03:26 PM
Rough Idle and Starting Issue crashnburn54 TJ Tech Forum 6 10-30-2009 09:11 AM


» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:05 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC