Help! I am pulling my hair out with my jeep's engine cut-off problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 11-02-2010, 09:52 PM   #1
Join Date: Jun 2010
Location: Las Vegas
Posts: 5
Help! I am pulling my hair out with my jeep's engine cut-off problem

I am hoping that some of you jeep brainiacs out there can help with a suggestion of the problem with my 1992 Jeep Wrangler 4.0 hi-output. Symptoms: backfire from time to time....cuts off when driving, cuts off when idling low (like at stoplights)...however, will start up pretty much immediately after it cuts off. Very slow driving speed seems to avoid the cutoff problem (like 10 to 15 mph).
Since this problem starting about 4 weeks ago, we have put new parts in for: distributor, magnetic pick up, crank shaft sensor, and the ignition switch. The ignition switch was replaced yesterday and I had a full day of excellent ++ engine performance, and today, it began the same problem...cutting off when I was driving, and at intersections when engine slows. Just before cutting off, it "burps" like rough engine performance, and then dies.....any help out there...PLEASE!!

HRDRCKN is offline   Quote
Old 11-02-2010, 10:03 PM   #2

WF Supporting Member
Fweaky's Avatar
Join Date: Aug 2009
Location: Central Virginia
Posts: 2,223
Backfire usually means rich fuel mixture is igniting in exhaust system. Could be O2 sensors or maybe TPS.

Nothing is foolproof to a sufficiently talented fool.
Fweaky is offline   Quote
Old 11-02-2010, 10:07 PM   #3
Join Date: Jun 2010
Location: Las Vegas
Posts: 5
I was just advised about the TPS today-- although the backfiring seems to be a side-issue with the cutoff problem being my main focus. We did replace the O2 sensor as well. thanks.
HRDRCKN is offline   Quote
Old 11-02-2010, 10:27 PM   #4
Join Date: Oct 2010
Posts: 203
Does it do it at will or only after the engine's good and warmed up and everything under the hood is nice and heat soaked? I've also heard of a fuel pump causing a similar issue. Dying pump or intermittant power/ground to the fuel pump could cause that type of behavior.
444 is offline   Quote
Old 11-02-2010, 10:35 PM   #5
Join Date: Jun 2010
Location: Las Vegas
Posts: 5
Yesterday morning, we replaced the ignition switch and it ran great all day-- up to this afternoon. Today, the engine was fairly cold, in that it had not been started for at least a couple of hours. I was only about 2 blocks away from home when it started acting up again.
HRDRCKN is offline   Quote
Old 11-02-2010, 10:35 PM   #6
Join Date: Jun 2010
Location: Las Vegas
Posts: 5
We did test the fuel pressure and there seems to be plenty of pressure.
HRDRCKN is offline   Quote
Old 11-03-2010, 12:52 PM   #7
damacct's Avatar
Join Date: Oct 2010
Location: Hoover, AL
Posts: 84
TPS corrected all my cranking and shutoff issues.
damacct is offline   Quote
Old 09-08-2011, 12:47 PM   #8
Seinb's Avatar
Join Date: Sep 2011
Posts: 21
could be a wiring issue had some thing like that happen to my ford threw parts at it.
follow and check your wiring harness and all plugs look for chafing and broken plugs or lose wires in plugs. can be time consuming but better than wasting money on parts.

Seinb is offline   Quote

help w/ 92 wrangler

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Seafoam? bato TJ Tech Forum 81 03-17-2014 01:37 PM
What does 4WD actually mean? 97'wrangler TJ General Discussion Forum 12 09-08-2011 03:41 PM
Phantom Engine Problem dhayes TJ Tech Forum 12 02-04-2011 06:46 PM
Consistent Idle problem, sputter @ idle-3000 whippet14 YJ General Discussion Forum 5 01-26-2006 07:41 AM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:00 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC