HELP! New alternator, but battery not staying charged! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 06-27-2012, 05:58 PM   #1
Join Date: Apr 2012
Posts: 1
HELP! New alternator, but battery not staying charged!

My '88 YJ has a new alternator that I just put in yesterday but coming back from school, the battery suddenly died. Any ideas?

Also, looked inside the car and saw an unconnected wire (orange). Wanna know if that has anything to do with it!
Thanks for the help!
PS!! Here are some photos of the wires I saw unconnected

nikomann02 is offline   Quote
Old 06-27-2012, 07:04 PM   #2
Redrider94's Avatar
Join Date: Aug 2010
Posts: 663
Look at the back of your alt and see if that plugs in somewhere, looks like that may be your field wires. Or it may plug in to the voltage reg on the firewall.
Redrider94 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:06 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC