High Idle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-07-2013, 03:45 PM   #1
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
High Idle

I have a 91 2.5. It idles high at around 1200 rpm. When pressing the clutch while driving the rpm stays around 2100 rpm and takes a few seconds to go down. I have replaced vacuum lines from the regulator, MAP, clutch, PCV,. Replaced IAC, MAP and TPS. Recently replaced 02 sensor,dist cap and rotor. Radiator flushed and today I changed the oil. Removed and cleaned throttle body and checked for leaks.

O2 sensor brand is Spectra Premium
IAC brand is bwd

MAP and TPS is Crown

Upon close inspection I found a crack in the brake booster grommet. I will be replacing it tomorrow since I found it after the store closing time.

Anything else that I can check? Did I miss anything?

Megamonster is offline   Quote
Old 08-08-2013, 11:16 AM   #2
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Replaced the grommet and no change in idle.

Megamonster is offline   Quote
Old 08-08-2013, 01:17 PM   #3
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Any ideas?
__________________
91 YJ 2.5 Manual
Megamonster is offline   Quote
Old 08-08-2013, 01:27 PM   #4
Jeeper
 
1987Wrangler YJ's Avatar
 
Join Date: Jun 2013
Posts: 568
have you checked for leaks around the intake manifold?
1987Wrangler YJ is offline   Quote
Old 08-08-2013, 01:59 PM   #5
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
I did but will recheck again to make sure.
Megamonster is offline   Quote
Old 08-08-2013, 03:28 PM   #6
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Quote:
Originally Posted by 1987Wrangler YJ View Post
have you checked for leaks around the intake manifold?
No leaks
Megamonster is offline   Quote
Old 08-08-2013, 03:45 PM   #7
Jeeper
 
1987Wrangler YJ's Avatar
 
Join Date: Jun 2013
Posts: 568
could be a pinched throttle cable, check that. make sure there is no dirt or debris that would cause the butterfly valve to stick open
1987Wrangler YJ is offline   Quote
Old 08-08-2013, 03:47 PM   #8
Jeeper
 
dguire792's Avatar
 
Join Date: Jul 2013
Location: Fairmont WV
Posts: 144
Mine did the same thing except it had a lot higher idle like 2500 but after I changed some vacuum line and the exhaust and intake manifold gasket it dropped way down I would check that to see if there are any leaks around it.
dguire792 is offline   Quote
Old 08-08-2013, 04:13 PM   #9
Jeeper
 
Join Date: Apr 2013
Location: The Woodlands, Tx
Posts: 58
any update?
CumminsGift is offline   Quote
Old 08-08-2013, 05:16 PM   #10
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
[QUOTE=1987Wrangler YJ;4055470]could be a pinched throttle cable, check that. make sure there is no dirt or debris that would cause the butterfly valve to stick open[/QUOTE

Checked the cable and it looks fine. Removed the throttle body and gave it another cleaning. Still high. When I start it, it goes to 1000 rpm then it does like it going down then it revs up to 1200 rpm or so. Check for exhaust leaks using the rag in the tailpipe and everything sounds ok.
Megamonster is offline   Quote
Old 08-10-2013, 02:18 PM   #11
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Well I got side tracked by a skid plate full of gas. Here are the spots. So further troubleshooting of the idle issue is postponed until I fix the gas leak.
Attached Thumbnails
Click image for larger version

Name:	IMG_2257.jpg
Views:	27
Size:	235.6 KB
ID:	284172   Click image for larger version

Name:	IMG_2258.jpg
Views:	24
Size:	236.6 KB
ID:	284173  

Megamonster is offline   Quote
Old 08-10-2013, 02:28 PM   #12
Jeeper
 
Join Date: Feb 2013
Posts: 793
If that is the rear if the jeep that looks like a problem with either a fuel line coming from the tank or maybe a roll over valve is this a carb or fuel injection?

If fuel injection check your fuel pump
89Saharagreen is offline   Quote
Old 08-10-2013, 05:45 PM   #13
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Quote:
Originally Posted by 89Saharagreen View Post
If that is the rear if the jeep that looks like a problem with either a fuel line coming from the tank or maybe a roll over valve is this a carb or fuel injection?

If fuel injection check your fuel pump
Fuel injection. I am hoping it is a fuel line rather than a faulty pump.
Megamonster is offline   Quote
Old 09-30-2013, 07:34 AM   #14
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Fixed the gas leak after month and a half waiting for parts.

Can a high idle be caused by a thermostat stuck open? My jeep runs cooler since I flushed the radiator.
__________________
91 YJ 2.5 Manual
Megamonster is offline   Quote
Old 10-24-2013, 01:05 PM   #15
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Update: replaced thermostat and it running a lot better. Tighten the exhaust manifold bolts and it got a little better. I am thinking a new gasket will fix it but the exhaust manifold looks bad so I am afraid to remove it and find a crack. So I am going to replace the manifold as well. Does anyone knows a good quality brand of exhaust manifold that won't cost a lot?
Megamonster is offline   Quote
Old 03-03-2014, 01:23 PM   #16
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Update: Since I replaced the exhaust manifold and the gasket it runs a lot better. However, it idles high around 1200. After checking everything again and not finding anything that could cause it I decided to put it in the back burner for the time being. Then last night as I was visiting other forums i stumbled upon this:

Yes, Another Jeep High Idle Thread - JeepForum.com

which led me to this: Cleaned throttle body now idling higher and acting different.. - JeepForum.com

Being out of ideas I decided to take a look at the adjusting screw and lo! it was actually keeping the butterfly open. the screw head was worn out so the PO adjusted it to compensate for an issue. i took it out, replace it and set it to where it look normal for a closed throttle. Reinstalled it, fire it up and behold! it spools down, it idles great.

__________________
91 YJ 2.5 Manual
Megamonster is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:47 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC