High idle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-03-2013, 04:31 PM   #1
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
High idle

Hey guys, just did the 4.0 tb swap to my 2.5 and now it idles too high. What can I do to remedy this?

ddferdt is offline   Quote Quick Reply
Old 10-03-2013, 04:39 PM   #2
Supporting Member

WF Supporting Member
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,862
[QUOTE=ddferdt;5063841]Hey guys, just did the 4.0 tb swap to my 2.5 and now it idles too high. What can I do to remedy this?[/QUOTE

Use the 4.0 IAC on the 4.0 TB. I had the same problem.

__________________
I'M FLEXY AND I KNOW IT

95 YJ, 2.5 AX15 conversion, 4.0 TB, SOA +1.5", 33" DC Crusher Tires, 8.8 Rear w/welded tubes + LSD, Spartan Locker HP30 Front w/solid axle swap, Rocky Road OTT kit, Safari Snorkel, Warn VR8000 Winch, Smittybuilt front Bumper, JKS Disconnects, AA SYE, Teraflex Shock Bar in Rear, 1/2" Boomerang Shackles, RE Add a Leafs, Homebrew Traction Bar, Monstalined in&out, LED Tail lights, 1700 Watt Stereo
OverkillYJ is offline   Quote Quick Reply
Old 10-03-2013, 04:46 PM   #3
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
I'm assuming that's the bigger of the two sensors?
ddferdt is offline   Quote Quick Reply
Old 10-03-2013, 04:54 PM   #4
Supporting Member

WF Supporting Member
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,862
If you are looking down on the TB with the sensors in the back it would be the one on the right. It is a plunger mechanism. The other is just a sensor. I am assuming you swapped both sensors off the TB with your 2.5 sensors when you swapped the TB?
__________________
I'M FLEXY AND I KNOW IT

95 YJ, 2.5 AX15 conversion, 4.0 TB, SOA +1.5", 33" DC Crusher Tires, 8.8 Rear w/welded tubes + LSD, Spartan Locker HP30 Front w/solid axle swap, Rocky Road OTT kit, Safari Snorkel, Warn VR8000 Winch, Smittybuilt front Bumper, JKS Disconnects, AA SYE, Teraflex Shock Bar in Rear, 1/2" Boomerang Shackles, RE Add a Leafs, Homebrew Traction Bar, Monstalined in&out, LED Tail lights, 1700 Watt Stereo
OverkillYJ is offline   Quote Quick Reply
Old 10-03-2013, 04:59 PM   #5
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
Quote:
Originally Posted by OverkillYJ View Post
If you are looking down on the TB with the sensors in the back it would be the one on the right. It is a plunger mechanism. The other is just a sensor. I am assuming you swapped both sensors off the TB with your 2.5 sensors when you swapped the TB?
Yes I swapped both sensors. Still getting high idle though
ddferdt is offline   Quote Quick Reply
Old 10-03-2013, 05:36 PM   #6
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
So I swapped the IAC over and it's still idling high. I left the 2.5 tps on though. Any ideas?
ddferdt is offline   Quote Quick Reply
Old 10-03-2013, 05:45 PM   #7
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
No vacuum leaks....did you drive it for a few miles so the computer can " learn" the new stuff.
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 10-03-2013, 06:00 PM   #8
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
Quote:
Originally Posted by Garyk View Post
No vacuum leaks....did you drive it for a few miles so the computer can " learn" the new stuff.
I "reset" the computer so to speak if that's what you mean
ddferdt is offline   Quote Quick Reply
Old 10-03-2013, 06:28 PM   #9
Supporting Member

WF Supporting Member
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,862
You didnt get the seal between the TB and intake manifold tight enough then. I like to RTV mine. I went through a lot of crap with a high idle. It ended up for me being that I needed to use the 4.0 IAC instead of the 2.5 everyone recommended.
__________________
I'M FLEXY AND I KNOW IT

95 YJ, 2.5 AX15 conversion, 4.0 TB, SOA +1.5", 33" DC Crusher Tires, 8.8 Rear w/welded tubes + LSD, Spartan Locker HP30 Front w/solid axle swap, Rocky Road OTT kit, Safari Snorkel, Warn VR8000 Winch, Smittybuilt front Bumper, JKS Disconnects, AA SYE, Teraflex Shock Bar in Rear, 1/2" Boomerang Shackles, RE Add a Leafs, Homebrew Traction Bar, Monstalined in&out, LED Tail lights, 1700 Watt Stereo
OverkillYJ is offline   Quote Quick Reply
Old 10-03-2013, 06:34 PM   #10
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
Quote:
Originally Posted by OverkillYJ View Post
You didnt get the seal between the TB and intake manifold tight enough then. I like to RTV mine. I went through a lot of crap with a high idle. It ended up for me being that I needed to use the 4.0 IAC instead of the 2.5 everyone recommended.
I'll try again tomorrow. Ran out of daylight, and apparently my droplight exploded. Thanks for the input, maybe it'll go better tomorrow
ddferdt is offline   Quote Quick Reply
Old 10-03-2013, 06:37 PM   #11
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
After a change sometimes it takes up to 30 miles for the computer to learn new stuff.
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 10-04-2013, 04:58 PM   #12
Newb
 
Join Date: Aug 2013
Posts: 6
Some years just have to go over 50 mph to relearn the idle air setting.
Witgen01 is offline   Quote Quick Reply
Old 10-04-2013, 05:01 PM   #13
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
Quote:
Originally Posted by Witgen01 View Post
Some years just have to go over 50 mph to relearn the idle air setting.
So it wouldn't destroy anything if I drove it with it idling at around 2k?
ddferdt is offline   Quote Quick Reply
Old 10-04-2013, 06:13 PM   #14
Supporting Member

WF Supporting Member
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,862
When it comes to idle you will know when you fix it right away. Same way that if you had it on a engine stande you would have a proper idle. Hitting the 50mph mark does tune things more with some models, but the idle should work immediately. Did you make sure the TB is sealed to the intake?
__________________
I'M FLEXY AND I KNOW IT

95 YJ, 2.5 AX15 conversion, 4.0 TB, SOA +1.5", 33" DC Crusher Tires, 8.8 Rear w/welded tubes + LSD, Spartan Locker HP30 Front w/solid axle swap, Rocky Road OTT kit, Safari Snorkel, Warn VR8000 Winch, Smittybuilt front Bumper, JKS Disconnects, AA SYE, Teraflex Shock Bar in Rear, 1/2" Boomerang Shackles, RE Add a Leafs, Homebrew Traction Bar, Monstalined in&out, LED Tail lights, 1700 Watt Stereo
OverkillYJ is offline   Quote Quick Reply
Old 10-04-2013, 06:59 PM   #15
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
Quote:
Originally Posted by OverkillYJ View Post
When it comes to idle you will know when you fix it right away. Same way that if you had it on a engine stande you would have a proper idle. Hitting the 50mph mark does tune things more with some models, but the idle should work immediately. Did you make sure the TB is sealed to the intake?
Going to work on that tomorrow. Got some rtv today just to be sure. It seemed sealed to me, I did torque it down nice
ddferdt is offline   Quote Quick Reply
Old 10-05-2013, 12:29 PM   #16
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
Okay, so I retried the swap today. After I first turned it over it was idling normally but as it sat the rpms went slowly higher. Any ideas?
ddferdt is offline   Quote Quick Reply
Old 10-05-2013, 09:37 PM   #17
Jeeper
 
Join Date: Jan 2013
Posts: 212
Vacuum leak!!!!!!!!!
__________________
1991 YJ 4.0L, K&N air filter, SS headers, 31X10.5, Congo Cage, etc...
CMike357 is offline   Quote Quick Reply
Old 10-05-2013, 10:58 PM   #18
Supporting Member

WF Supporting Member
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,862
Quote:
Originally Posted by ddferdt View Post
Okay, so I retried the swap today. After I first turned it over it was idling normally but as it sat the rpms went slowly higher. Any ideas?
Yeah. Not necessarily a vacuum leak. The computer will slowly open the air. What iac did you start with, what do you have in now?
__________________
I'M FLEXY AND I KNOW IT

95 YJ, 2.5 AX15 conversion, 4.0 TB, SOA +1.5", 33" DC Crusher Tires, 8.8 Rear w/welded tubes + LSD, Spartan Locker HP30 Front w/solid axle swap, Rocky Road OTT kit, Safari Snorkel, Warn VR8000 Winch, Smittybuilt front Bumper, JKS Disconnects, AA SYE, Teraflex Shock Bar in Rear, 1/2" Boomerang Shackles, RE Add a Leafs, Homebrew Traction Bar, Monstalined in&out, LED Tail lights, 1700 Watt Stereo
OverkillYJ is offline   Quote Quick Reply
Old 10-06-2013, 06:04 AM   #19
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 217
Quote:
Originally Posted by OverkillYJ View Post
Yeah. Not necessarily a vacuum leak. The computer will slowly open the air. What iac did you start with, what do you have in now?
Fixed the problem, all running smooth now. Just a stupid gasket problem. Wasn't seating right
ddferdt is offline   Quote Quick Reply
Old 10-06-2013, 07:36 AM   #20
Supporting Member

WF Supporting Member
 
OverkillYJ's Avatar
 
Join Date: Jun 2012
Location: Philadelphia, PA
Posts: 2,862
Quote:
Originally Posted by ddferdt View Post
Fixed the problem, all running smooth now. Just a stupid gasket problem. Wasn't seating right
Nice to know it is solved!

__________________
I'M FLEXY AND I KNOW IT

95 YJ, 2.5 AX15 conversion, 4.0 TB, SOA +1.5", 33" DC Crusher Tires, 8.8 Rear w/welded tubes + LSD, Spartan Locker HP30 Front w/solid axle swap, Rocky Road OTT kit, Safari Snorkel, Warn VR8000 Winch, Smittybuilt front Bumper, JKS Disconnects, AA SYE, Teraflex Shock Bar in Rear, 1/2" Boomerang Shackles, RE Add a Leafs, Homebrew Traction Bar, Monstalined in&out, LED Tail lights, 1700 Watt Stereo
OverkillYJ is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:19 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC