HOWTO: Retain 4wd light with passenger solid axle shaft upgrade - Page 2 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-07-2012, 05:23 PM   #31
Newb
 
Join Date: May 2012
Location: Florida Panhandle
Posts: 14
I have the 4.0 (6 cyl). When the shop put the Posi-Lok in, they simply didn't run the "hot" wire from the actuator unit and butt splice it to the appropriate hot wire that goes to the light. They did run the gound wire. I just need to know which wire is the wire that goes to the 4wd indicator on the dash. Also, my '89 came with California emissions. There's more vacuum banjo work under that hood than most folks can understand. That's why my next move is a Nutter bypass to get all of that vacuum crap gone!

89FLIslander is offline   Quote Quick Reply
Old 05-07-2012, 05:34 PM   #32
Newb
 
Join Date: May 2012
Location: Florida Panhandle
Posts: 14
I have the straight 6 cyl 4.2 L engine. When the shop put the Posi-Lok on, they simply didn't run the hot wire from the actuator to the proper wire to turn the 4wd indicator light on, but they did run the ground wire. They were closed today so I couldn't call them but I will get in touch with them tomorrow. As for the blue/white vacuum hose, when they installed the Posi-Lok, they took the vacuum lines to the front axle out, so I don't know where it went. Anyway, if you'll watch the thread, I'll post the right color wire tomorrow so maybe it will help someone. Thanks for all of your help.

89FLIslander is offline   Quote Quick Reply
Old 05-07-2012, 07:17 PM   #33
Jeeper
 
year1camaro's Avatar
 
Join Date: Feb 2012
Location: Grand Canyon, Az.
Posts: 207
You need to change the indicator on the transfer case from ypur currrent year to a 95 xj.......the wires from the accuator to the new switch are only two wires ..... easy cheesy
__________________
Function over Form
31" A/T's--1" Daystar--XRC8000--4.0HO--Rhino Int. Dual Battery setup
year1camaro is offline   Quote Quick Reply
Old 05-07-2012, 08:52 PM   #34
Newb
 
Join Date: May 2012
Location: Florida Panhandle
Posts: 14
Sorry for the double post. Computer decided to go nuts as I was posting the first one so I thought it didn't go. Will go back to the shop in Panama City tomorrow and see what the scoop is. Will post it as soon as I find out. Thanks again to all.
89FLIslander is offline   Quote Quick Reply
Old 05-08-2012, 12:29 PM   #35
Newb
 
Join Date: May 2012
Location: Florida Panhandle
Posts: 14
Okay, as promised, here is the answer to the mystery. When installing a Posi-Lok, the instructions on how to hook up your factory 4wd indicator light are kinda vague (see above where I posted them). Here is what you do;

On the Posi-Lok actuator, there are two screw terminals on at the end of the unit. The top screw is your ground. The bottom scew is your "hot" lead. Follow the instructions to hook up the ground by simply making a 4" jumper and going from the top lug to one of the four bolts used to install the Posi-Lok actuator. The "hot" lead is a bit more problematic. Because it is on the right (passenger's side) of the front axle, there is not a good way to route the hot lead up to the switch without having a wire dangling underneath ready to be torn off. I used plastic ties and ran the hot lead back along the Posi-Lok cable up to where it came through the firewall, then pushed it into the wireloom to hide it.
NOW - For the part that had me stumped. The instructions say "cut and splice to the OEM wire". Doesn't tell you what color the OEM wire is (as I'm sure they change from model to model) nor does it tell you where to look other than "on some YJs the switch is under the battery tray". Mine wasn't.
On my 1989 Islander with straight 6 cyl. engine, the switch is mounted on the firewall between the battery box and the heater hoses, right by itself, in plain sight. A simple little vacuum switch with a black/yellow wire and a ground wire coming off it. Simply butt splice your hot lead into this black/yellow wire, OR, cut the wire off the vacuum switch and straight slice it into your hot lead. Then, if you want to, you can take the old vacuum switch off and throw it away! You're not using it anymore, anyway!
Thanks to Jamie Carr at Son of a Jeep in Panama City, FL for his help and expertise. Took him all of 2 minutes to point this switch and wire out to me and 1 minute was used opening the hood!
Thanks to jeff in rc on the forum. You were on the money with the black/yellow wire info. I just couldn't find it. I appreciate your trying to help.
89FLIslander is offline   Quote Quick Reply
Old 05-08-2012, 12:45 PM   #36
Jeeper
 
jeff_in_rc's Avatar
 
Join Date: Mar 2012
Location: Ridgecrest, CA
Posts: 1,501
Hey no problems man, you have the solution and that is all that matters!
I'm just glad I could help being a newbie and all! LOL

Now wire it up, test it, and let us know it works!
__________________
2004 RED TJ Rubicon
Member of the Gear Grinders 4WD Club
jeff_in_rc is offline   Quote Quick Reply
Old 05-15-2012, 12:25 PM   #37
Newb
 
Join Date: May 2012
Location: Florida Panhandle
Posts: 14
Just to finish out this issue, I got the hotwire run from the Posi-Lok actuator to the black/yellow wire and spliced in. Guess what? The 4wd indicator light on the dash worked! Here's the deal. It works when you engage the Posi-Lok, not when you move the 4wd shift lever. Makes sense because on the old vacuum system it worked when the (old) actuator moved due to the vacuum being applied from the transfer case. At any rate, now I have an "idiot light" to tell me when my front wheels are engaged!
89FLIslander is offline   Quote Quick Reply
Old 06-13-2012, 10:56 PM   #38
Jeeper
 
phnguyen7's Avatar
 
Join Date: Jun 2012
Posts: 77
I bought the switch and pigtail.. I hooked up one Side to the ground and the other to the black and yellow.. The light didn't turn on. Did I do something wrong?
phnguyen7 is offline   Quote Quick Reply
Old 06-14-2012, 10:25 AM   #39
Jeeper
 
jeff_in_rc's Avatar
 
Join Date: Mar 2012
Location: Ridgecrest, CA
Posts: 1,501
Question Need more info

Quote:
Originally Posted by phnguyen7 View Post
I bought the switch and pigtail.. I hooked up one Side to the ground and the other to the black and yellow.. The light didn't turn on. Did I do something wrong?
OK dumb question time, the switch you got, is that the one on the transfer case? If yes, did you put the transfer case into 4WD?
__________________
2004 RED TJ Rubicon
Member of the Gear Grinders 4WD Club
jeff_in_rc is offline   Quote Quick Reply
Old 06-14-2012, 11:09 AM   #40
Jeeper
 
Join Date: Apr 2010
Posts: 440
might just be me being lazy, but all you guys have to do is just take the vacuum plug off and slice a thin section off, then plug it back onto the pipes again. I had changed my front axles to CV style, and just left the actuator on and plugged in. Leave and or remove the fork inside, thats all. Less hassles running wires, and switches and blah blah. Makes life easy.
Dr. Venture is offline   Quote Quick Reply
Old 06-15-2012, 01:26 AM   #41
Jeeper
 
phnguyen7's Avatar
 
Join Date: Jun 2012
Posts: 77
Quote:
Originally Posted by jeff_in_rc View Post
OK dumb question time, the switch you got, is that the one on the transfer case? If yes, did you put the transfer case into 4WD?
Yeah, found out I didn't ground right. Works great now!
phnguyen7 is offline   Quote Quick Reply
Old 06-15-2012, 01:48 AM   #42
Jeeper
 
darkproximity's Avatar
 
Join Date: Feb 2011
Location: Not Spokane, WA
Posts: 12,000
Quote:
Originally Posted by Dr. Venture
might just be me being lazy, but all you guys have to do is just take the vacuum plug off and slice a thin section off, then plug it back onto the pipes again. I had changed my front axles to CV style, and just left the actuator on and plugged in. Leave and or remove the fork inside, thats all. Less hassles running wires, and switches and blah blah. Makes life easy.
You're still at the mercy of hoping your vacuum lines don't crack somewhere, then have to track them down and mess with them every time. This offers a permanent fix, and is also a solution for people who swap in other axle assemblies all together. I have a Dana 44 front axle out of a 70s Ford truck, no axle disconnect, so that's out of the question for me
__________________
Apache chief, e ne chuk!
darkproximity is offline   Quote Quick Reply
Old 06-15-2012, 10:02 AM   #43
Jeeper
 
jeff_in_rc's Avatar
 
Join Date: Mar 2012
Location: Ridgecrest, CA
Posts: 1,501
Quote:
Originally Posted by phnguyen7 View Post
Yeah, found out I didn't ground right. Works great now!
Good news, glad to hear it has been repaired!
__________________
2004 RED TJ Rubicon
Member of the Gear Grinders 4WD Club
jeff_in_rc is offline   Quote Quick Reply
Old 06-15-2012, 03:19 PM   #44
Jeeper
 
Join Date: Apr 2010
Posts: 440
Quote:
Originally Posted by darkproximity View Post
You're still at the mercy of hoping your vacuum lines don't crack somewhere, then have to track them down and mess with them every time. This offers a permanent fix, and is also a solution for people who swap in other axle assemblies all together. I have a Dana 44 front axle out of a 70s Ford truck, no axle disconnect, so that's out of the question for me
track what down? all the vacuum lines are about 3-4 feet long and are all wrapped in one tube. only line that veers off is the one that comes off the intake manifold to create the vacuum. it is very simple to track a cracked line which is rare to begin with. Common problem is that the rubber grommet that attaches each hose to the trans itself stretches (holes elongate) at the base and allows air to escape. Hence why i say just slice a thin section out with a razor and it will be much tighter. I even used a wire tie to hold it in place for extra added security. ( lightly tightened hose clamp also works)

Dont get me wrong, the new switch and wiring is a great idea, but no need to spend $ the other way, and then you get a good common knowledge on how everything works.

I did the CV axle upgrade, but left the actuator on the shaft. The CV axle diameter is actually smaller than the original split axle shaft so nothing touches regardless. Even if i remove the inner fork it will still work the same. When i had originally done the job i too did not have the 4x4 light come on, then realized ( because i had also rebuilt my tranny) that the grommet was what was causing my issue.

Has worked ever since that last thread i posted about the job i did on my axles. So no further issues on my end.

Both ideas work. Just depends if you wanna spend the $ or keep it OEM either way its the same.
Dr. Venture is offline   Quote Quick Reply
Old 06-15-2012, 03:59 PM   #45
Jeeper
 
darkproximity's Avatar
 
Join Date: Feb 2011
Location: Not Spokane, WA
Posts: 12,000
You can do it this way for basically free.. I'd prefer to get rid of the problem completely, and again this is an option for people who ditch their front axle all together
__________________
Apache chief, e ne chuk!
darkproximity is offline   Quote Quick Reply
Old 06-15-2012, 04:55 PM   #46
Jeeper
 
Join Date: Apr 2010
Posts: 440
Quote:
Originally Posted by darkproximity View Post
You can do it this way for basically free.. I'd prefer to get rid of the problem completely, and again this is an option for people who ditch their front axle all together
Hey if its for free then its for me..lol

But when you say ditch the front axle are you
meaning RWD only?

then what would the point be in having a 4x4 light?
Dr. Venture is offline   Quote Quick Reply
Old 06-15-2012, 05:02 PM   #47
Jeeper
 
jeff_in_rc's Avatar
 
Join Date: Mar 2012
Location: Ridgecrest, CA
Posts: 1,501
I believe he meant swapping out the stock front axle for a stronger unit.
Am I correct Darkproximity?

Either that or he turned it into a 2 wheeler???
Man, I just could NOT resist!
__________________
2004 RED TJ Rubicon
Member of the Gear Grinders 4WD Club
jeff_in_rc is offline   Quote Quick Reply
Old 06-15-2012, 05:04 PM   #48
Jeeper
 
darkproximity's Avatar
 
Join Date: Feb 2011
Location: Not Spokane, WA
Posts: 12,000
No, if they swap in another axle assembly.. Not every front axle has a CAD, and most people avoid CAD axles anyway when swapping.
__________________
Apache chief, e ne chuk!
darkproximity is offline   Quote Quick Reply
Old 08-09-2012, 04:40 PM   #49
Jeeper
 
90DesertTanYJ's Avatar
 
Join Date: Jul 2012
Location: JAX, FL
Posts: 635
I thank you for this write up and I already have a new switch from O Reilly's it was a whole $5.99. I stupidly did not order the weatherpac harness thinking it would be on the shelf somewhere in this shithole of a town in Alabama. I am making money but I hate it here for that reason.

Anyway, I am going to lock my right axle together and do this mod so I know when the transfer case is in 4X4. My vac system is screwed and I dont feel like getting to know it. I understand it perfectly. It was a screwed up system since day one. I am not going to try bandaids to get mine working, I am going to eliminate it. My YJ will not run with the 4X4 system plugged up, I dont know if its the transfer case switch, the CAD or the tubing and I dont care to find out.

Just like DarkProximity said, get rid of the failure prone system. Easy and cost me less than $20.

Thanks DP!
90DesertTanYJ is offline   Quote Quick Reply
Old 08-09-2012, 07:14 PM   #50
Jeeper
 
darkproximity's Avatar
 
Join Date: Feb 2011
Location: Not Spokane, WA
Posts: 12,000
No problem man, glad you found it useful
__________________
Apache chief, e ne chuk!
darkproximity is offline   Quote Quick Reply
Old 08-17-2012, 09:13 PM   #51
Jeeper
 
90DesertTanYJ's Avatar
 
Join Date: Jul 2012
Location: JAX, FL
Posts: 635
Hey DP, is the T/C case switch need to be polarized for the early YJs? Just curious as the switch does have the little slot in it.

Phnguyen, was this your issue or just didnt get a good ground?

Got the weatherpac harness today and my YJ up and running so tomorrow morning I should have a 4X4 light! Another of the hundred insane little issues solved!
90DesertTanYJ is offline   Quote Quick Reply
Old 08-18-2012, 07:36 PM   #52
Jeeper
 
90DesertTanYJ's Avatar
 
Join Date: Jul 2012
Location: JAX, FL
Posts: 635
Never mind guys, I got it all in and works great!!! Thank you DP!

http://www.wranglerforum.com/f8/gott...wf-181315.html
90DesertTanYJ is offline   Quote Quick Reply
Old 02-10-2013, 09:59 AM   #53
Jeeper
 
redmanwalking's Avatar
 
Join Date: Mar 2012
Posts: 343
Need a little clarification. Whats the wiring process for the new pig tail? How do I know which one is the ground? Any special route to take in getting this routed back to the transfer case?

redmanwalking is offline   Quote Quick Reply
Reply

Tags
4wd light , solid axle shaft

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Axle upgrade and swap options jbone03 TJ General Discussion Forum 6 06-15-2011 07:44 AM
Superior Axle's new axle Super Truss kit installed. Jerry Bransford TJ Tech Forum 29 03-19-2009 02:26 PM
knuckle wobbling due to play in front axle shaft SFJeeper TJ Tech Forum 5 01-23-2009 02:09 AM
WTB Dana 30 passenger axle shaft jamesx2 Classifieds Archive 0 10-22-2008 11:04 AM
axle shaft question jeepocalypse YJ Tech Forum 14 10-04-2007 09:55 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC