i need some advice .... been having issues with my 95 Rio Grande - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-16-2012, 09:16 PM   #1
Newb
 
Join Date: Mar 2012
Location: South Western Pennsylvania
Posts: 1
i need some advice .... been having issues with my 95 Rio Grande

Hi guys,
Im new to the forum, and I am looking to hopefully get some advice on my Wrangler. I have had my Jeep for about a year now, and haven't had any problems with it. It is a 1995 Wrangler Rio Grande. She has about 72,000 miles. I was having some problems with it overheating, so I had changed the thermostat and flushed the radiator. Which fixed my problem, but ever since it wont start. The starter clicks like it is a bad solenoid. It will catch in gear, but wont start any other way. I changed the starter today, and that didn't fix the problem. A few months ago I was having issues with the fuse for my gauges blowing all of the time. But that eventually stopped happening randomly. Im wondering now though if those things were connected, because it was the Ign/Starter fuse that blew all of the time I believe. I am a chick with general knowledge of vehicles .... but when it comes to troubleshooting things like this im pretty much at a loss .... Considering the fact I only weigh about 120 pounds soaking wet .... its not always the easiest most convenient task trying to get my jeep moving fast enough to catch it in gear when im not lucky enough to be able to park on a hill, lol. I would love anyyy kind of advice you may have. Or any similar issues u have had, and resolved that could maybe give me an idea of what to try next. I don't know what to turn at this point.


Thank you

Courtney

dreampixie94 is offline   Quote Quick Reply
Old 03-16-2012, 09:19 PM   #2
Jeeper
 
Xpress's Avatar
 
Join Date: Jan 2011
Location: El Cajon
Posts: 2,585
Take a piece of wire or a pair of pliers and try to jump the contacts on the starter solenoid. If the engine cranks over then your problem is the solenoid itself. Flushing the coolant and replacing the thermostat shouldn't cause any form of issue to the misc starting components.

If your ignition fuse is blowing you need to inspect the harness for a short somewhere. Don't try to start it again unless you find the issue, otherwise you can blow more than just a fuse...
__________________


2.5L Genius of some sort.
Xpress is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is My Dealer Lying? shacklyn JK General Discussion Forum 31 03-22-2012 10:42 AM
Front end issues need insight Rwilliamjacob TJ General Discussion Forum 2 03-20-2012 03:02 PM
TJ Diesel with 5 speed? Jo1175 Builders Corner 5 03-19-2012 11:35 AM
Rotation noise on my 2005 Rubicon RyanG TJ General Discussion Forum 8 03-17-2012 07:13 PM
Does anyone have pics of a JK with Flares Removed.... JKLIVIN JK General Discussion Forum 4 03-16-2012 09:15 PM


» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:16 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC