Idle problem? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 09-03-2006, 09:14 PM   #1
sc4x4's Avatar
Join Date: Aug 2006
Location: South Carolina Low Country
Posts: 6
Idle problem?

I have a 1990 with a 4.2, it has an aftermarket carb. that was put on by the previous owner. The motor runs fine as long as I don't stop, as I slow down it will either float between 600 and 1000 rmp or it will drop to 0 and cut out forcing my to pop the clutch or restart the motor. (sometimes it actually works corectly) Is this a common problem? Do I need a new carb or is there a way to adjust the one I have, or do I need to find a replacement? Sorry I do not know the brand of the one on the motor. Any help or suggestions would be great.

sc4x4 is offline   Quote
Old 09-03-2006, 10:25 PM   #2
coilovers are damn flexy
bluvikng's Avatar
Join Date: Mar 2006
Location: Texas
Posts: 3,260
Before you through it away, try giving it a good cleaning with Barryman's carb cleaner. If that does not help, then you might need a rebuild kit.

bluvikng is offline   Quote
Old 09-06-2006, 07:44 AM   #3
3jeepguy's Avatar
Join Date: Aug 2005
Location: upstate ny
Posts: 119
the carbs on the 4.2 are real pains to deal with even the aftermarket versions of the carter suck i would suggest a weber or a holley / motorcraft conversion
95 yj 4.0 4 inch bds and 1.5 shackle lift 33inch swampers for summer and 32 inch mudkings for winter 8500# milemarker winch and homemade high lift / light mount on hood

3jeepguy is offline   Quote
Old 09-06-2006, 07:55 PM   #4
sc4x4's Avatar
Join Date: Aug 2006
Location: South Carolina Low Country
Posts: 6
Thanks for the input, I went and saw a buddy of mine, after about an hour of timing adjustment, cleaning the carb and re-routing a couple of vacume lines we were able to get it to clear up.
Again thanks for the input.
sc4x4 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
4.2 carb problems stray YJ Tech Forum 20 09-29-2014 11:02 PM
Idle problem and MAP sensor ROLYAK TJ Tech Forum 15 05-23-2014 05:36 PM
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
1997 Brake and Idle Problem norml CJ General Discussion Forum 0 12-21-2008 05:14 PM
Consistent Idle problem, sputter @ idle-3000 whippet14 YJ General Discussion Forum 5 01-26-2006 08:41 AM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:33 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC