idling/acceleration problems. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-22-2010, 04:12 PM   #1
Newb
 
Join Date: Feb 2010
Location: new york
Posts: 7
Unhappy idling/acceleration problems.

Hi all I'm new here so go easy on me! So if you read my intro you know I got Karl as a gift and its a great gift but he has a few issues. The main one is that when cold he's hard to start. It'll take at least two attempt to get him fired up and when I do I need to keep on the accelerator to keep him going. He's fine for the most part once warmed up but the odd time when shifting in higher gears he,ll stall likes he's not getting any fuel or maybe too much. Its not a constant problem just happens every now in then. I've given him all the basi tune up thing including a fuel filter so its not that or air filter spark plugs etc. Its a carter carb and I read how to clean it here or somewhere. Did that too. Nothing has really made any difference. I'm told its prob the fuel pump or a dirty tank? Do you guys agree? Cos that my next mission. I have the haynes manual so I'm learning everyday lol. Just wondering what else I can check. Thanks for reading this. I'll try keep my post shorter. In future lol.

gungadin is offline   Quote Quick Reply
Old 02-22-2010, 04:24 PM   #2
Jeeper
 
Bignuke's Avatar
 
Join Date: Mar 2009
Location: Fort Mill, SC
Posts: 1,057
It could be the pump... Have you checked the battery and the starter?

Bignuke is offline   Quote Quick Reply
Old 02-22-2010, 04:39 PM   #3
Newb
 
Join Date: Feb 2010
Location: new york
Posts: 7
Yeah it has a new battery and I haven't checked the starter. But when i turn the key i need to keep tapping the gas pedal to get him to fire? I'll add that to the list though! But that wouldn't affect it while driving right? Jut feels like its not getting enough gas at times or else its choking itself with gas.
gungadin is offline   Quote Quick Reply
Old 02-22-2010, 08:32 PM   #4
Supporting Member

WF Supporting Member
 
scott howard's Avatar
 
Join Date: Dec 2009
Location: wichita falls texas
Posts: 1,035
If you have a 4.2 you need to do a nutter bypass and set the timing to 8 degrees and set the metering rods on the carter to the closed position and make sure the choke is working right or just change it to a manual choke.
all the above can be done for less then 15 dollars.
__________________
Scott Howard
940-444-1972
scott howard is offline   Quote Quick Reply
Old 02-24-2010, 07:14 PM   #5
Newb
 
Join Date: Feb 2010
Location: new york
Posts: 7
Hey thanks for that scott. I've read some of your posts on the nutter bypass. I was wondering if its a must do on thhe 4.2? I'm not questioning its effectiveness. More my ability to do it! like is anything else I do a bit of a waste of time without doing the bypass? Really want to get it running right and if it has to be done i'l just have to grow a pair and do iit! Also do you think replacing the cat con would help? I have a feeling its blocked as mileage is horrible also. Thanks for your help.
gungadin is offline   Quote Quick Reply
Old 02-24-2010, 07:48 PM   #6
Jeeper
 
Bignuke's Avatar
 
Join Date: Mar 2009
Location: Fort Mill, SC
Posts: 1,057
Yeah check cat con.. check your intake too, not sure if you checked that yet... Friend had a problem with his mustang gt and he had the same problems, said it was an intake problem...
Bignuke is offline   Quote Quick Reply
Old 02-25-2010, 07:26 PM   #7
Jeeper
 
lawdawg's Avatar
 
Join Date: Oct 2009
Posts: 21
Go with MC2100 carb and eliminate all your carb problems. Also what others have said: nutter bypass and do the Team Rush. With the team rush mod I found through trail & error that .55 gap on Autolite plugs was right on the money. The team rush is a great & inexpensive mod and will help with your starting and idling problems. Good luck
__________________
Lawdawg
[SIGPIC]
lawdawg is offline   Quote Quick Reply
Old 02-25-2010, 10:35 PM   #8
Jeeper
 
tlrrob1000's Avatar
 
Join Date: Jul 2009
Location: Pain is a gift...Fear is not an option!
Posts: 786
Images: 23
When we bought our 90 with 4.2 we also had all these problems. Started going through everything ie; tune up, carb rebuild, fuel filter, numerous carb adjustments guess what I found.... nylon coating on the timing chain sprockets came off. Way too much slack! Changed the timing chain and gears and Hello issues are gone. I also actually found that someone also had bumped the distributor one tooth in order to get it to time. It never made tapping or slapping sounds. Only found it because I had an oil leak on the front cover. Only had 112,000 miles on it. How many miles do you have?
HAve not done the nutter yet and unfortunatly Can't change over to the 2100 due to Cali emissions. Runs GReat now so not worried about it for now.

__________________
No Bad Days!
tlrrob1000 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to fix all vacume problems and how to locate the problems. Captaincoop1220 YJ Tech Forum 50 02-23-2013 12:19 PM
major 88 wrangler problems please help 88wranglerLa YJ Tech Forum 5 11-09-2009 08:43 PM
New YJ, New (old?) Problems fyallm YJ General Discussion Forum 6 07-10-2009 11:17 AM
Fuel injector cleaner caused major problems. NEED HELP!! dwilliams59 YJ Tech Forum 2 03-14-2008 10:52 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:34 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC