Ignition Coil Blowing Out - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-13-2010, 03:44 PM   #1
Jeeper
 
andiesel's Avatar
 
Join Date: Sep 2010
Location: Goleta, CA
Posts: 594
Send a message via AIM to andiesel
Ignition Coil Blowing Out

Hi all,

I've got a 93 jeep wrangler. Bought it from a mechanic who was doing short drives around his town every couple of weeks for the last 6 months. I got about 60 miles down the 101 hwy before the ignition coil blew out and I had to tow it to a shop (really a tow yard with a part time mechanic) 4 hours away from home.

$200 later (for a $20 part) they said the coil is bad, but everything else is just fine.

I drove up this Saturday and got another 60 miles away from the shop (both drives it's staying steady at 3000 RPMs) and the engine cut out again. Felt exactly the same as last time.

I upgraded my AAA tow package and had it hauled back home with my trusty mechanic. Since Saturday I've talked to quite a few people and everyone is placing money on the voltage regulator/alternator, distributor, or condensor.

My question is if I do replace one or all of those parts what can I do to keep this from happening again? Are there any upgrades, or known mods to keep this system from failing? Spare parts and easy fixes to carry in the jeep?

Thanks!

Andii

andiesel is offline   Quote Quick Reply
Old 09-13-2010, 04:06 PM   #2
Jeeper
 
Join Date: Aug 2007
Location: So Cal.
Posts: 1,146
Most coils have a resistor or a resistive going to the coil so the voltage at the coil is less than 12 v, more like 6 IIRC, when the resister or resistive wire goes bad and a full 12v goes to the coil, then the coil will run real hot until it goes bad. So I guess what I am saying is to check ( and I don't remember if the YJ has a resistor or a resistive wire) and see if you have 12 volt or less at the coil.

Donn

__________________
My Jeep is NOT an suv and Your suv is NOT a Jeep
30-284 is offline   Quote Quick Reply
Old 09-13-2010, 04:11 PM   #3
Jeeper
 
andiesel's Avatar
 
Join Date: Sep 2010
Location: Goleta, CA
Posts: 594
Send a message via AIM to andiesel
ok - so I should get a digital multimeter to keep with me. I trust my mechanic 100% but I've vowed to do my own repairs from now on. thanks for the help.
andiesel is offline   Quote Quick Reply
Old 09-13-2010, 04:33 PM   #4
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,459
Not a bad idea....you should be able to get cheap one for a few bucks
Ibuildembig is offline   Quote Quick Reply
Old 09-13-2010, 07:58 PM   #5
Jeeper
 
Jeep Nurse's Avatar
 
Join Date: Jul 2010
Location: North Georgia
Posts: 146
Things that make you go hmmm....

Quote:
Originally Posted by andiesel View Post
Hi all,

I've got a 93 jeep wrangler. Bought it from a mechanic who was doing short drives around his town every couple of weeks for the last 6 months. I got about 60 miles down the 101 hwy before the ignition coil blew out and I had to tow it to a shop (really a tow yard with a part time mechanic) 4 hours away from home.

$200 later (for a $20 part) they said the coil is bad, but everything else is just fine.

I drove up this Saturday and got another 60 miles away from the shop (both drives it's staying steady at 3000 RPMs) and the engine cut out again. Felt exactly the same as last time.

I upgraded my AAA tow package and had it hauled back home with my trusty mechanic. Since Saturday I've talked to quite a few people and everyone is placing money on the voltage regulator/alternator, distributor, or condensor.

My question is if I do replace one or all of those parts what can I do to keep this from happening again? Are there any upgrades, or known mods to keep this system from failing? Spare parts and easy fixes to carry in the jeep?

Thanks!

Andii
When the engine quits what happens? Does the engine just shut down?

With the KEY ON ... do you have a reading on your volt gauge? (on the dash)

START the engine...turn the key to start, what does the gauge do?
Jeep Nurse is offline   Quote Quick Reply
Old 09-14-2010, 12:46 PM   #6
Jeeper
 
andiesel's Avatar
 
Join Date: Sep 2010
Location: Goleta, CA
Posts: 594
Send a message via AIM to andiesel
The Jeep loses all power when the engine quits...no power steering, brakes, etc. I didn't check the gauges immediately as both situations were relatively dangerous trying to maneuver the Jeep to the side of the road.

When I did try to get the engine started again there was no movement on any gauge for anything that I remember.

The first coil blew without explanation, and the engine started back up again roughly 3 seconds after it died and promptly spit out fire before dying completely (tried sparking with fuel in the engine). When the second coil went out the engine just cut out.

I got it back from my mechanic last night. He said he scoured the whole system and couldn't find anything wrong - he believes the first shop put in a really cheap coil and overcharged me...it just wasn't strong enough to work with my Jeep. So I'm going to fight the first shop to get a refund.

Not sure if this helps with your questions.
andiesel is offline   Quote Quick Reply
Old 09-14-2010, 01:01 PM   #7
Jeeper
 
PTaylor's Avatar
 
Join Date: Jul 2009
Location: South Carolina
Posts: 721
Almost sounds like a bad or loose ground somewhere....

the reason I say is becuase electricity will still flow with no ground, it will find a path to flow through. Usually, this winds up damaging something.

So, you have had two coils go bad in this short time, and it still does the same thing?


One coil going bad.....ehhhh, it happens. two in such a short time? naw, sorry, something is causing it. are you sure they replaced the coil?

Can they prove the coil is bad instead of "we replaced it, it works now, turn the page..."
PTaylor is offline   Quote Quick Reply
Old 09-14-2010, 01:54 PM   #8
Jeeper
 
andiesel's Avatar
 
Join Date: Sep 2010
Location: Goleta, CA
Posts: 594
Send a message via AIM to andiesel
Trust me I'm still a little skeptical. I'm figuring that the first one that blew out could have been old, and the Jeep hadn't been driven on the fwy in over 6 months, just occasional drives around town so I'll chalk that one up to an old part that gave out.

The second one got me pretty worried and I immediately came to the same conclusion - something else in the wiring is going wrong and blowing out my coils. But my mechanic is insisting he's checked out the whole car and can't find a single thing wrong with the wiring. His answer to me was that the 2nd coil was a cheap $10 part and couldn't cut it.

So at this point I'm going to get my money back from the first shop and keep a spare coil just in case.
andiesel is offline   Quote Quick Reply
Old 09-14-2010, 02:23 PM   #9
Jeeper
 
PTaylor's Avatar
 
Join Date: Jul 2009
Location: South Carolina
Posts: 721
Almost sounds like the new BMW bugs.... If you were going across country, you better carry a box of coils with you!

I hope that solves your problem, I hate riding around in an unreliable vehicle. I'm fighting with a truck that the brakes like to give out on at the wrong moment. yours will leave you stranded, mine will leave me in....strands.


Thought I had it licked, until the other day.....
PTaylor is offline   Quote Quick Reply
Old 09-14-2010, 02:26 PM   #10
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,459
what kinda truck PT?
Ibuildembig is offline   Quote Quick Reply
Old 09-14-2010, 02:36 PM   #11
Jeeper
 
PTaylor's Avatar
 
Join Date: Jul 2009
Location: South Carolina
Posts: 721
Quote:
Originally Posted by Ibuildembig View Post
what kinda truck PT?
Ford Ranger, '88. v6, 2.9L.

It did this early in the summer, I was carrying a LARGE load of vynl siding, the pedal went alway to the floor with no stopping going downhill. People in front of me were turning so I was dodging in and out of traffic while pumping the breaks.

they finally caught and locked the tires down, like you would expect when you hit the pedal hard. So, one minute nothing, next, everything is alright.

Man, that scared the sh!t out of me, I wanted to stop and get 10 beers to calm my nerves but that's all I needed to have it happen again and having beer breath.

I went home, added more fluid and bled the brakes. everything seemed ok.

Then the other morning, same thing. so, either I've got air still in it or the master cylinder is going bad...maybe. that's all I can think of at the moment.
PTaylor is offline   Quote Quick Reply
Old 09-14-2010, 02:39 PM   #12
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,459
Hmmm that is odd...no leaks? Could potentially be the proportioning valve too
Ibuildembig is offline   Quote Quick Reply
Old 09-14-2010, 03:24 PM   #13
Jeeper
 
andiesel's Avatar
 
Join Date: Sep 2010
Location: Goleta, CA
Posts: 594
Send a message via AIM to andiesel
Quote:
Originally Posted by PTaylor View Post
Almost sounds like the new BMW bugs.... If you were going across country, you better carry a box of coils with you!

I hope that solves your problem, I hate riding around in an unreliable vehicle. I'm fighting with a truck that the brakes like to give out on at the wrong moment. yours will leave you stranded, mine will leave me in....strands.


Thought I had it licked, until the other day.....

Dang...that's tricky. My Jeep's brakes are a little squishy for my taste but it's a work in progress. I'm taking it this weekend to a guy in town who does military restorations for war games to get an estimate on a towbar. My front bumper is a little crowded with hellas and a winch...
andiesel is offline   Quote Quick Reply
Old 09-14-2010, 07:50 PM   #14
Jeeper
 
andiesel's Avatar
 
Join Date: Sep 2010
Location: Goleta, CA
Posts: 594
Send a message via AIM to andiesel
ok so from some light research and consulting some engineers I'm going to test the coil tonight to see what kind of voltage is going in there. It seems that initially when you start the engine there should be the 12v going in and then it should drop to 8-9v. I'm going to go pick up a multimeter and some copper wire to set into the plug and see if the voltage is dropping or if it's staying steady at 12v...which would definitely kill the coil.

fingers crossed.
andiesel is offline   Quote Quick Reply
Old 09-14-2010, 10:15 PM   #15
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,459
just be careful around the coil wire you could end up having an afro
Ibuildembig is offline   Quote Quick Reply
Old 09-15-2010, 02:21 AM   #16
Jeeper
 
mameyj's Avatar
 
Join Date: Aug 2009
Location: los angeles
Posts: 50
I was having the same problem with my 87, the coil would get really hot and would just shut off. was getting over 12v to the coil, later found out the coil didn't have a resistor. I got a ballast resistor from Autozone part #8214 and now its only getting about 9v, and haven't had the problem since.
mameyj is offline   Quote Quick Reply
Old 09-15-2010, 01:17 PM   #17
Jeeper
 
Jeep Nurse's Avatar
 
Join Date: Jul 2010
Location: North Georgia
Posts: 146
Check your PMs

Jeep Nurse is offline   Quote Quick Reply
Reply

Tags
coil , distributor , engine problems , ignition

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to replace the ignition coil Vaultzz YJ Tech Forum 6 06-29-2010 10:01 AM
disconnecting ignition coil D-EZ1 General Jeep Discussion 0 11-16-2009 09:15 PM
Blistered Ignition Coil, Rough at Idle sgblakley TJ Tech Forum 0 04-12-2009 09:18 PM
ignition coil info? sonofabeach TJ Tech Forum 1 02-06-2009 08:30 PM
Blowing ignition modules Grandpa Jeeper YJ Tech Forum 12 09-04-2007 11:48 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:49 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC