instrument panel lights and rear lights are out - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-11-2010, 08:25 PM   #1
Newb
 
Join Date: Jul 2010
Posts: 14
instrument panel lights and rear lights are out

Hey guys, was wondering if its something obvious I'm missing.
My 89 Jeep Wrangler Islander got only bikini top so after a heavy rain my instrument panel lights went out. All the gages are working and turn signals and check engine but the light behind instrument panel not working.
I thought it was a fuse and checked all of them under the dash and they seem working. I also saw two black big ones relays? fuses? next to the battery under the hood. Not sure what they are.
Suddenly now I also noticed my rear lights are out. Brake lights and backing up lights working but not regular ones. When I turn on the headlights, they work but no instrument panel lights or rear lights. I dont think the bulbs are burned out.
Any ideas? I can't drive now this jeep at night because I'm afraid of getting a ticket without the rear lights, so I'm trying to fix this asap.
Thanks for any help you can provide.

Kommy000 is offline   Quote Quick Reply
Old 08-11-2010, 08:58 PM   #2
Jeeper
 
FNjeep's Avatar
 
Join Date: Jul 2010
Location: Everett, WA
Posts: 266
That certainly sounds like a relay problem Kommy000.

The tricky problem with relay's, is that they can be difficult to see if they've gone bad with a visual inspection. With most fuses, you can look for burn marks, but since relay's are in a little box, you can't always be sure.

Start popping out relays until you find the correct one causing the problem, or spend $30 dollars or so and replace them all.

Either option, let us know what happens.

FNjeep is offline   Quote Quick Reply
Old 08-11-2010, 09:05 PM   #3
Aka Vaultzz

WF Supporting Member
 
Vaultzz's Avatar
 
Join Date: Jul 2009
Location: My Secret Lab
Posts: 5,624
or just pry off the relay cap, I tried to pull the starter relay on my YJ and the plastic cap just ripped off and I saw the inside all burned
__________________
The YJ is in Rebuild Mode
Vaultzz is offline   Quote Quick Reply
Old 08-12-2010, 12:13 AM   #4
Jeeper
 
FNjeep's Avatar
 
Join Date: Jul 2010
Location: Everett, WA
Posts: 266
Wink

Now *that* sounds like an interesting story Vaultzz.
FNjeep is offline   Quote Quick Reply
Old 08-12-2010, 12:37 AM   #5
Jeeper
 
jeepr's Avatar
 
Join Date: Jun 2010
Location: Littleton Colorado
Posts: 390
Fuse or relay probably a fuse though, the same thing happened to me when I had an 89 easy fix though at least... hope that helps.
jeepr is offline   Quote Quick Reply
Old 08-12-2010, 08:18 PM   #6
Newb
 
Join Date: Jul 2010
Posts: 14
Yea, I checked all the clear fuses and they all ok. There is one fuse all the way in the bottom row middle that has metal cover, cant see if its good or not. I think its 30 amp one. I will change all of them anyway.
What are those 2 relays right next to the battery under the hood? I'm thinking about changing them too just in case.
Also I see 2 round relays on top row of the fuses but I think those are hazard lights and turn signal lights which work, just no clicking sound. Don't know if it makes a difference.
Maybe I should just change all of them and all of the fuses just in case. Will try tomorrow...
Kommy000 is offline   Quote Quick Reply
Old 08-12-2010, 10:17 PM   #7
Jeeper
 
madrnch's Avatar
 
Join Date: May 2010
Location: wetumpka alabama
Posts: 136
my 93 had the same problem i had to replace the switch
madrnch is offline   Quote Quick Reply
Old 08-13-2010, 08:42 PM   #8
Newb
 
Join Date: Jul 2010
Posts: 14
Ok, I changed all the fuses and 2 relays under the hood, the one was horn relay and that works so didnt bother changing. Also changed big 30 amp circuit braker on the fuse panel. the old one was 5.2 amp for some reason.
Anyways, thought I had my lights working on the back, checked now at night and nope, no instrument panel lights and no rear lights just brake and back lights. Light bulbs are not burnt out.
Got my replacement dimmer switch, will change it my next day off, hopefully it will fix everything. Funny thing... I swore I saw my rear lights work right after I did all the work, so not sure if it was all in my head or they did work for a little while, so why not now. There was no rain, I didnt drive it. Sigh.....
Kommy000 is offline   Quote Quick Reply
Old 08-16-2010, 01:58 PM   #9
Newb
 
Join Date: Jul 2010
Posts: 14
Hmm, got wrong dimmer switch. Checked Autozone and Napa parts nobody has dimmer switch for jeep or can even find one to order. I brought the old one and at most they were able to find official name Rheostat Switch but nobody was able to find this part to order.
I feel like I'm in twilight zone. It's a simple part , why can't I find it?
Kommy000 is offline   Quote Quick Reply
Old 08-16-2010, 02:46 PM   #10
Jeeper
 
UABYJ94's Avatar
 
Join Date: Apr 2010
Location: Panama City
Posts: 210
Take a meter and verify you are getting power thru the 5amp fuse(10) to the guages from the dimmer switch for the dash lights. If not then check to make sure power is coming the headlight switch to the dimmer switch. Should be a blue wire feeding the dimmer from headlight switch and a pink/orange wire feeding the gauge lights from the dimmer.
Check the mounting bolts for the tail lights, that's where they get the ground.
UABYJ94 is offline   Quote Quick Reply
Old 08-17-2010, 05:11 PM   #11
Jeeper
 
Join Date: Jul 2010
Posts: 79
in my 95 im having a similar but oposite problem i dont have brake lights but my tails work and my relay is buzzing but when i turn my lights on or turn dash lights off it stops buzzing and my relay for that is under the center of the dash by my radio, but i dont think i have a relay problem
Travis91 is offline   Quote Quick Reply
Old 08-17-2010, 05:33 PM   #12
Jeeper
 
booboy75's Avatar
 
Join Date: Apr 2010
Location: Oswego,Illinois
Posts: 79
Quote:
Originally Posted by Kommy000 View Post
Hmm, got wrong dimmer switch. Checked Autozone and Napa parts nobody has dimmer switch for jeep or can even find one to order. I brought the old one and at most they were able to find official name Rheostat Switch but nobody was able to find this part to order.
I feel like I'm in twilight zone. It's a simple part , why can't I find it?

I have that problem two months ago. It could be your switch like someone else said. I took my light switch apart from the dash and clean the terminals and hook it back up and it came back on. Happen to me yesterday while driving again. I reach my fingers behind the switch and push the terminals connections together. The connections get loose from bouncing around. Replace your switch or check your connections on the switch. I have a 89 also
booboy75 is offline   Quote Quick Reply
Old 08-19-2010, 08:48 AM   #13
Jeeper
 
UABYJ94's Avatar
 
Join Date: Apr 2010
Location: Panama City
Posts: 210
Get one from an early 90's model S-10. We share the same steering column and alot of other parts that alot of different manufaturers used in their vehicles.

UABYJ94 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear driving lights out along with instrument cluster? NickBoudin TJ Tech Forum 5 04-08-2010 12:24 PM
instrument cluster, fog lights inop dmonster TJ Tech Forum 0 07-12-2009 02:02 PM
Adding rear lights Jma20a TJ General Discussion Forum 7 03-24-2009 04:09 PM
rear view mirror with map lights and batteries? dwdrums801 General Jeep Discussion 5 06-02-2007 04:11 PM
Installed My Backup Lights YellowRubiU TJ General Discussion Forum 11 12-07-2006 09:11 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:49 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC