is it my water pump neck or clamp issues? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-05-2011, 11:29 PM   #1
Newb
 
Join Date: Nov 2011
Posts: 4
Exclamation is it my water pump neck or clamp issues?

I have a 1992 Jeep YJ as a daily driver and right now it sits in the garage with a big green pool underneath of it...(sigh). I was heading home the other night and my heater wasn't blowing any hot air... the next morning checked the coolant level and was super low. After a quick refill drove around town a few days and checked it later and it was low again. So I crawled my lazy underneath and noticed that my lower radiator hose was leaking from the water pump end. Removed the hose and found that it had a tear inside where I assumed the water was traveling through and thus causing the leak. no one in town had the proper hose so I bought a flex hose instead. Attached hose and refilled the radiator again, started up and crawled back down to check for leak... small leak coming from the inside part... looks like it is leaving the water pump neck and forced up between the neck and hose and out...very small drip but continuous... all in all what I thought was going to be a quick replacement and solution is still my problem... possibly worse than before. Not sure if it is the clamp, hose, or water pump... or simply I am just an idiot and overlooking something? Any suggestions? Thanks in advance!

Ytread is offline   Quote Quick Reply
Old 11-06-2011, 12:07 AM   #2
Newb
 
Join Date: Aug 2011
Posts: 10
Can you wiggle your fan attached to the water pump? I had a similar problem and replaced all hoses. It ended up being the pump. It was leaking from behind the pump pulley and dripping down the hose. You can get a water pump and all hoses from advanced auto.com for under 100 bucks.

Also replace stock hose clamps with the type you screw on. The old ones can wear down, or so I've been told.

keybler is offline   Quote Quick Reply
Old 11-06-2011, 01:13 AM   #3
Jeeper
 
draarong2004's Avatar
 
Join Date: May 2011
Posts: 499
Quote:
Originally Posted by keybler View Post
Can you wiggle your fan attached to the water pump? I had a similar problem and replaced all hoses. It ended up being the pump. It was leaking from behind the pump pulley and dripping down the hose. You can get a water pump and all hoses from advanced auto.com for under 100 bucks.

Also replace stock hose clamps with the type you screw on. The old ones can wear down, or so I've been told.
i've never trusted the stock clamps on anything being re-used, i always opt for the screw down clamps....
also did you put any sealant between the hose and the water pump? in any repair manual it recomends blue rtv or equiv to help seal it up better, i had to do this when i replaced my radiator in my jeep recently, no matter how i clamped it down it still leaked a lil around brand new hoses and brand new radiator, now it doesn't leak ANYWHERE.
draarong2004 is offline   Quote Quick Reply
Old 11-06-2011, 02:33 AM   #4
Newb
 
Join Date: Nov 2011
Posts: 4
Keybler No wiggle in the fan.. leading me to believe that it's not the water pump failing but possibly could be a crack in the neck... all clamps are the screw on, that's the first thing that I do with a vehicle because the clamp ones are rediculous!!! BUT they are not brand new so could be an issue...

draarong2004 I did not put any sealant around either the water pump nor the hose... I'll give it a shot in the morning though... nice going on your end though! No leaks are good!

Thanks to both of your responses, I really appreciate it. I'm gonna give it another run and see where I am... gotta get it back up by Monday!
Ytread is offline   Quote Quick Reply
Old 11-06-2011, 03:21 AM   #5
Jeeper
 
draarong2004's Avatar
 
Join Date: May 2011
Posts: 499
its a neverending battle with any vehicle, but i fix everything i can as fast as i can, and so far i don't have any new leaks yet, i'm sure somethings going to leak tomorrow while wheeling though...lol
draarong2004 is offline   Quote Quick Reply
Old 11-06-2011, 12:18 PM   #6
Newb
 
Join Date: Nov 2011
Posts: 4
Dra, I know what you're saying... I'm thinking the only reason it's leaking now is because it finally rained here and it's nice and muddy now that the Jeep is garaged!
Ytread is offline   Quote Quick Reply
Old 11-06-2011, 07:47 PM   #7
Jeeper
 
Join Date: Aug 2011
Location: Pennsylvania
Posts: 86
The lower hose has a spring in it. My pump went out on me after doing a flush so I decided to change hoses while I was replacing pump. Still had the stock ones on. The only place I could find one with a spring was the stealership. I was told you should get it because it might close up from pressure and cause overheating.
Franklin3 is offline   Quote Quick Reply
Old 11-06-2011, 09:28 PM   #8
Newb
 
Join Date: Nov 2011
Posts: 4
Franklin3-- I'll check into the spring deal...the old one I took off did not have one on it but that doesn't say anything... Whoever wrenched on this thing before I bought it...eek! I have found some shotty work so far...not good.

UPDATE-- replaced flex hose with new hose and clamps as well...still freaking leaking! This makes my mechanical skills look bad! I think it's worse than before...I am left to believe that it is my water pump... I have not put sealer on yet and may not... I gotta take it in and have it looked at cuz its my daily driver and can't have it break too bad!
Ytread is offline   Quote Quick Reply
Old 11-07-2011, 07:43 AM   #9
Jeeper
 
draarong2004's Avatar
 
Join Date: May 2011
Posts: 499
if you have any white lightning grease or can buy a small tub of it, get it and try putting that on first. it'll help seal it but also make it so you can get it back off if you need to, you can use this instead of rtv or the like if you don't have any majore leaking issues, i just used rtv on mine because i didn't plan on taking them off the new radiator again...or the block, if i do, i might be able to get it back off.

draarong2004 is offline   Quote Quick Reply
Reply

Tags
antifreeze , hose , leak , radiator , water pump

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing a water pump on a 4.0 in a 95' YJ. Got_Mud? YJ Tech Forum 12 08-10-2014 12:06 AM
heavily Leaking coolant not water pump cfish133 TJ General Discussion Forum 9 07-22-2011 04:39 PM
water pump issue lonewolf6224 YJ Tech Forum 1 05-14-2011 05:31 PM
Water pump problem? oIIIIIIo TJ General Discussion Forum 10 03-02-2011 12:22 AM
Interior Water issues HELP TOW69 JK General Discussion Forum 14 07-07-2010 07:18 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:58 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC