issues still - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-09-2013, 08:50 PM   #1
Newb
 
Join Date: May 2013
Location: Jacksonville, NC
Posts: 8
issues still

Okay heres the issue. My 95 yj Rio Grande with 2.5 4 banger still shuts off while driving. Gauges don't die and I've checked fuel pressure. So I've changed my IAC, TPS, Plugs and wires, fuel filter, map sensor, new computer, checked fuel pressure, etc. I have a fuel pump, distributor cap, and rotor button. With that being said almost everything has been looked at. Tomorrow I'm getting a crank position sensor. I must be doing something wrong. Lol please help. Yj only has 37k on it bone stock. So nothing major has ever been done to it. Never been off road hard so idk what it could be. Any help would be great!

teamrealtree93 is offline   Quote
Old 06-09-2013, 10:20 PM   #2
Jeeper
 
DirtyRob's Avatar
 
Join Date: Sep 2011
Location: Sampson County N.C.
Posts: 1,155
Images: 3
My 90 YJ would lose fire when the cps went out on the way up a mountain trail. It ran fine when I got back to the tow rig. Very frustrating. The cps is a common issue. I carry a spare when wheeling now.
__________________
wherever you go there you are..........
DirtyRob is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC