Jeep bogs down after warm up - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 05-03-2010, 05:39 AM   #1
Join Date: Apr 2010
Location: So Cal
Posts: 1
Jeep bogs down after warm up

My 89 Jeep bogs down after it warms up, the cat is hollowed out, new fuel pump, egr valve, fuel filter, air cleanger, pcv valve, and it still runs poorly after 10 to 15 mins of driving.

starts up and idles fine, and now backfires once when shut off.

Any suggestions? I have had this ride for almost 20 years with relatively few problems and I would like to keep it going for another 20

TJ Ryan is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep towing problem IBHIPRU General Jeep Discussion 6 05-29-2012 07:33 PM
Biggest Jeep Freek Contest!!!! txoutdoorx4 Classifieds Archive 6 02-21-2011 11:48 AM
History of the Jeep. George T. General Jeep Discussion 8 02-04-2009 02:03 AM
Had the best ride in my Jeep so far.... hedonist Off-Topic 8 01-08-2008 11:06 AM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:35 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC