Jeep died while driving...no power to ne thing - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-01-2009, 10:03 PM   #1
Newb
 
Join Date: Nov 2009
Location: Montana
Posts: 4
Jeep died while driving...no power to ne thing

Hey all...1st post!
I purchased a 1989 Wrangler for my lad (ok..for me but don't tell him that). Anyway, he was driving last night and all of a sudden, the thing just died. He said it felt like someone turned off the ignition. He rolled to a stop and called me.
Upon my arrival, I found that when I turned the key, I get NADA!!! No gauges, not spark, no crank, no radio...just crickets.

I am wondering if this could be the Ignition Switch? It is UGLY under the dash. Old wires and bad connections. Also, if it is the IS, can someone give me some tips on how to get it out. I have fat sausage fingers that don't fit well.

Help Please!!!
Thanks

wrangler_noob is offline   Quote Quick Reply
Old 11-01-2009, 11:06 PM   #2
Aka Vaultzz

WF Supporting Member
 
Vaultzz's Avatar
 
Join Date: Jul 2009
Location: My Secret Lab
Posts: 5,624
Woah, slow down buddy, before you start ripping out wires have you gotten the battery checked? Always start with the beginning (and easiest) of possible problems then move up the list into the tougher stuff

__________________
The YJ is in Rebuild Mode
Vaultzz is offline   Quote Quick Reply
Old 11-02-2009, 12:37 AM   #3
Newb
 
Join Date: Nov 2009
Location: Montana
Posts: 4
I have checked the battery. In fact, I have checked the coil, the starter, the plugs, etc..The battery is fine...
As I mentioned, there is no power anywhere there should be once the ignition is put into "start".
I have headlights, but they are hardwired into a switch straight off the battery.

I'm open to any and all suggestions. Thanks!
wrangler_noob is offline   Quote Quick Reply
Old 11-02-2009, 01:12 AM   #4
Aka Vaultzz

WF Supporting Member
 
Vaultzz's Avatar
 
Join Date: Jul 2009
Location: My Secret Lab
Posts: 5,624
Well you said before that theres some "unprofessional wiring" under the dash so theres a chance that something important got disconnected (mines the same way ) I'd look around for anything that's hanging or touching a ground that shouldn't be.
__________________
The YJ is in Rebuild Mode
Vaultzz is offline   Quote Quick Reply
Old 11-02-2009, 09:12 AM   #5
after birthday glow
 
morphious's Avatar
 
Join Date: Jul 2009
Location: wisconsin
Posts: 1,963
Images: 1
ok if the ignition does nothing then chances are that is ur prob but to be sure check all the grounds and then check for voltage off the switch is u have no voltage then that's ur prob let us know what u find so we can give u a hand in diagnosing
__________________
some say why i say
its a jeep thing u wouldn't understand
morphious is offline   Quote Quick Reply
Old 11-02-2009, 11:47 PM   #6
Newb
 
Join Date: Nov 2009
Location: Montana
Posts: 4
Ok..I have looked at all the electrical under the dash..it is a mess...However, the one problem that stands out is a small black box thing that has snap connectors on both sides.
One side looks like it comes off of the ignition switch. The other side goes up to the harness and disappears.
Anyway...i don't know what it is but it the connector that runs to the harness has a loose wire... hanging on by one strand.

This part is hanging down under the left side of the dash by the e-brake release. One side of it has a patch of loop (hook & loop..aka..velcro). The wires are pretty tight and I can't get it to drop down any more. I am going to do my best to jerry-rig this to see if it is the problem. I would rather just buy a new part, but I don't know what it is called.
Any thoughts?
I will take a photo in the AM when there is light and post it.
thanks

Jim
wrangler_noob is offline   Quote Quick Reply
Old 11-03-2009, 07:19 PM   #7
Newb
 
Join Date: Nov 2009
Location: Montana
Posts: 4
Ok...Solution!!!!

First..the vehicle stopped because a main wire leading to the power distribution center (PDC) had fried. Don't know why, but it did. This is a bit concerning as I have fixed it with a slightly larger gauge wire and I am now afraid something bad will happen, but at least it will be exciting.

Second, I only found the main problem AFTER I changed the ignition switch. So, just to keep my sanity, I am holding on to the thought that the IS was bad and needed changed and only after I did, the wire at the PDC fried...Ok? So..don't tell me different.

And C...the black hangy downy thing is apparently the Turn signal switch. I am going to order a new one and life will be good again!

Thanks to all for your help..I'm sure there will be more in the near future.

Jim

wrangler_noob is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
You know you're driving a YJ when: Incursorio Off-Topic 11 10-13-2011 05:37 PM
What Is The Weirdest Thing You Strapped To Your Jeep? jgano23 General Jeep Discussion 43 01-10-2010 09:08 PM
The jeep just died ? 89PBR96 YJ General Discussion Forum 26 09-21-2009 09:45 PM
2007 Hot Springs Jeep Jamboree USA review jeeptales On The Trail 0 11-16-2007 10:15 AM
Gave my fiance that jeep thing..... njatrtljp Off-Topic 17 11-11-2007 12:39 PM



» Featured Product

All times are GMT -5. The time now is 02:28 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC