Jeep doesn't run with lights on. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-04-2010, 10:38 AM   #1
Newb
 
Join Date: Sep 2010
Location: cleveland
Posts: 5
Jeep doesn't run with lights on.

Hi everybody I'm new to the forum. I just bought my first Jeep it's a 1990 wrangler with a 4cylinder and a 5spd and it has 164,000 miles. The problem I'm having is it runs great with the lights off, but when I turn them on the Jeep studders and barely stays running. I just replaced the oxygen sensor, pcv valve, and replaced the heater core and did the back brakes. It ran fine when I brought home, even with the lights on. I don't know if maybe I knocked something loose under the dash when I removed the heater box or what I did. Any help would be great. Thanks.

BigC is offline   Quote Quick Reply
Old 09-04-2010, 10:41 AM   #2
Jeeper
 
Kohrs93's Avatar
 
Join Date: Apr 2010
Location: Moline, IL
Posts: 594
battery? alternator?

__________________
92 2.5L 5 speed - 3" RC lift - Skyjacker Steering Stabilizer - 17" XD HOSS wheels - 315/70r17 BFG All-terrain T/A
Kohrs93 is offline   Quote Quick Reply
Old 09-04-2010, 10:53 AM   #3
Jeeper
 
Join Date: Aug 2010
Location: Virginia
Posts: 38
sounds like kors93 is onto something there. Sounds like the alternator cannot keep up with the electrical load the lights are puting on the system.
vetteguy is offline   Quote Quick Reply
Old 09-04-2010, 11:16 AM   #4
Jeeper
 
PTaylor's Avatar
 
Join Date: Jul 2009
Location: South Carolina
Posts: 718
I've had an alternator belt break before and it did the same thing, run like crap.

you can check it if you have a meter. Google it.
PTaylor is offline   Quote Quick Reply
Old 09-04-2010, 11:18 AM   #5
Jeeper
 
Join Date: Aug 2010
Location: Virginia
Posts: 38
If you take it off auto zone or any auto parts shop will test it for free
vetteguy is offline   Quote Quick Reply
Old 09-04-2010, 02:48 PM   #6
Newb
 
Join Date: Sep 2010
Location: cleveland
Posts: 5
Alright I'm of to the parts store to get the alternator checked out.The Jeep is also wired up with a kill switch underneath the dash. The other night I forgot to turn it off and I had to jump start the battery the next morning. Do think the kill switch has anything to do with it as well?
BigC is offline   Quote Quick Reply
Old 09-04-2010, 04:39 PM   #7
Newb
 
Join Date: Sep 2010
Location: cleveland
Posts: 5
The alternator was bad so I put a new in. I still have the same problem when I turn on the lights 10 seconds later it dies.
BigC is offline   Quote Quick Reply
Old 09-04-2010, 07:34 PM   #8
Deaky

WF Supporting Member
 
Fweaky's Avatar
 
Join Date: Aug 2009
Location: Central Virginia
Posts: 2,202
Images: 18
Check the main ground. The one to engine from battery.
__________________
Nothing is foolproof to a sufficiently talented fool.
Fweaky is offline   Quote Quick Reply
Old 09-05-2010, 09:41 PM   #9
Jeeper
 
austin1869's Avatar
 
Join Date: May 2010
Location: South East Texas
Posts: 53
Ground Wires!!! I had some ground wires go bad in an old Chevrolet one time. I had a stero system in the truck and if the head lights were on the truck would back fire when the base would hit. come to find out the main ground on the battery had a bad spot in it and wouldn't let the current flow properly.
austin1869 is offline   Quote Quick Reply
Old 09-05-2010, 11:06 PM   #10
Jeeper
 
chensley's Avatar
 
Join Date: Jun 2010
Location: Mississippi
Posts: 444
10 bucks says it's a faulty ground, if the alternator was fried he would have not been able to start it up.
chensley is offline   Quote Quick Reply
Old 09-06-2010, 01:34 AM   #11
Member
 
Join Date: Aug 2010
Location: 4wheel heaven
Posts: 211
hello ur in luck I had the same problem but I had to find the wires to the head lights and replace them it work try it
yjforlife is offline   Quote Quick Reply
Old 09-06-2010, 07:30 AM   #12
Jeeper

WF Supporting Member
 
Got_Mud?'s Avatar
 
Join Date: Mar 2010
Location: Charlottesville, VA
Posts: 347
Sounds like a weak ground between the battery and the frame. For about $10 you can just replace the cable. Clean the mounting points *really* well and try it again.
__________________
In dog beers, I've only had one.....
Got_Mud? is offline   Quote Quick Reply
Old 09-06-2010, 07:58 AM   #13
Newb
 
Join Date: Sep 2010
Location: cleveland
Posts: 5
I can run the heater and turn on all the spotlights and the jeep will still runs fine. I'll be replacing the ground and if that doesn't work I'll try the headlight wires.
BigC is offline   Quote Quick Reply
Old 10-28-2010, 04:29 PM   #14
Newb
 
Join Date: Sep 2010
Location: cleveland
Posts: 5
Update... After three alternators and adding numerous ground straps the problem ended up being the dimmer switch. I'm still not sure why it was killing the the jeep, but I put another one and the no more problems. Thanks for all the suggestions. It was a big help.

BigC is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Biggest Jeep Freek Contest!!!! txoutdoorx4 Classifieds Archive 6 02-21-2011 10:48 AM
JEEP JAM - June 5,6th 2010 Mr. T Ohio Jeep Forum 0 04-27-2010 03:43 AM
Newbie with A few ?'s before I purchase a jeep... nickbooma TJ General Discussion Forum 16 05-27-2009 01:04 PM
Some (( Fun )) lights for the inside of my jeep. stinger124 General Jeep Discussion 2 11-16-2007 01:57 PM
2007 Hot Springs Jeep Jamboree USA review jeeptales On The Trail 0 11-16-2007 10:15 AM



» Featured Product

All times are GMT -5. The time now is 12:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC