jeep just stopped!!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-12-2007, 05:52 PM   #1
Jeeper
 
Join Date: Aug 2006
Posts: 52
jeep just stopped!!!!

Its a 91 Jeep. 4 banger. OK I was driving and the Jeep just stopped running. I costed to the side of the road and turned it off, turned the key and the engine started turning (battery, starter etc all fine), but the engine would not fire. I tried again and again, it would turn over, but not fire. What should I check? I'm not sure what to even start looking at.

Thanks for your help.

__________________
91 YJ, Black, 5 speed, 2.5L, recreation vehicle, do you wave at the 4 door wrangler, or not?
itsmyjeep is offline   Quote Quick Reply
Old 11-12-2007, 06:02 PM   #2
Pushy, Loudmouthed, and Ballsy
 
Dare2BSquare's Avatar
 
Join Date: Jul 2006
Location: Driving Around Arkansas In My Black XJ
Posts: 6,177
Silly to ask? ... Does it have gas?

__________________
99 XJ Sport
4.0l
AW4
NP231
d30/C8.25
3" Skyjacker lift
31 x 10.50 General Grabbers


http://i66.photobucket.com/albums/h2...are/TMLogo.gif Are all fishermen liars, or do only liars fish?
Dare2BSquare is offline   Quote Quick Reply
Old 11-12-2007, 06:05 PM   #3
Jeeper
 
Join Date: Aug 2006
Posts: 52
Yes it has gas...and however I have run out of gas before and it seems to choke a little then die...this was more like someone just turned off the key. I thought a fuel pump...I changed the filter 6-8 months ago so I ruled that out...what do you think.
__________________
91 YJ, Black, 5 speed, 2.5L, recreation vehicle, do you wave at the 4 door wrangler, or not?
itsmyjeep is offline   Quote Quick Reply
Old 11-12-2007, 06:06 PM   #4
Jeeper
 
yj4x4's Avatar
 
Join Date: Nov 2007
Location: puyallup, wa
Posts: 152
could be a bad gas gauge and shes empty. it does kind of sound like something just shut off. it could be the fuel pump
__________________

92 yj, 4.0 with 240,000 miles, 3 inch mystery lift(was on when i bought it), 1.5 inch shackle lift, 35/12.50 Super Swamper Thornbirds, Ford 8.8 rear, square tubing custom front drive line, disc brakes all around, 3.55 gears fron and rear,

Shiny side up, Greasy side down
yj4x4 is offline   Quote Quick Reply
Old 11-13-2007, 12:29 PM   #5
Newb
 
Join Date: Nov 2007
Posts: 4
Happened to me before and It ended up being no spark from the distributer
1BusyBoy is offline   Quote Quick Reply
Old 11-13-2007, 02:15 PM   #6
Jeeper
 
Join Date: Apr 2007
Location: Arizona's White Mountains
Posts: 227
Quote:
Originally Posted by 1BusyBoy View Post
Happened to me before and It ended up being no spark from the distributer
I would second that. Could be a failed coil, failed electronics, bad wire to or from the coil and distributor.
Grandpa Jeeper is offline   Quote Quick Reply
Old 11-13-2007, 06:27 PM   #7
Jeeper
 
NY94YJ's Avatar
 
Join Date: May 2005
Location: Malta NY
Posts: 307
Coil.
__________________
'03 TJ Sport on 33's, 2"BB, 1"BL, 1"MML
NY94YJ is offline   Quote Quick Reply
Old 11-19-2007, 09:26 PM   #8
Newb
 
Join Date: Nov 2007
Posts: 1
Same exact thing happened to mine, After I towed it home I replaced the Coil, Distributor cap & Rotor, Checked ECM (Fine), Checked Ignition (Fine) Replaced Crankshaft Positioning sensor, Replaced In-tank fuel Pump, Fuel Filter, Checked Injector. about 200 dollars later I decided to check my distributor drive gear for the hell of it. Pulled it out and the gear was completely stripped. Checked my camshaft gear and it was fine. got a distributor drive gear off of a 4.2 Liter (you can also get them off of any YJ years 87-95 they used the same part the whole time in every single engine. haha.) So after all that I slap in the gear that I paid $2 for at the junkyard and it fired right up. I think it was stripped because the distributor shaft also drives the oil pump and I was running too thick of an oil for the cold temperatures where I live.
QuadsquirrelYJ is offline   Quote Quick Reply
Old 11-19-2007, 09:28 PM   #9
Jeeper
 
orange05tj's Avatar
 
Join Date: Jun 2007
Location: Stop having a boring tuna. Stop having a boring life.
Posts: 3,897
Sounds like it needs round headlights.
orange05tj is offline   Quote Quick Reply
Old 11-19-2007, 10:10 PM   #10
Jeeper
 
whiteyj's Avatar
 
Join Date: Jul 2005
Location: Pleasanton CA
Posts: 4,856
Quote:
Originally Posted by orange05tj View Post
Sounds like it needs round headlights.
Might as well just turn it in for a JK at that rate
__________________
Fallen Angel...Former MOD
whiteyj is offline   Quote Quick Reply
Old 11-20-2007, 11:34 PM   #11
Jeeper
 
Join Date: Jul 2007
Posts: 37
Did u check to make sure u getting fuel pressure? Not that u actually have gas in the tank. I had a bad wire on my jeep and it fried 3 computers in 3 minutes of running; put a new harness in shes great. Just Check for fuel pressure then spark. If u have neither the magic 8-ball points to ECU.
__________________
I still dont understand......

88 YJ 4banger

Currently Building a Chevy 350 for superfun when i get outta college and can afford to actually put the motor in...
Raymond85 is offline   Quote Quick Reply
Old 11-21-2007, 09:25 AM   #12
Jeeper
 
fly's~yj's Avatar
 
Join Date: Mar 2007
Posts: 86
it needs air..it needs fuel..it needs spark..find out which one it's not getting..
fly's~yj is offline   Quote Quick Reply
Old 11-21-2007, 11:16 AM   #13
coilovers are damn flexy
 
bluvikng's Avatar
 
Join Date: Mar 2006
Location: Texas
Posts: 3,260
Same thing happened on my F-350, a couple of weeks ago. It turned out to be the computor that tells the injectors when to fire. I know this is a completely different engine, but the way you described the problem, it is identical to what happened to me. If it was a fuel related problem, you would have sputtered out, and not just died. I am sure that your problem is electrical, in nature. Have your ECU checked at auto zone, as that is probably the best place to start. QuadsquirrelYJ has good info. Check the same way he did.
__________________
bluvikng is offline   Quote Quick Reply
Old 11-23-2007, 11:37 AM   #14
Newb
 
Join Date: Nov 2007
Posts: 8
Same thing happened to my jeep a few weeks back. I did a full tuneup from front to back on my jeep and come to find out, my computer burnt up...

BluJ is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
jeep vs girls mr4x4 Off-Topic 15 08-22-2011 02:00 PM
It's Better In A Jeep Dare2BSquare Off-Topic 0 01-27-2008 09:13 PM
Texas Spur Recap and pics whitebuffalo On The Trail 23 04-11-2007 12:44 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC