jeep starts and runs great then after warming up acts like it is out if time? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-21-2011, 08:10 PM   #1
Newb
 
Join Date: Feb 2011
Posts: 3
jeep starts and runs great then after warming up acts like it is out if time?

My 1993 wrangler 4.0 liter. Starts and runs great. Then somewhere in the warm up cycle runs like it is way out of time.. then after a complete warm up runs great? I have replaced every sensor on this jeep O2, cps, cam position sensor, map sensor, coolant temp sensor, had the pcm rebuilt, new pkugs wires,cap rotor... what am I missing? Please help! I love my jeep want to get her on the road!!

woodfordjay is offline   Quote
Old 02-21-2011, 08:12 PM   #2
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,303
Does this one have a MAT? Its located on the intake.

__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote
Old 02-21-2011, 08:12 PM   #3
Jeeper
 
carlyj's Avatar
 
Join Date: May 2009
Location: Las Vegas, NV
Posts: 180
don't mean to be ignorant. but, .. is the timing set right?
carlyj is offline   Quote
Old 02-21-2011, 08:35 PM   #4
Jeeper
 
crash0515's Avatar
 
Join Date: Jan 2011
Location: White House, TN
Posts: 39
Check your EGR valve. They build up carbon. Sometimes you can simply clean out the carbon, and sometimes you have to replace them.
crash0515 is offline   Quote
Old 02-21-2011, 10:04 PM   #5
Jeeper
 
Jeepin91YJ's Avatar
 
Join Date: Jan 2011
Location: Colorado Springs
Posts: 138
Images: 1
You could also take throttle body off and clean real good.
Jeepin91YJ is offline   Quote
Old 02-22-2011, 07:32 AM   #6
Newb
 
Join Date: Feb 2011
Posts: 3
Yes replaced the Mat sensor. Cleaned the throttle body. But never took it off. I know it is in time have double checked that.
woodfordjay is offline   Quote
Old 02-22-2011, 09:22 AM   #7
Newb
 
Join Date: Feb 2011
Posts: 3
Also replaced the EGR Valve. Jeep still does it... Seams to be running really rich, and backfires through the intake
woodfordjay is offline   Quote
Old 02-22-2011, 10:44 AM   #8
Jeeper
 
Undead-89's Avatar
 
Join Date: Feb 2011
Location: Loveland, CO
Posts: 760
Timing. Clogged Catalytic Converter. Check any vacuum hoses.
Undead-89 is offline   Quote
Old 02-22-2011, 05:58 PM   #9
Jeeper
 
Jeepin91YJ's Avatar
 
Join Date: Jan 2011
Location: Colorado Springs
Posts: 138
Images: 1
I think all of us covered it all.

Jeepin91YJ is offline   Quote
Reply

Tags
1993 , jeep , misses , runs and dies , runs rough

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need expert advice jeep runs then stalls Bs13855 YJ Tech Forum 21 02-08-2011 08:25 PM
Jeep starts hard after siting. Help nmill TJ Tech Forum 0 09-15-2010 08:38 AM
HELP.. Jeep runs but wont go into gear. jrodd1973 TJ Tech Forum 2 09-06-2010 11:38 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:06 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC