Low beams and tail lights not working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-23-2011, 09:48 AM   #1
Newb
 
Join Date: May 2011
Posts: 1
Low beams and tail lights not working

My fiancé has a 93 and has been having some electrical problems with it since she's had it. The only lights that work are the high beams and the brakes. Her tail lights, low beam headlights, and turn signals do not work at all. We took it to a shop and they just let it sit for 3 weeks and didn't fix anything. Does anybody have input on what the problem might be? Any help is appreciated. Thanks

spnksmck is offline   Quote
Old 05-23-2011, 12:18 PM   #2
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,292
It could be as simple as bad grounds/bad connections. Time to get out the test light and check each light.
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:13 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC