Low Voltage Wrangler 1993 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-13-2011, 06:27 AM   #1
Newb
 
Join Date: Jun 2011
Posts: 2
Low Voltage Wrangler 1993

Hello, i have 1993 YJ 2.5 liter. I have replaced the Starter, Battery, Factor Battery cables, maxi fuses and the alternator. Voltage at the battery is +12 volts when turned off. With the Jeep running the voltage is 9. My initial problem was a bad starter last week. Previously the Voltage was 14.5 while running. I replaced the starter and then i begin having the voltage problems. I had the battery tested which was fine but i replaced it anyway because of its age. No change in voltage. I replaced the alternator because it was the original. No change in voltage. Any ideas?? Thanks Jon

weinz69 is offline   Quote Quick Reply
Old 06-13-2011, 09:06 AM   #2
Jeeper
 
NAVYCHIEF's Avatar
 
Join Date: Sep 2008
Posts: 2,207
check all of your grounds. clean the terminals and reconnect them and reconnect them. also clean the area where thet connect.

__________________
1994 RENEGADE

TREAT EVERY STRESSFUL SITUATION AS A DOG WOULD.
IF YOU CAN'T EAT IT OR PLAY WITH IT,
JUST PEE ON IT AND WALK AWAY.
NAVYCHIEF is offline   Quote Quick Reply
Old 06-13-2011, 09:08 AM   #3
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,337
Could be the ECM V/R gave up
Ibuildembig is online now   Quote Quick Reply
Old 06-13-2011, 09:37 AM   #4
Newb
 
Join Date: Jun 2011
Posts: 2
Quote:
Originally Posted by NAVYCHIEF View Post
check all of your grounds. clean the terminals and reconnect them and reconnect them. also clean the area where thet connect.

I will try the cleaing the ground again. Thanks, Jon
weinz69 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 Wrangler with soft clutch pedal Designllc YJ Tech Forum 4 05-02-2011 09:55 AM
1993 Wrangler Water temperature very high Designllc YJ Tech Forum 1 01-12-2011 02:31 PM
NEPA - 1993 Wrangler. 4 cyl. 5 spd. Leumas Classifieds Archive 7 04-29-2010 12:05 PM
4.0 oil blow by problems on a 1993 Jeep Wrangler Sahara. JCochran YJ General Discussion Forum 1 03-25-2010 01:33 PM
1993 Wrangler JaMeri YJ General Discussion Forum 3 05-11-2009 08:52 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:23 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC