Manual tranny issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-02-2013, 02:25 PM   #1
Jeeper
 
88beast's Avatar
 
Join Date: Jan 2013
Posts: 96
Manual tranny issues

When in 2wd if I try and let out clutch and take off with Speed lol my tranny or something in that area is knocking... Went thru a creek in 4 low it worked but now something is knocking and rattling in the transmission area doesn't do it near as much as when I'm on a muddy road I'm lost no clue what it is. There is no slipping gears and 4wd works great but it sounds horrible any help would be great thanks guys

88beast is offline   Quote Quick Reply
Old 08-02-2013, 02:25 PM   #2
Jeeper
 
88beast's Avatar
 
Join Date: Jan 2013
Posts: 96
Also is a 2.5l with 35's not sure what tranny though

88beast is offline   Quote Quick Reply
Old 08-02-2013, 02:57 PM   #3
Jeeper
 
incizion's Avatar
 
Join Date: Jul 2011
Location: Manassas, Virginia
Posts: 1,263
Images: 1
Did you check the fluids in ur tcase and tranny?
__________________
,[____],
---([ ]lllll[ ])--
( )_)=o=( )_)
My Build - Ol' Gloria (Slow)
incizion is offline   Quote Quick Reply
Old 08-02-2013, 03:01 PM   #4
The wicked fat man!!!

WF Supporting Member
 
HillbillyJeeper's Avatar
 
Join Date: Jun 2011
Location: Nun yo gyatdamn biniz!
Posts: 1,043
Oh sorry, I thought the thread was about Manuel the tranny.... Im a follower of his.... I have nothing to add. Please carry on
__________________
OUTHOUSE OFFROAD CLUB!!! We Do Shit!!


That was Purdy as hell right there!!!!

Uh.... dad... Uncle Jessie is crazy! Sooo cool though!
HillbillyJeeper is offline   Quote Quick Reply
Old 08-02-2013, 04:39 PM   #5
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,275
Yeah start with checking your motor mounts, tranny mount and torque arm. You may have a bad mount. Next check all your u- joints front and rear shaft.

Slipping sliding and spinning in mid can upset or break things especially with 35s.
__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:14 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC