Misfireing - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-18-2014, 11:19 PM   #1
Jeeper
 
Trusty_jeep22's Avatar
 
Join Date: Jul 2014
Posts: 30
Misfireing

I have a 1990 jeep wrangler and I'm having a problem when I start it up and start to drive when I'm in first and second it'll like quit accelerating then pick right back up but feels like it's about to die right before that. I put new plugs wire and distributor cap on it thinking bad plugs and stuff but nothing helped it I put cfoam through it trying to clean it up but didn't really help. Thanks again guys

Trusty_jeep22 is offline   Quote Quick Reply
Old 07-19-2014, 07:21 AM   #2
Jeeper
 
mrjoey's Avatar
 
Join Date: Mar 2014
Posts: 158
what motor?

__________________
mrjoey is offline   Quote Quick Reply
Old 07-19-2014, 12:54 PM   #3
Jeeper
 
Trusty_jeep22's Avatar
 
Join Date: Jul 2014
Posts: 30
2.5 4 cylinder
Trusty_jeep22 is offline   Quote Quick Reply
Old 07-19-2014, 01:45 PM   #4
Jeeper
 
rJeePu's Avatar
 
Join Date: Jul 2014
Posts: 88
Sounds almost like fuel starvation
rJeePu is offline   Quote Quick Reply
Old 07-19-2014, 01:54 PM   #5
Jeeper
 
0III0forlife's Avatar
 
Join Date: Mar 2012
Location: Ridgway, Pa.
Posts: 3,589
Images: 6
Take a look at the new plugs that you installed, they will tell you what it's doing.

Black, its running to rich, white/gray is too lean, light brown is the color that you are after.

And stock champions or autolite are the plugs to run. Don't waste your money on those big fancy expensive plugs, since you don't have a big fancy expensive motor for them to go into.

Sounds like you might need to clean the throttle body, sometimes they get carboned up to the point where sea foam won't even clean it out. Check and clean all of the electrical connections to the throttle body as well. Those mean a lot with that TBI injection system.
__________________
'87 YJ, 4.2L built and bored, 8.5" of lift, 8.8 rear, AX15/NP 231, Tom Woods drive shafts, Flat fenders, 12,000LB winch, Custom bumpers, Rattle can paint job. Never completed...
0III0forlife is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC