Motor Mount Issue YJ with Chevy 350 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-19-2013, 08:50 AM   #1
Newb
 
Join Date: Mar 2013
Posts: 1
Motor Mount Issue YJ with Chevy 350

I recently picked up a 89 Wrangler with a Chevy 350. Over the last few days I have been reading tons of posts, lots of great info out there!

It looks like who ever put in the 350 did a pretty good job. One issue is the motor mounts are shot (see photos). I would like to get replacement motor mount bushings but can't figure out what i need. Looks like others have used a similar setup. Does anyone know what i need and where to purchase? Thanks in advance! Look forward to the forum!
Attached Thumbnails
Click image for larger version

Name:	MM1.jpg
Views:	41
Size:	172.0 KB
ID:	224733   Click image for larger version

Name:	MM2.jpg
Views:	39
Size:	221.2 KB
ID:	224734  


Islander1989 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:42 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC