Need a diagnosis...bizzare problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-04-2009, 12:20 AM   #1
Newb
 
Join Date: May 2009
Posts: 3
Need a diagnosis...bizzare problem

Towards the end of the summer i took my 91' 4 cyl. on a road trip and about 4 hours in i lost power and couldn't get over 45 mph. It was during a rain storm and i figured that i might have gotten some water in the gas tank. I pulled over topped off the tank and put some treatment in and it seemed to work fine until about an hour down the road it happened again. When i got to my destination i ran out the rest of the tank and my return trip went fine.

Recently the jeep has been running well at the start of the day. Idles good and runs as good as it did the day i got it. However, when i get about 2 blocks down the road i lose power and it is almost undriveable. Occasionally it will run bad then it will miraculously run great for about 10 miles before it takes a crap on me again.

I havn't taken the gas tank off yet and drained it. I suspect that its full of water/sediment and is causing the power loss. It chugs down gas all of the sudden...like 7mpg. If i put gas treatment in it'll run great until i turn it off then when i restart it the old boy its back to bein a crap sandwich.

I'm just looking for ideas since i'm about to face the harsh illinois winter.

Loutty is offline   Quote Quick Reply
Old 12-04-2009, 12:59 AM   #2
Jeeper
 
NAVYCHIEF's Avatar
 
Join Date: Sep 2008
Posts: 2,207
how's your in line fuel filter? and your cat?

__________________
1994 RENEGADE

TREAT EVERY STRESSFUL SITUATION AS A DOG WOULD.
IF YOU CAN'T EAT IT OR PLAY WITH IT,
JUST PEE ON IT AND WALK AWAY.
NAVYCHIEF is offline   Quote Quick Reply
Old 12-04-2009, 06:23 AM   #3
Jeeper
 
crtaylor's Avatar
 
Join Date: Sep 2009
Location: Beaver Falls,PA
Posts: 1,055
catalitic convter could do just what you describe.
crtaylor is offline   Quote Quick Reply
Old 12-04-2009, 08:39 AM   #4
Jeeper
 
RedWrangler's Avatar
 
Join Date: Oct 2009
Location: Morrisville, PA
Posts: 1,165
If you did get water in the fuel line, the filter might be your problem. Cheap fix. If it's your cat, you would probably be hearing the tell-tale rattling of the broken element. If the pieces get lodged just so, they clog the exhaust, and that will cause your engine to bog down and run like crap. They can become freed up, and then it will run normally again until the next clog.
RedWrangler is offline   Quote Quick Reply
Old 12-04-2009, 10:11 AM   #5
Jeeper
 
Join Date: Mar 2009
Location: Seattle
Posts: 259
I think if it was the cat it would do it all the time, not intermittenly, I think it may be stuff in your fuel line thats breaks down after a while and able to get past the injectors after a bit
Rainycity is offline   Quote Quick Reply
Old 12-04-2009, 10:27 AM   #6
after birthday glow
 
morphious's Avatar
 
Join Date: Jul 2009
Location: wisconsin
Posts: 1,963
Images: 1
id be checking the cat if i were u
__________________
some say why i say
its a jeep thing u wouldn't understand
morphious is offline   Quote Quick Reply
Old 12-04-2009, 11:29 AM   #7
Really?

WF Lifetime Member
 
ccain's Avatar
 
Join Date: Feb 2007
Location: SoCal
Posts: 6,453
Images: 9
Ditto on the cat.
ccain is offline   Quote Quick Reply
Old 12-04-2009, 12:04 PM   #8
Jeeper
 
BIGMAN95YJ's Avatar
 
Join Date: Nov 2009
Location: NE MISSOURI
Posts: 31
If the cat is clogged, the exhaust should be red hot to the cat itself, then quite cooler after. careful checking that out, don't get burned!!
BIGMAN95YJ is offline   Quote Quick Reply
Old 12-04-2009, 04:02 PM   #9
Jeeper
 
Join Date: Oct 2009
Posts: 269
Cat
haroldpo6 is online now   Quote Quick Reply
Old 12-04-2009, 06:13 PM   #10
Newb
 
Spetsnaztico's Avatar
 
Join Date: Oct 2009
Location: SoMD
Posts: 9
I had a similar problem. Mine ended up being the automatic choke being stuck shut. .
Spetsnaztico is offline   Quote Quick Reply
Old 12-05-2009, 05:13 AM   #11
Newb
 
Join Date: May 2009
Posts: 3
the fuel filter was replaced in july and I haven't had a Catalytic converter in years
Loutty is offline   Quote Quick Reply
Old 12-05-2009, 06:27 AM   #12
Jeeper
 
buckshot500's Avatar
 
Join Date: Mar 2009
Location: Carolina
Posts: 798
Just curious why you think that water got in the fuel tank, was the cap left off?

I can think of no other way water could get in there. Jeeps are designed to be subjected to water crossings that would normally drown a regular passenger car.
__________________
90YJ 98XJ
buckshot500 is offline   Quote Quick Reply
Old 12-05-2009, 03:00 PM   #13
after birthday glow
 
morphious's Avatar
 
Join Date: Jul 2009
Location: wisconsin
Posts: 1,963
Images: 1
well i think we may have an electrical gremlin.maybe the icm heating up witch would explain the water being a factor. seeing as that d@mn box is mounted on the bottom side of the fender. or it could be that ur fuel pump cant keep up to the demand of higher rpms

__________________
some say why i say
its a jeep thing u wouldn't understand
morphious is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
05 tj rattle problem fixed. JeepGuyLJ TJ General Discussion Forum 2 05-25-2011 01:00 PM
mystery engine problem fivesevenusg TJ Tech Forum 13 09-22-2009 11:48 PM
different transmission problem greasem0nkey86 YJ Tech Forum 5 03-26-2007 03:31 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC