Need help on what is wrong. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-05-2010, 01:45 PM   #1
Jeeper
 
Join Date: Oct 2009
Location: New Jersey
Posts: 71
Need help on what is wrong.

Hey, I have a 1990 Jeep Wrangler with Fuel Injection and lately it has been loosing power when driving. It is sort of pulsating when doing so. It will slow down then pick up again. I'm wondering as to what could cause this. Also, my engine seems to be covered in a liquid. Could I have a head gasket leak? Also, I can smell gas, but, there are no visible signs of a gas leak. Additional info, it is a 4.2 6cyl. Thanks in advance for the responses!

monteYJ is offline   Quote Quick Reply
Old 10-05-2010, 01:48 PM   #2
Jeeper
 
NAVYCHIEF's Avatar
 
Join Date: Sep 2008
Posts: 2,207
look at your cat. 20 yrs is a long time

__________________
1994 RENEGADE

TREAT EVERY STRESSFUL SITUATION AS A DOG WOULD.
IF YOU CAN'T EAT IT OR PLAY WITH IT,
JUST PEE ON IT AND WALK AWAY.
NAVYCHIEF is offline   Quote Quick Reply
Old 10-05-2010, 02:09 PM   #3
Jeeper
 
Join Date: Oct 2009
Location: New Jersey
Posts: 71
Will do. Ty.
monteYJ is offline   Quote Quick Reply
Old 10-05-2010, 09:44 PM   #4
Jeeper
 
89JEEPYJ's Avatar
 
Join Date: Oct 2010
Posts: 967
i took my cat off makes it run a lot better. i have headers and it would clog cats in about 10 minutes and the truck dies
89JEEPYJ is offline   Quote Quick Reply
Old 10-06-2010, 03:27 PM   #5
Jeeper
 
89Jeezy's Avatar
 
Join Date: Oct 2010
Location: Virginia Beach, VA
Posts: 38
Images: 2
I have had this same thing happen. normally its induced by water though. and occasionally it causes it to stall and wont start again for 15-20 min. anyone have any insight on if the cat could cause this too? ive just about exhausted any other options and whats the point of having a jeep if a heavy rainstorm or the slightes puddle makes it stall?!! grr.
89Jeezy is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Wrong manual transmission fluid listed in computer scotiez TJ Tech Forum 6 11-03-2012 09:03 PM
can someone tell me how this is wrong? (CB ant. mount) drummerwookie Communications and Electronics 3 11-18-2010 10:15 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM



» Featured Product

All times are GMT -5. The time now is 04:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC