Need some tips on Fix - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-29-2012, 10:59 PM   #1
Jeeper
 
Ianbeaulieu's Avatar
 
Join Date: Mar 2012
Location: San Antonio Texas
Posts: 1,449
Need some tips on Fix

I bought my new YJ and I need some Tips on some fixes,

1:My Headlights are a yellow Color( I dont know if this is just how they are or not) but they are also very very and i mean very Dim, How can i make them Brighter?

2:I think it has a miss, Im not to sure, what may i need to replace?

3: It has a Stock Lift, but the back of it sags alot and im not to sure why, mabye i need a new lift.

Any tips or suggestions would be great guys

Ianbeaulieu is offline   Quote
Old 03-29-2012, 11:13 PM   #2
Jeeper
 
busemans's Avatar
 
Join Date: Dec 2010
Location: on the gulf of mexico
Posts: 1,352
check your battery voltage. dim lights sounds like your alt is not working and you are running on the battery.

__________________
A lot of teenagers are people who express a burning desire to be different be dressing exactly alike.
Panties aren't my favorite, but they're right next to it...
No one is normal, there are just a lot of weird people with things in common.
busemans is offline   Quote
Old 03-29-2012, 11:14 PM   #3
Jeeper
 
Ianbeaulieu's Avatar
 
Join Date: Mar 2012
Location: San Antonio Texas
Posts: 1,449
Quote:
Originally Posted by busemans View Post
check your battery voltage. dim lights sounds like your alt is not working and you are running on the battery.
would that mean i have to replace the alternator?
Ianbeaulieu is offline   Quote
Old 03-29-2012, 11:15 PM   #4
Jeeper
 
busemans's Avatar
 
Join Date: Dec 2010
Location: on the gulf of mexico
Posts: 1,352
depends if it is actually bad. do you have a multimeter?
__________________
A lot of teenagers are people who express a burning desire to be different be dressing exactly alike.
Panties aren't my favorite, but they're right next to it...
No one is normal, there are just a lot of weird people with things in common.
busemans is offline   Quote
Old 03-29-2012, 11:25 PM   #5
Jeeper
 
Xpress's Avatar
 
Join Date: Jan 2011
Location: El Cajon
Posts: 2,585
Check the voltage across the battery terminals. An easy test is to fire the Jeep up and remove the POSITIVE terminal on the battery. If the alternator is working properly the Jeep will run- it only uses the battery to start, then once running the alternator provides ample power to the Jeeps systems on its own. If the Jeep dies when you remove the terminal, then your alternator is bad and not charging.

From there we can help further...
__________________


2.5L Genius of some sort.
Xpress is offline   Quote
Old 03-29-2012, 11:33 PM   #6
Jeeper
 
DirtyRob's Avatar
 
Join Date: Sep 2011
Location: Sampson County N.C.
Posts: 1,155
Images: 3
For the question about the rear sagging......the previous owner probably pulled a trailer behind it or something of the like to make the springs sag. Most folks install a lift soon after getting a Wrangler if bought in stock form. AS far as the lights go, you can get the battery and alternator tested at your local VatoZone or Advance auto for free. That will save you some time seraching for what is going on.
I bought the Sylvania SilverStar replacement lights for mine and they are bright and legal. I like them a lot
__________________
wherever you go there you are..........
DirtyRob is offline   Quote
Old 03-29-2012, 11:42 PM   #7
Jeeper
 
whiteyj's Avatar
 
Join Date: Jul 2005
Location: Pleasanton CA
Posts: 4,856
If you test out and determine it's just the lights, I run the Sylvania's as well. Very bright and DOT legal.

As for the miss, what motor and year are you running? Fuel injected or carb?
__________________
Fallen Angel...Former MOD
whiteyj is offline   Quote
Old 04-01-2012, 10:41 PM   #8
Jeeper
 
Ianbeaulieu's Avatar
 
Join Date: Mar 2012
Location: San Antonio Texas
Posts: 1,449
Quote:
Originally Posted by busemans View Post
depends if it is actually bad. do you have a multimeter?
I do not think so, i have a device that tells me if electrical current is running through it or not, i forget the name of that lol
Ianbeaulieu is offline   Quote
Old 04-01-2012, 10:43 PM   #9
Jeeper
 
Ianbeaulieu's Avatar
 
Join Date: Mar 2012
Location: San Antonio Texas
Posts: 1,449
Quote:
Originally Posted by Xpress View Post
Check the voltage across the battery terminals. An easy test is to fire the Jeep up and remove the POSITIVE terminal on the battery. If the alternator is working properly the Jeep will run- it only uses the battery to start, then once running the alternator provides ample power to the Jeeps systems on its own. If the Jeep dies when you remove the terminal, then your alternator is bad and not charging.

From there we can help further...
Thank you! i will try this tomorrow and let you know
Ianbeaulieu is offline   Quote
Old 04-01-2012, 10:46 PM   #10
Jeeper
 
Ianbeaulieu's Avatar
 
Join Date: Mar 2012
Location: San Antonio Texas
Posts: 1,449
Quote:
Originally Posted by whiteyj View Post
If you test out and determine it's just the lights, I run the Sylvania's as well. Very bright and DOT legal.

As for the miss, what motor and year are you running? Fuel injected or carb?
its an I6, i wanna say from 87, but the guy said he had it rebuilt so im not sure, and for the Fuel injected or Carb, i dont really know, i wanna say fuel injected but im not sure, i have really been under the hood of it alot since i was out of town for the weekend, whats a quick way to tell What it is?

Ianbeaulieu is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Steps/Tips to Order a New Wrangler LAH JK General Discussion Forum 10 09-29-2012 03:08 PM
Black things on hood snikt JK General Discussion Forum 32 03-31-2012 10:58 AM
Replacing "JEEP" decal on the side. AtlFalcon01 TJ General Discussion Forum 14 03-30-2012 07:49 PM
2dr Handling On Wet/Slick Roads? tpelle JK General Discussion Forum 28 03-30-2012 08:52 AM
Install Tips Appreciated on TF 2.5 RPN516 JK General Discussion Forum 20 03-29-2012 09:52 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:15 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC