New to the forum and need Help please!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-27-2009, 04:06 PM   #1
Newb
 
Chancho's Avatar
 
Join Date: Jan 2009
Location: San Ferando Valley, CA
Posts: 5
Thumbs up New to the forum and need Help please!!!

Hi everyone, I'm new to the forum and to the Jeep pack also, just recently I bought a 1993 Jeep Wrangler YJ. This past weekend I took it to do some off roading, which by the way was lots of fun, but since I came back I feel that the clutch is very loose, before the trip I used to put my foot on the clutch and I would imidiately feel the pressure, but now my foots goes in about 1 1/2 to 2 inches inside and I feel no pressure at all, I'm afraid I may have damaged something, if any of you has had this experience or can tell me what's wrong I would greatly appreciate it.

Thank you from me and Chancho, that's my Jeep's name.

__________________
Chancho
Chancho is offline   Quote Quick Reply
Old 01-27-2009, 04:49 PM   #2
that's what she said

WF Supporting Member
 
jgano23's Avatar
 
Join Date: Oct 2008
Location: \m/-_-\m/
Posts: 16,482
Send a message via AIM to jgano23 Send a message via Yahoo to jgano23
was there a lot of sand and/or water?

jgano23 is offline   Quote Quick Reply
Old 01-27-2009, 07:34 PM   #3
Newb
 
Chancho's Avatar
 
Join Date: Jan 2009
Location: San Ferando Valley, CA
Posts: 5
There was lots of mud no so much sand or water, I did drive over two pudles of water, one of them is my avatar picture.
Thanks a lot for your reply.
__________________
Chancho
Chancho is offline   Quote Quick Reply
Old 01-27-2009, 07:36 PM   #4
Newb
 
Chancho's Avatar
 
Join Date: Jan 2009
Location: San Ferando Valley, CA
Posts: 5
Here is a picture of the water I drove by, both were similar. I only drove once through each.
__________________
Chancho
Chancho is offline   Quote Quick Reply
Old 01-27-2009, 10:14 PM   #5
Jeeper
 
87YJWrangler's Avatar
 
Join Date: Sep 2008
Location: Owatonna, Minnesota
Posts: 640
Check your clutch linkage I dont about yours but mine is a mechanical clutch and I had to tighten mine up a bit so that maybe your problem too
__________________
Mine: 1987 YJ 4.2 5spd soft top
98% of people when they are about to go into the ditch say "oh shit!" The other 2% are Minnesotans and when we are about to go into a ditch we say "Hold my beer and watch this shit!"
87YJWrangler is offline   Quote Quick Reply
Old 01-27-2009, 10:16 PM   #6
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
also check your clutch fluid, maybe flush it out. possibly damaged the slave cylinder.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 01-28-2009, 12:40 AM   #7
Newb
 
Chancho's Avatar
 
Join Date: Jan 2009
Location: San Ferando Valley, CA
Posts: 5
Thanks to both of your for your advice, I will research about your suggestions and try them. Thanks.
__________________
Chancho
Chancho is offline   Quote Quick Reply
Old 01-28-2009, 04:09 PM   #8
Newb
 
Chancho's Avatar
 
Join Date: Jan 2009
Location: San Ferando Valley, CA
Posts: 5
I just bought the Haynes book for the jeep and read through the clutch part but doesn't mention anything about slave cylinders, it only mentions the master cylinder. Anybody know where is the slave sylincer on a 1993 Jeep Wrangler?
THank you,.

__________________
Chancho
Chancho is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:18 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC