No fuel at Mechanical Pump - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-23-2012, 01:39 AM   #1
Newb
 
Join Date: Dec 2012
Posts: 6
Exclamation No fuel at Mechanical Pump

I have a 89 Wrangler with a straight 6. It was running fine and then it just shut off one day. I do not think I am getting fuel to the mechanical pump. I took the line off and have good suction from the pump but its like it wont pull from the tank.

Also it will not automatically downshift but will if you manually place it in lower gears. Up shifting was a problem but added some lucas and it is better but sticks sometimes. ANY ideas mainly for fuel issue now will be appreciated.

mdmoore is offline   Quote
Old 12-23-2012, 07:44 AM   #2
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,931
if your pump is in fact good then there could be a few reasons that it is not pulling fuel..I would

take the gas cap off to make sure the tank is venting
replace the fuel filter
if it still is not working then the gas line could be crimped closed or plugged..if for some reason your steel gas line has been replaced with a rubber line then it could be collapsing

harleydragon is offline   Quote
Old 12-23-2012, 12:07 PM   #3
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 6,402
Good suction doesn't mean that it's pulling enough, 4-5lbs. It still could be a bad/weak fuel pump. It can also be a bad/collapsed fuel line. I would check the lines, replace the fuel filter and fuel pump. There are two types of mechanical fuel pumps for an 89 4.2; one has the inlet to the front, one has it to the rear. Check your original and make sure you get the correct replacement.
kik is offline   Quote
Old 12-23-2012, 02:24 PM   #4
Jeeper
 
DALTY_D's Avatar
 
Join Date: Jan 2012
Location: Middletown, DE
Posts: 48
Same thing happened to me, mine wasn't getting any fuel but if you turned the key you can hear the pump kick on. I just had to replace the fuel filter which was an easy fix and it was good as new
DALTY_D is offline   Quote
Old 12-23-2012, 05:13 PM   #5
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,931
Quote:
Originally Posted by DALTY_D View Post
Same thing happened to me, mine wasn't getting any fuel but if you turned the key you can hear the pump kick on. I just had to replace the fuel filter which was an easy fix and it was good as new
complete different fuel pump..his is mechanical,not electric
harleydragon is offline   Quote
Old 12-23-2012, 05:30 PM   #6
Newb
 
Join Date: Dec 2012
Posts: 6
Ok replaced pump and filter noticeable change with the suction at the new pump but still not getting fuel to pump. Lines do not appear to be crimped but its dark. Thinking maybe the strainer in tank could be clogged up?? Any thoughts?
mdmoore is offline   Quote
Old 12-23-2012, 05:46 PM   #7
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,931
could be ( if it even has a strainer )..could be rust or trash clogging the line..could be an old hose screwing up

harleydragon is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:33 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC