No power @ coil, Please help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-20-2012, 04:39 AM   #1
Newb
 
Join Date: Aug 2012
Posts: 11
No power @ coil, Please help

Long story short. 94 wrangler with 2.5 had warped head and sat for three years. Recently got the head fixed and put back together, and No start. It started fine before the head warped. I could tell by the sound there was no spark, so I checked to see where, and there was no spark coming out of the coil. I removed the electric connector and found there was no power going to the coil. I checked all of the wireing all the way back to the auto shutdown relay and to the Pcm. All of the wires were in good shape. I changed the ignition switch and no change. I replaced the capacitors inside the PCM hopeing for some luck but no help. I've spent hours on end checking wires and I cannot figure out were the circuit is broken. I changed the relays around and still no power. The 'hot' wire from the coil runs back to the auto shutdown relay and then to the fuel injectors and on to the PCM. Also the auto shutdown relay and the fuel relay are connected to the same circuit so I'm not getting fuel either, but before I checked the spark I put starting fluid in and still not even close to a spark. I've seen similar probelms on this site but none that have no power at the coil. Please help, I'm laid off and my son is turning 16 and I need this for him.
Thanks,

__________________
Jefferson Davis
backbonejay is offline   Quote Quick Reply
Old 09-20-2012, 05:25 AM   #2
Commercial Member

WF Supporting Member
 
kfdjason7620's Avatar
 
Join Date: Apr 2011
Location: Kenly, NC
Posts: 3,962
Just a shot, and I have a 2000 I6, but something is telling it not to spark and first thoughts would be the cps in my jeep.

kfdjason7620 is offline   Quote Quick Reply
Old 09-20-2012, 06:25 AM   #3
Jeeper
 
kdub's Avatar
 
Join Date: Sep 2011
Location: alabama
Posts: 521
Images: 1
The crank position sensor tells the computer when to fire the coil.
__________________
93 yj 2.5 swap to 4.0,ax15. 4 inch RC lift with 33s.410 gears
kdub is offline   Quote Quick Reply
Old 09-20-2012, 06:45 AM   #4
Commercial Member

WF Supporting Member
 
kfdjason7620's Avatar
 
Join Date: Apr 2011
Location: Kenly, NC
Posts: 3,962
Quote:
Originally Posted by kdub
The crank position sensor tells the computer when to fire the coil.
Yeah, what he said!!
kfdjason7620 is offline   Quote Quick Reply
Old 09-20-2012, 07:53 AM   #5
Jeeper
 
Vaccarothetank112's Avatar
 
Join Date: May 2012
Location: Chicago
Posts: 116
Check the wire harnesses same thing happen to me and it was a pin not connected good in the harness!
Vaccarothetank112 is offline   Quote Quick Reply
Old 09-20-2012, 03:28 PM   #6
Newb
 
Join Date: Aug 2012
Posts: 11
Quote:
Originally Posted by kfdjason7620 View Post
Yeah, what he said!!
I understand what the crank sensor does, but there is no power @ the coil. Meaning, when I take the electrical connector off of the coil there should be one hot wire showing there is power at the coil, and there is none. The wire that should be hot in the coil connector is also ran to the fuel injectors then on to the computer, and it goes to the shutdown relay on the other end of the circuit. I'll go ahead and change the cps this weekend, but I'm sure that can't be why there is No hot wire @ the coil. Thanks for the help, and if you think of anything else please let me know.
__________________
Jefferson Davis
backbonejay is offline   Quote Quick Reply
Old 09-21-2012, 09:25 AM   #7
Jeeper
 
Vaccarothetank112's Avatar
 
Join Date: May 2012
Location: Chicago
Posts: 116
I'm telling you it's one of the wire harnesses check all of them!!
Vaccarothetank112 is offline   Quote Quick Reply
Old 09-21-2012, 10:13 AM   #8
Newb
 
Join Date: Oct 2011
Posts: 11
Send a message via Yahoo to Darkside
I would also go with the cps had the same thing happen to my 95 after the rebuild. I would have power to the coil no fire check the coil again no power in. Replaced the cps fired and ran.

__________________
So I decided to name my jeep Christine, first after my wife second after the Steven King book, sooner or later one or both may kill me!!
Darkside is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:39 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC