No power to my fuel system? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-18-2007, 03:10 PM   #1
Jeeper
 
Join Date: Feb 2007
Location: central Indiana
Posts: 38
Send a message via AIM to the idiot magnet
No power to my fuel system?

I have a 2.5L in my 95 Wrangler and I can't get any power to the relay in the fuse box under the hood which means I don't have any power to get this thing running.
I've swapped or replaced the following: Fuel pump, fuel filter, rotor, relays, crank position sensor, and several other parts including another ECU.
Still nothing!

Any ideas?
I'm getting spark.
Where is the ground for the fuel pump?

the idiot magnet is offline   Quote Quick Reply
Old 03-18-2007, 03:23 PM   #2
Jeeper
 
Join Date: Mar 2007
Location: olivebridge
Posts: 27
well first thing is how much spark are you getting, and the ground for the pump is in the harness that plugs into it. you should get a bright blue spark if you dont have a spark tester just pull one out and put the wire on and ground it out while somebody cranks the motor and see what it looks like. What relay is not getting power??

kyle is offline   Quote Quick Reply
Old 03-18-2007, 03:56 PM   #3
Jeeper
 
Join Date: Feb 2007
Location: central Indiana
Posts: 38
Send a message via AIM to the idiot magnet
The fuel pump relay is not getting anything.
I'm getting a spark, but it's tough to say how strong the spark is. I do the old school screwdriver to some metal in the end of the plug wire.
the idiot magnet is offline   Quote Quick Reply
Old 03-18-2007, 04:27 PM   #4
Jeeper
 
Join Date: Mar 2007
Location: olivebridge
Posts: 27
i dont suppose you have a power probe do you? if you do you can check for power and ground. you should check the wires and look for fuseable links that might have blown. get a can of starting fluid and see if it will start with that (spray it in the intake as close the the throttle body as possible). if it does then just run the fuel pump on a toggle switch.
kyle is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
95 YJ Fuel Pump, no power at connector? snb73 YJ Tech Forum 6 06-06-2013 03:02 PM
Fuel system over pressurizing kmssg YJ Tech Forum 1 07-27-2008 02:40 PM
Fuel Pump? jjonesx2 YJ Tech Forum 5 01-22-2008 08:32 AM
Finally Help for 4 Bangers? Dare2BSquare General Jeep Discussion 6 07-24-2007 12:15 AM



» Featured Product

All times are GMT -5. The time now is 05:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC