No power to the fuel pump - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-26-2011, 02:51 PM   #1
Newb
 
Join Date: Sep 2011
Location: Camden, NC
Posts: 14
No power to the fuel pump

i recently purchased a 1990 wrangler off of craigslist. the seller told me all it need was fuel pump so i purchased one and then went to pick it. i live neat the outer banks and drove all the way up to maryland to pick it up and drive it back. took me five damn hours. so when i got there, me and my dad gave it the look over and he had the audacity to say that he was a mechanic and he diagnosed it himself and it just needed the fuel pump replaced.

needless to say.. we brought it home. it has been sitting in the yard for the passed week. me and my dad were gonna put the fuel pump in ourselves but we had to wait till sunday, yesterday, cause thats the only time he had off. so we pushed it into the garage. dropped the tank, drained the fuel, replaces the pump, put it bank it and reconnected all the hoses and wires. then i gave it a fresh tune up (changed the oil, air filter, spark plugs, spark plug wires, fuel filter.)

we went to start her up and nothing.... just kept turning over and over. my dad poured some gas into the carb and it tried to catch but it wouldnt. there is/was no fuel getting to the engine. he kept going and eventually the starter went out so i have to replace that.

but my issue is... i read somewhere that the fuel pump turns on as soon as you turn the key without turning it over. i turn the key and nothing... the fuel pump is not kicking in... what do i do next?????

please help

vikessoftball is offline   Quote Quick Reply
Old 09-26-2011, 03:00 PM   #2
Jeeper
 
Join Date: Apr 2011
Posts: 172
sometimes the wiring harness pins that plug together just near the drivers rear wheel area near the gas tank will push out and not make contact when you push both together. check and see if the end fron the pump side has the female contacts are fully seated, if not push them in completely so you can see the ends on the other side and put the little silicone oval shaped plug back in and maybe even tape it so it won't slide out. this is a problem I just had with mine and this fixed it. good luck, Driller

Driller is offline   Quote Quick Reply
Old 09-26-2011, 03:04 PM   #3
Jeeper
 
Jeep716's Avatar
 
Join Date: Aug 2010
Posts: 397
Bench test the pump with a battery to confirm it works. Test for power on with test light on jeep where pump plugs in. Check fuses and fuel pump relay too. Good luck.
Jeep716 is offline   Quote Quick Reply
Old 09-26-2011, 09:24 PM   #4
Jeeper
 
Join Date: Aug 2011
Location: Utah
Posts: 88
Keep in mind that if you turn the key to run ... The pump is only supplied power fir a second or two. Then apllies powet continuous when cranking and running. Swap the relay with the horn relay (same) and see if it makes a difference. Again if you out a test light on thee connector near the tank it only has power when cranking it running. A buddy of mine chased wires all day making that mistake
__________________
Location: 3 Hours from Little Sahara Dunes
4 Hours from St. Anthony Dunes
4.5 hours from MOAB
DamnBigPapa is offline   Quote Quick Reply
Old 09-27-2011, 09:09 AM   #5
Jeeper
 
UABYJ94's Avatar
 
Join Date: Apr 2010
Location: Panama City
Posts: 210
I just posted this same test in another thread. Check the ground wire that is connected at the E-brake assy. This is the ground for the fuel pump and may have broken or come loose.
UABYJ94 is offline   Quote Quick Reply
Old 09-27-2011, 11:47 AM   #6
Newb
 
Join Date: Sep 2011
Location: Camden, NC
Posts: 14
Okay.. So today. I swapped out the fuel pump relay with which ever one was underneath it. Still nothing... I'm assuming that my horn relay is broke since it doesn't work so I don't know if I should still switch it out.. I ordered a starter and its gonna be here tomorrow. I check the wires near the pump and they all look in good shape. Didn't see any corrosion or breaking. Also check the ground wire. Its bolted into a piece of metal near the parking break. Is that normal?? And I also tested the pump on the battery... It works... And so does the other one. Go figure... I'm going to go buy a new fuel pump relay tomorrow. Anything else I should try... If the relay doesn't fix it.. What's next???
vikessoftball is offline   Quote Quick Reply
Old 09-27-2011, 11:59 AM   #7
Jeeper
 
UABYJ94's Avatar
 
Join Date: Apr 2010
Location: Panama City
Posts: 210
Did you make sure the ground wire was making a solid contact with metal and no corrosion or rust inhibiting continuity? If yes then ohm out the wires to the fuel pump to make sure they are good,not broken, and getting proper voltage. Ofcourse this is only after you have verified a working relay has been installed.
UABYJ94 is offline   Quote Quick Reply
Old 12-04-2011, 09:49 AM   #8
Newb
 
Join Date: Sep 2011
Location: Camden, NC
Posts: 14
well it turns out... i had to replace the computer. i got an electrician from the coast guard to check it out and he eliminated every possible cause. so i ordered the computer, plugged it up and it cranked right up... i'll be damned. i was driving it for about 2 weeks and it was leaking oil. located the source of the leak and it turns out the valve cover was cracked on the right side. so i let it sit a couple days, replaced the valve cover, and then went to crank it up yesterday and the engine sounded terrible... like it was so weak. i checked the oil and there was a white foamy substance... this is when water mixes with the oil correct?? what could be the possible source of this? is my engine blown?
vikessoftball is offline   Quote Quick Reply
Old 12-04-2011, 09:57 AM   #9
Jeeper
 
Irongrave's Avatar
 
Join Date: Apr 2011
Location: Erie, PA
Posts: 2,800
Send a message via AIM to Irongrave
drain your oil and see what it looks like and work from there
__________________
4421
Irongrave is offline   Quote Quick Reply
Old 12-05-2011, 02:10 PM   #10
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
Could be a blown head gasket. Check the plugs too, see if any are wet or black.
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 04-16-2012, 09:47 PM   #11
Newb
 
Join Date: Sep 2011
Location: Camden, NC
Posts: 14
solution

well we bought a compression tester... and it was like around 60 on the first 3 and 90 on the last one... my book says its supposed to be around 180... holy hell it was off. i had to wait till i had the funds and i bought another engine. i ordered one from engine and transmission world... used, supposed to have around 80k on it. about a 20 day process. put the new engine in.... and it has been so far so good for now...
vikessoftball is offline   Quote Quick Reply
Old 04-16-2012, 09:56 PM   #12
Jeeper
 
jfbilbro's Avatar
 
Join Date: Jul 2011
Location: Central Alabama
Posts: 746
Quote:
Originally Posted by vikessoftball View Post
well we bought a compression tester... and it was like around 60 on the first 3 and 90 on the last one... my book says its supposed to be around 180... holy hell it was off. i had to wait till i had the funds and i bought another engine. i ordered one from engine and transmission world... used, supposed to have around 80k on it. about a 20 day process. put the new engine in.... and it has been so far so good for now...
glad you got it fixed...enjoy it!!

__________________
...huh?...
jfbilbro is offline   Quote Quick Reply
Reply

Tags
fuel pump , no fuel to engine , won't start , wrangler yj

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump initially won't activate. '95 YJ Rray1 YJ Tech Forum 28 10-04-2012 09:35 AM
KS: RCI 2161a fuel cell with KORE rings for TJ fuel pump MR.CLIFFORD Classifieds Archive 0 12-13-2010 11:08 AM
Fuel Pump Issue w/ Troubleshooting WhiteWillSmiff YJ Tech Forum 3 11-06-2010 05:14 PM
no power to fuel pump minderbinder3 YJ Tech Forum 9 08-14-2009 09:54 PM
Fuel Pump? jjonesx2 YJ Tech Forum 5 01-22-2008 08:32 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC