No spark - CPS? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-07-2009, 01:54 PM   #1
Newb
 
JB208's Avatar
 
Join Date: Aug 2009
Location: Minnesota
Posts: 14
No spark - CPS?

Hi all,

I'm looking to pick some knowledgeable Jeep brains. My 93' Wrangler quit after I put it in reverse (manual trans) before I let out the clutch. The stall resembled electrical failure. No start now. No spark from the ign. coil. Gauges aren't working. Back up lights aren't working. All other electrical seems to work. Checked fuses and they seem to be ok. I was wondering if it couldn't be the CPS. My repair manual suggests that, along with several other wiring problems. Any advice? Thanks for your time.

JB

JB208 is offline   Quote Quick Reply
Old 08-07-2009, 03:33 PM   #2
Jeeper
 
yjwes's Avatar
 
Join Date: May 2009
Location: howell nj
Posts: 369
could be a cps fuel pump run?

yjwes is offline   Quote Quick Reply
Old 08-07-2009, 03:39 PM   #3
Newb
 
JB208's Avatar
 
Join Date: Aug 2009
Location: Minnesota
Posts: 14
Thanks for the reply. I just checked it and the fuel pump is not running. I had the power on and no fuel pump sound, or pressure on the fuel rail port.
JB208 is offline   Quote Quick Reply
Old 08-07-2009, 07:04 PM   #4
Jeeper
 
yjwes's Avatar
 
Join Date: May 2009
Location: howell nj
Posts: 369
check all your fuses. it cranks with the key?
yjwes is offline   Quote Quick Reply
Old 08-07-2009, 08:14 PM   #5
Newb
 
JB208's Avatar
 
Join Date: Aug 2009
Location: Minnesota
Posts: 14
It does crank with a key. I'll dig into the fuses more tomorrow. The fuses in the power distribution center next to the battery appear fine. I checked all the fuses that can be pulled out. I'll look at the ones on the inside under the dash tomorrow.

Is there anything else that it could be, other than the CPS or a fuse/ short in a wire? The symptom that is tricky to me is that it was idling fine until I put the gear in reverse (manual tranny). It stalled immediately and hasn't started since. It's almost like there is a sensor in the tranny that effects fuel and spark.
JB208 is offline   Quote Quick Reply
Old 08-07-2009, 09:34 PM   #6
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
i was all on board for cps till the fuel pump. cps will usually be no spark, and no injector pulse, but fuel pump will still prime at key on, and power to pump is not controlled by cps. it is effected by ignition switch though, do the warning lights come on the dash for the first few seconds the key is on? if not thats a tell tale sign of switch.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 08-07-2009, 10:21 PM   #7
Newb
 
JB208's Avatar
 
Join Date: Aug 2009
Location: Minnesota
Posts: 14
Warning lights do not come on. I didn't notice that before. So no warning lights, no gauges, no back up lights. No spark, no fuel pump, no fuel rail pressure. All other controlled electrical components seem to work (head lights, break lights, turn signal, radio, and wipers). Tomorrow I'll test the ignition switch.

Could a faulty ignition switch cause all of my symptoms?
JB208 is offline   Quote Quick Reply
Old 08-08-2009, 04:13 PM   #8
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
yep, sounds like the switch. other parts will still work, and the starter can still crank, they're on different pins on the switch being powered up.

be sure to post updates.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 08-08-2009, 10:54 PM   #9
Newb
 
JB208's Avatar
 
Join Date: Aug 2009
Location: Minnesota
Posts: 14
I pulled a relay out from under the dash today and swapped it with the one that runs my horn in the power distribution center. The Jeep started right up. Then I swapped the relays back so they are in their original places. The Jeep started right up. I guess that relay needed to be re-set, if thats possible. I am still skeptical that I could have a short somewhere. The previous owner left a mess of wires behind the dash that hang down a bit. I'll have to dig into that after a while. For now, I'll pick up another relay to have just in case this happens again. Thanks to all for their input. I'm just happy to be playing in the Jeep again. My little boys were happy to go for a ride today also.
JB208 is offline   Quote Quick Reply
Old 08-10-2009, 05:01 PM   #10
Newb
 
Join Date: Aug 2009
Posts: 12
Hey JB208,
I have a '92 that I am having similar problems with. What relay did you replace? Any help would be appreciated.
zhenke is offline   Quote Quick Reply
Old 08-10-2009, 05:08 PM   #11
Jeeper
 
93yjsplash's Avatar
 
Join Date: Jun 2009
Location: Corpus Christi/Falfurrias
Posts: 241
happened to me i pulled something that was not labled as anything pertaining to the fuel pump to try in my dash lights scoket and then was baffled when it wouldnt start. I listened for fuel pump and nothing so i retraced my steps and remembered i had pulled that fuse put it back and started right up
__________________
Photobucket YJ Page
93yjsplash is offline   Quote Quick Reply
Old 08-16-2009, 04:18 PM   #12
Newb
 
Join Date: Aug 2009
Posts: 12
I just replaced my crankshaft position sensor, and it fired right up. Woohoo!
zhenke is offline   Quote Quick Reply
Old 08-31-2009, 05:41 PM   #13
Newb
 
Join Date: Aug 2009
Posts: 1
I am having the exact same problem with my 97 Wrangler. Where under the dash did you find the relay? I can only find one relay to the bottom right of the fuse panel on the passenger side of my vehicle and it is not the same as my horn relay, so I don't think its the same one you are talking about.
Kenney
ShoreToRun is offline   Quote Quick Reply
Old 08-31-2009, 08:54 PM   #14
Jeeper
 
93yjsplash's Avatar
 
Join Date: Jun 2009
Location: Corpus Christi/Falfurrias
Posts: 241
ShoreToRun

You should post in the TJ section of the forum,they could probably answer your question better there.

Welcome to the forums

__________________
Photobucket YJ Page
93yjsplash is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with DW, spark plugs, and accessories for '06 wrangler 3bJeepina06 TJ Tech Forum 6 08-06-2009 02:21 PM
Spark Plug Wire Diagram uscchris YJ General Discussion Forum 1 08-04-2009 07:52 AM
Spark Plug HELL Willbanks TJ Tech Forum 44 04-18-2009 11:51 PM
Spark plug questions 2002TJX TJ Tech Forum 13 01-25-2008 06:03 PM
No spark solrac2182 TJ General Discussion Forum 4 09-04-2007 07:20 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC