No start help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-13-2007, 11:58 AM   #1
Newb
 
britton's Avatar
 
Join Date: Apr 2007
Posts: 8
No start help

Hey people,

I thought I would introduce myself with a troubleshooting question. I have been waiting for the weather to get a little better for what I thought was going to be a simple fix but so far I haven't figured it out.

'91 YJ 4.0L with multi-port fuel injection.

I have a no-start. I noticed that the fuel pump doesn't come on for its usual two seconds when the ignition switch is first turned on.

I jumped the connectors at the fuel pump relay and the fuel pump turned on and I heard the fuel flowing through the lines.

Bought a new fuel pump relay and installed it but no dice.
I am not sure exactly what the auto shut down relay does but I replaced it with the relay I had just removed from the fuel pump position just to try it out. Still nothing.

I jumped the relay connectors again and cranked the engine with the fuel pump relay bypassed and the fuel pump operating. Still no start.

Removed a spark plug and the cylinder was dry.

Checked the fuel rail very unscientifically (stuck the test port with a screwdriver) and got lots of fuel out.

Sooo... I am thinking I have fuel to the fuel rail but the injectors are not getting a signal to open. I imagine the issue is related to the fact that I am not getting that two second run of the fuel pump on initial start-up.

I suppose I need to get a real shop manual...

Any thoughts?

Thanks,

Britton

britton is offline   Quote Quick Reply
Old 04-15-2007, 08:30 PM   #2
Jeeper
 
Join Date: Apr 2007
Location: Pismo Beach, Ca
Posts: 15
did you check, or do you have a cps? if so you might check that.

Mike

__________________
89 YJ White with blue pearl custom paint, light bar w/ 4 kc daylighters, kenwood sound, rockford fosgate, and kicker amps, 32x11.50 15s Nuttered, holley carb, no emissions.
jeepdrvr101 is offline   Quote Quick Reply
Old 04-16-2007, 09:15 PM   #3
Newb
 
britton's Avatar
 
Join Date: Apr 2007
Posts: 8
Umm... what's a CPS?
britton is offline   Quote Quick Reply
Old 04-16-2007, 10:12 PM   #4
Jeeper
 
amerijeep's Avatar
 
Join Date: Apr 2005
Location: Mississippi.
Posts: 3,951
Crank position sensor, I think.
__________________
To all who serve, Thank You.
amerijeep is offline   Quote Quick Reply
Old 04-17-2007, 01:20 AM   #5
Jeeper
 
Join Date: Apr 2007
Location: Arizona's White Mountains
Posts: 227
Britton,

I read your post and didn't see that you checked for spark. Fuel needs to be ignited. Have you checked the coil and distributor for power. Did you pull a plug and ground it against the block while someone cranked it over. You can get an inexpensive 12 volt tester to check for power to the coil and distributor
Grandpa Jeeper is offline   Quote Quick Reply
Old 04-17-2007, 11:13 AM   #6
Newb
 
britton's Avatar
 
Join Date: Apr 2007
Posts: 8
CPS= crank position sensor, of course I should have figured that out.

I am under the assumption that my fuel pump not cycling when the key is turned on is related to the no-start. The fuel pump ALWAYS kicks in for about two seconds every time the switch is turned on so the fact that it suddenly has stopped doing it after a year of daily driving is what has me scratching my head. I am not sure what triggers the action but I bet it is related. It is probably time to get a real manual and figure out what is really happening here.

I haven't followed up the no-spark route because of the lack of fuel pump action and the fact that the cylinders are bone dry after cranking. This makes me think I am not getting fuel. If I were simply not getting spark then I would expect the plugs to be getting wet with unburnt fuel. To be thorough though I should probably eliminate that possibility.

Thanks.

-Britton
britton is offline   Quote Quick Reply
Old 04-20-2007, 01:20 PM   #7
Newb
 
Join Date: Apr 2007
Posts: 12
Same problem as britton

the auto shut off relay was making a fast clicking sound after the jeep stopped running, the fuel pump works also, I have gas at and pressure at the test port, I do not have a spark from the coil. This has been a problem for a while, I would leave the key on for a minute and then the relays would click and the pump would run for a few seconds and stop and it would start right upand run great, untill I shut it off. If I tried to start it within a few minutes it work run great,leave it for more than a few minutes and I would have to wait for 5 minutes or more for the pump to start again. now it will not do anything. And by the way its a 1994 se with 2.5 Thanks Joe
bigbuck1566 is offline   Quote Quick Reply
Old 04-20-2007, 03:24 PM   #8
Jeeper
 
Join Date: Apr 2007
Location: Arizona's White Mountains
Posts: 227
Quote:
Originally Posted by bigbuck1566 View Post
the auto shut off relay was making a fast clicking sound after the jeep stopped running, the fuel pump works also, I have gas at and pressure at the test port, I do not have a spark from the coil. This has been a problem for a while, I would leave the key on for a minute and then the relays would click and the pump would run for a few seconds and stop and it would start right upand run great, untill I shut it off. If I tried to start it within a few minutes it work run great,leave it for more than a few minutes and I would have to wait for 5 minutes or more for the pump to start again. now it will not do anything. And by the way its a 1994 se with 2.5 Thanks Joe
When my jeep started doing that I found it was in the distributor. The ignition control unit would start and run from cold, but would not restart after being driven. Eventually it just shorted out internally and left me stranded. They run around $35 and just plug and unplug.
Grandpa Jeeper is offline   Quote Quick Reply
Old 04-20-2007, 06:04 PM   #9
Newb
 
britton's Avatar
 
Join Date: Apr 2007
Posts: 8
Smile

Just to put my issue to rest. After some work with the schematics it turns out my computer failed.

The fuel relay was not getting a ground from the computer. The computer also controls the 2 second fuel pump run before starting which had stopped working. Other options were a shorted MAP, throttle position, or distributor sensors that would have confused the computer. In my case the sensors were okay and it was the computer itself that quit.

-Britton
britton is offline   Quote Quick Reply
Old 04-28-2007, 08:56 PM   #10
Newb
 
Join Date: Apr 2007
Posts: 12
Britton, Is the computer on the fire wall by the master brake cylinder? I have changed out the "cps" and still will not start. How much is a computer?
Thanks Joe
bigbuck1566 is offline   Quote Quick Reply
Old 04-30-2007, 07:28 AM   #11
Supporting Member

WF Supporting Member
 
daddyjeep's Avatar
 
Join Date: Apr 2005
Location: Smethport, PA
Posts: 2,572
The unit by you master cylinder is the ignition control module. Like grandpa Jeeper said, you can get this for about 30 bucks. Your computer will be under the dash behind the glove box and will cost more.
__________________
87 YJ, 5.2/46RH/NP231, Custom 4 link/ Radius Arms, Ballistic Nitrogen Shocks, 35" Cooper STT
DaddyJeep build Thread:http://www.wranglerforum.com/f8/dadd...ld-122601.html
daddyjeep is offline   Quote Quick Reply
Old 04-30-2007, 09:06 AM   #12
Newb
 
Join Date: Apr 2007
Posts: 12
Thanks daddyjeep

bigbuck1566 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Takes forever to start.. Mike2000 General Jeep Discussion 7 04-10-2011 11:42 AM
FAQ's-jeep wont start! speepdaedeesi TJ Tech Forum 20 05-30-2010 12:28 AM
wierd start up in am BigaAl TJ General Discussion Forum 0 12-25-2008 09:03 PM
wont start? snowmanzz13 YJ Tech Forum 10 04-14-2008 01:14 PM
How flammable is a tj? (My jeep doesnt start) lost TJ Tech Forum 20 02-22-2008 08:15 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:43 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC