Oil pressure...again - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-18-2013, 09:37 AM   #1
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 231
Oil pressure...again

So my jeep seems to be running fine, but the oil pressure gauge is pinned above 80. Normally it runs a little high but it's never been pinned. It's a little disconcerting, any thoughts?

ddferdt is offline   Quote
Old 05-18-2013, 09:55 AM   #2
Jeeper
 
wwch99tj's Avatar
 
Join Date: Mar 2011
Location: Felton Delaware
Posts: 5,014
The oil pressure sender unit is bad.

wwch99tj is offline   Quote
Old 05-18-2013, 09:59 AM   #3
Jeeper
 
ddferdt's Avatar
 
Join Date: Mar 2013
Location: Long Island, New York
Posts: 231
That doesn't necessarily mean the pump itself is bad though?
ddferdt is offline   Quote
Old 05-18-2013, 10:19 AM   #4
Jeeper
 
Jerricho's Avatar
 
Join Date: Oct 2011
Location: Layton UT
Posts: 218
There is no jump technically. The sending unit is just out, so the gauge is getting more voltage than it should. The oil pressure itself is not spiking.

They are pretty easy to change, $15 at AutoZone, and probably 15 minutes to swap it out. If you are due for an oil change that makes it even easier, because you don't have to worry about doing the quick swap.
__________________
If you choose to say "plz" because it is shorter than "please" I choose to say "no" because it is shorter than "yes".
Jerricho is offline   Quote
Old 05-18-2013, 11:43 AM   #5
Jeeper
 
Join Date: Feb 2013
Location: Idabel, Ok
Posts: 76
Mine did the same thing. Like they said the sending unit is bad its an easy fix.
Dac7529 is offline   Quote
Old 05-18-2013, 01:01 PM   #6
Jeeper
 
Bladeski's Avatar
 
Join Date: Mar 2011
Location: Raleigh NC
Posts: 73
Yes it is the sending unit-but get it fixed right away. Mine was pinning over 80 for a week because the mechanic wasn't worried about it. Then I smelled burning oil. Sending unit just plain broke off and sent oil everywhere.

__________________
Each time you jump in, it's like a vacation! But what's that new noise!!!
Bladeski is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC